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Preface

» About This Guide

» Change History

» Related Documents

» Communications, Services, and Additional Information
» Field Alerts and Field Notices

» Documentation Feedback

» Document Conventions



Welcome to the Enterprise Chat and Email (ECE) feature, which provides multichannel interaction software
used by businesses all over the world as a core component to the Unified Contact Center Enterprise product

line. ECE offers a unified suite of the industry’s best applications for chat and email interaction management
to enable a blended agent for handling of web chat, email and voice interactions.

About This Guide

Enterprise Chat and Email Installation and Configuration Guide is intended for installation engineers,

system administrators, database administrators, and others who are responsible for installing and configuring
Enterprise Chat and Email (ECE) installations that are integrated with Cisco Unified Contact Center

Enterprise (Unified CCE).

The best way to use the installation guide is to print it, read the entire guide, and then start at the beginning
and complete each pre-installation, installation, and post-installation task, in sequence.

Change History

This table lists changes made to this guide. Most recent changes appear at the top.

Change

See

Date

Added a note about restarting
ECE.

“Starting ECE” on page 103

Added the Load Balancer
Configuration Examples.

“Load Balancer Configuration
Examples” on page 25

Added information about some
tasks that need to be performed
before configuring the SAL
Server Always On Availability
Groups.

“Configuring SQL Server Always
On Availability Groups” on
page 166

March, 2024

Replaced CCE Call Server with
CCE Peripheral Gateway in the
following steps:

> Step 1 & Step 8

> Step 1 & Step 6

“Adding MR PIM for ECE” on
page 74 & “Adding Agent PG PIM
for ECE” on page 75

“Adding CTI for ECE” on page 76

February, 2024
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Change

Updated the Field Name and
Description for the following:

» Enterprise Chat and Email
Home Directory

» File Server Parameters

See

“File Server Details” on page 84

“Database Server Details” on
page 85, “Messaging Server
Details” on page 92,“Application
Server Details” on page 93 &
“Services Server Details” on
page 94

Date

October, 2023

Updated the note about the
conditions when Reports Data
Utility can be run.

“Run reports DB utility to
configure secondary nodes” on
page 169

August, 2023

June, 2023

Added information about port “Configuring Port Numbers
requirements for Application Between Components” on
Server to 1dS Servers & IdP page 35
(ADFS) Servers connectivity.
Updated the SQL database jobs “Stopping ECE Application and May, 2023
names Disable SQL Jobs.” on page 175
& “Starting the SQL Jobs and
ECE Application” on page 177
Added a note about manually “Configuring Expanded Call March, 2023
adding the ECC variables when Context (ECC) Variables” on
multiple payloads are configured. | page 70
Added a note about not changing | “Context Root Name” on page 85 | March, 2023

the value of the context root
name in the ECE/ eGain
application URL.
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Change

Updated the steps for
Configuring Cluster Quorum
Settings.

Added a new section:
Configuring Permissions for the
File Share Witness Folder

See

“Configure Cluster Quorum
Settings” on page 165

“Configuring Permissions for the
File Share Witness Folder” on
page 164

Date

February, 2023

Updated Step 5

Changed the occurrence of
Cisco__Hometo ECE _Hometo
maintain consistency all across
the document

“Configuring SQL Server Always
On Availability Groups” on
page 166

Added a new section: Changing
the Service Account Password

“Changing the Service Account
Password” on page 41

» Added a note about upgrading
the SQL version.

» Added information about
creating new home
directories.

» Added a cross reference to
Appendix A.

Added a new item to the
checklist about updating the
External URL of Application.

“Converting Existing Two Server
Installation to HA” on page 173

“Converting Databases to SAL
Server to Always On
Configuration” on page 174

Updated Step 2.

“Backing up and Restoring
Databases” on page 176

Added a note about using a load
balancer for a VPN less ECE
environment.

“Load Balancing Considerations”

on page 25
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Change

Added two new sections:

> For 401-2500 Agent
Deployments

» For 401-2500 Agent
Deployments (HA)

Provided the file name for the

Virtual Machine template for 401-

2500 agent deployments

Changed the following headings:
» For 400 Agent Deployments to
For Collocated Deployments
» For 401-1500 Agent
Deployments to For Fully
Distributed Deployments

See

“For 401-2500 Agent
Deployments” on page 81

“For 401-2500 Agent Deployments
(HA)” on page 81

“Download OVA for ECE” on
page 32

“For Collocated Deployments” on
page 28

“For Fully Distributed
Deployments” on page 29

Date

November, 2022

Provided the requirements to
install ECE components for fully
distributed deployments.

Added a new section: Run the
UpdateDBIndexStats Utility

Added a new section: Additional
Configuration for Multi-subnet
Availability Group.

Provided correct information for
installing additional web server
components.

“For Fully Distributed
Deployments” on page 29

“Run the UpdateDBIndexStats
Utility” on page 170

“Additional Configuration for
Multi-subnet Availability Group”
on page 167

“Installing Additional Web Server
Components” on page 179

Added more information about
installing web servers.

“Installation Overview” on
page 79

.NET Extensibility 4.6 has been
replaced with .NET Extensibility
41.

“Configuring Roles and Features”
on page 48

Removed the Modifying N/A
Connpool File section from

Appendix A: Convert Existing
Deployment to HA.

Removed the following topic: N/A

Enable PowerShell Remote
Commands from the Pre-
Installation Tasks.

Added a note about when to run
the Reports Database utility.

Added the location of the
settings.

“Running the Reports Database
Utility” on page 169

“Mandatory Settings” on
page 108

October, 2022
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Change See Date
Added a new section: “Configuring Clickjacking September, 2022
Clickjacking Protection. Protection” on page 109
Added information regarding the | “Configuring Port Numbers
Services server to Application Between Components” on
server connectivity. page 35
Added a note about creating a “Configuring SQL Server Always
new endpoint while setting up a On Availability Groups” on
new availability group. page 166
» Updated the description of the | “Database Server Details” on
Server instance name and the | page 85
Database listener port fields
for the following tables:
Master Database Parameters
and Active Database
Parameters.
» Updated the description of the
Database server instance and
the Database listener port
fields for the Reports
Database Parameters table.
Provided the format to run the “Configuring Permissions on
command when the Listener Active Directory Server” on
Name is used instead of the page 38
Sever name.
Updated the steps and image for | “Creating a Database User on July, 2022
creating a database user on ECE | ECE Reports Database” on
Reports database. page 110
Removed the occurrence of “Running Services” on page 47
Distributed Transaction
Coordinator Service as it is not to
be run under the service
account.
Updated screenshots for all the “Binding the Certificate to the June, 2022
steps. Application Website” on
page 144
Added a note about the retry “Planning Services Servers” on
mechanism for failover page 24
processes.
Added information about “Uninstalling ECE” on page 111 February, 2022

manually deleting components
after Uninstalling ECE.

Added information regarding
dependency of Filer server and
Database server installation.

“Installation Overview” on
page 79

December, 2021

Updated the settings name.

“Mandatory Settings” on
page 108

November, 2021
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Change

Updated the steps for Integrating
ECE with Unified CCE.

Added step to verify NIC
configuration in Pre-Installation
Tasks chapter.

Clarified steps regarding the
modification of the Connpool file.

Added the health check URL for
ECE web-app pair.

Added a new section:
Configuring Memory Settings.

Removed all references to SAL
Server Integration Services
(SSIS).

See

“Integrating ECE with Unified
CCE” on page 105

“Verifying Network
Configuration” on page 34

Modifying Connpool Files

“Load Balancing Considerations”

on page 25

“Configuring Memory Settings”
on page 44

N/A

Date

October, 2021

September, 2021

August, 2021

July, 2021

Related Documents

The latest versions of all Cisco documentation can be found online at https://www.cisco.com

Subject

Complete documentation for Enterprise
Chat and Email, for both Cisco Unified

Link

https://www.cisco.com/c/en/us/support/customer-collaboration/cisco-
enterprise-chat-email/tsd-products-support-series-home.html

Contact Center Enterprise (UCCE) and Cisco
Packaged Contact Center Enterprise (PCCE)

Communications, Services, and Additional

Information
» To receive timely, relevant information from Cisco, sign up at Cisco Profile Manager.
» To get the business impact you’re looking for with the technologies that matter, visit Cisco Services.
» To submit a service request, visit Cisco Support.
» To discover and browse secure, validated enterprise-class apps, products, solutions and services, visit
Cisco Marketplace.
» To obtain general networking, training, and certification titles, visit Cisco Press.
» To find warranty information for a specific product or product family, access Cisco Warranty Finder.
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http://www.cisco.com
https://engage2demand.cisco.com/LP=6097?oid=pcuxa003033
https://www.cisco.com/c/en/us/services/overview.html
https://www.cisco.com/c/en/us/support/index.html
https://marketplace.cisco.com/home
http://www.ciscopress.com/
https://connectthedots.cisco.com/connectdots/serviceWarrantyFinderRequest?fl=wf

Cisco Bug Search Tool

Cisco Bug Search Tool (BST) is a web-based tool that acts as a gateway to the Cisco bug tracking system
that maintains a comprehensive list of defects and vulnerabilities in Cisco products and software. BST
provides you with detailed defect information about your products and software.

Field Alerts and Field Notices

Cisco can modify its products or determine key processes to be important. These changes are announced
through use of the Cisco Field Alerts and Cisco Field Notices. You can register to receive Field Alerts and
Field Notices through the Product Alert Tool on Cisco.com. This tool enables you to create a profile to
receive announcements by selecting all products of interest.

Sign in www.cisco.com and then access the tool at
https://www.cisco.com/@isco/Support/dotifications.html.

Documentation Feedback

To provide comments about this document, send an email message to the following address:
contactcenterproducts_docfeedback @cisco.com

We appreciate your comments.

Document Conventions

This guide uses the following typographical conventions.

Convention Indicates

Italic Emphasis.
Or the title of a published document.

Bold Labels of items on the user interface, such as buttons, boxes, and lists.

Or text that must be typed by the user.

Monospace The name of a file or folder, a database table column or value, or a command.

Variable User-specific text; varies from one user or installation to another.

Document conventions
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ECE can be installed in multiple configurations, ranging from a simple collocated installation, to many flavors of
distributed installations. This chapter lists the components that make up ECE deployment and available
configuration options. It also helps you plan your installation.

Identifying Components

All ECE installations have the following six components:
» File Server Component

» Database Server Component

» Messaging Server Component

» Application Server Component

»  Web Server Component

» Services Server Component

File Server Component

The file server is used to store application files, reports templates, and reports output files. In non HA
environment, there is only one file server in a deployment. HA deployments use DFS.

Database Server Component
All ECE databases are created on the database server. The installation program creates the following databases:
» A master database, that stores system configuration information to manage services.

» An active database, where all business and interaction data is stored. This is also referred to as the partition
database.

» A reports database, where all data used by the reports module is stored.

The master and active databases are installed on the same instance. The reports database can be installed on a
different instance.

Messaging Server Component

The messaging server provides a centralized location for the exchange of information asynchronously among
various components of ECE application through the sending and receiving of messages.

For example,

» The application server publishes a message to the workflow cache process to refresh its cache when a user
modifies a workflow in the Administration Console.

A deployment can have a cluster of messaging servers.
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Components that use messaging are listed in the following table.

Component Use

Email Workflow > The Workflow Assignment Service publishes a message to application servers when a
new email is assigned to a user.

» The application server publishes a message to Workflow Cache Service when any
workflow is created or modified from the Administration Console. The Workflow Cache
Service publishes a message to the Workflow Service after it rebuilds its cache.

Email Retriever and The application server publishes a message to the Retriever and Dispatcher Services when an
Dispatcher email alias is created or modified from the Administration Console.
Miscellaneous » The Scheduler Service publishes a message to the Reports Service when the schedule for

a report fires.

> The application server publishes a message to the Distributed Services Manager (DSM)
whenever an agent logs in to or logs out of the application.

> The application server publishes a message to all other application servers and services
when a Custom attribute is created from the Tools Console.

> The application server publishes a message to other application servers every time an
article or topic is added, modified, or removed.

Application Server Component

The application server houses the business logic responsible for interactive responses to all user-interface
requests—across all classes of users including customers, agents, administrators, knowledge authors, system
administrators. It handles requests for operations from a user (the web client), interprets user requests and
delivers responses as web pages, constructed dynamically using JSP (based on the user request).

A deployment can have more than one application server. The number of application servers in a deployment
will depend on the amount of user load to be handled. For details about sizing, see the Enterprise Chat and
Email Design Guide.

Web Server Component
The web server is used to serve static content to the browser.

It gets requests from, and serves static content such as images, java applets, and client-side JavaScript code to a
web browser. All dynamic requests are routed to the application server for further processing and generation of
dynamic content. The web server component is always installed on a separate VM.

Installing the web server does not need access to any other ECE component. The web server can be installed
outside firewall. A deployment can have multiple web servers, with a one-to-one mapping between a web server
and an application server. The web servers can be separated from their corresponding application servers across
a firewall.

No user identification is required at the web server. Access to the application functionality is controlled at the
application server layer.
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Services Server Component

ECE has processes that perform specific business functions, such as fetching emails from a POP3 or IMAP
server, sending emails through an SMTP server, processing workflows, assigning chats to agents, etc. All

services run on the services server and are managed by the Distributed Service Manager (DSM). Framework
services that manage these remote services also run on the services server.

A deployment can have two services servers.

Understanding Deployment Models for ECE

With its modular, component-based architecture ECE caters effortlessly to the growing demands for increased
concurrent user loads. To provide the flexibility to suit deployments of varied sizes, ECE supports components
that may be distributed across various servers in a deployment. This section provides details of the possible
deployment options.

» Collocated Deployment for ECE: The web server is installed on a separate VM and all other components

are installed on one VM. The web server may be installed outside the firewall, if required.

Distributed-server deployment: Components are distributed over two or more servers. A wide range of
options are available for distributed-server deployment. The database is usually installed on a dedicated
server, and the other components are installed on a separate server or spread over two Or more Servers.

Collocated Deployment for ECE

The web server is installed on a separate VM outside the firewall.

Firewall

Database Server
File Server
Application Server —— Web Server

=
Messaging Server ? ?
Services Server u’;‘

Collocated deployment for ECE

Distributed-Server Deployment

In this configuration, each component is on a separate VM, with the web servers installed outside the firewall.

The application, messaging, services, and web servers in this configuration can be restarted without restarting
any other servers.
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» Multiple web-application server pairs are used with a load balancer.

ﬂ =

=

(1]

File o
Server

Database L )
Server with [~= Application
Master and g‘ Server

Active DBs == n

I Messaging

)

~=

<=
Web ‘
Server @
Server

Database | _—— |ﬂ <
Server with [~== Application Web ‘ ||
ReportsDB §1 A { Server Server @

-
W

Load Balancer

\A

Services
Server

E

Complex distributed-server configuration

Planning Components for Specific Configurations and
High Availability

Planning the File Server

» Use Windows Distributed File System to achieve high availability for the File Server. For details about
Windows Distributed File System, refer the Microsoft documentation: https://docs.microsoft.com/en-
us/windows/desktop/dfs/distributed-file-system

Planning the Database Server

Installing the Application on a SQL Server 2019 Cluster

» ECE can be installed in a Microsoft SQL Server 2019 clustered environment using the Always On
Availability Group cluster option to achieve high availability. To install and configure the SQL Server
cluster, follow the instructions in the Microsoft SQL Server 2019 documentation.

Things to note:
O Clustering feature is available only for Enterprise Edition of MSSQL.

O  When using Always On Availability Group clustering, you must use the Windows Authentication
mode.
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Planning Database Server Distribution

4

The master and active databases are installed on the same database server. The reports database can be
installed on the same instance as the master and active databases or on a different instance.

If the reports database is to be installed on a different instance, make sure that you complete the steps
described in the “Configuring Database Servers” on page 44. You may also need to complete certain tasks
described in “Setting Up User Accounts and Permissions” on page 37.

Planning Messaging Servers

4

ECE can be installed with a cluster of messaging servers to achieve high availability. After deploying the
cluster, when the application is started, it connects to one messaging server in the cluster. If at any time that
messaging server goes down, the application connects to the next available messaging server in the cluster.

For 400 Agent deployments, the messaging server component is collocated with other components. For
400+ agent deployments, the messaging server component is always installed on a dedicated VM.

If the messaging server is on a separate VM, it can be restarted independently, without affecting application
usage.

Planning Services Servers

4

For high availability support, you can install two services servers. When the application starts, one server
will become primary services server and other server will be secondary services server. The ECE application
will need to be started on both the services servers, however, all the service processes (for example, retriever,
dispatcher, etc.) will run only on the primary services server.

All service processes will automatically failover to the secondary services server when the primary server is
unavailable because of network connection failure or hardware issues. You can identify the primary services
server from the System Console of the application. For details, see the Enterprise Chat and Email
Administrator’s Guide to System Console.

@ Important: While initiating a failover when the connection to the database is down, the

% service processes will automatically run a retry mechanism every 10 seconds for an interval
period of 30 seconds, thereby allowing the server to re-run the failover process for a maximum
of three times. If the connection establishes within the defined interval period, services start
successfully on the failed over services server.

Planning Application Servers

4

ECE can be installed with multiple application servers to achieve high availability. The number of
application servers in your deployment depends on the total number of concurrent agents to be supported.

If any of the application servers go down, a load balancer can help handle the failure through routing
requests to alternate application servers through the web server.
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Planning Web Servers

» ECE can be installed with multiple web servers. The number of web servers in a deployment depends on the
number of application servers in the deployment.

If any of the web servers go down, a load balancer can help handle the failure through routing requests to
alternate web servers. The load balancer detects web server failure and redirects requests to another web
server.

Load Balancing Considerations

» A load balancer may be used in a distributed installation of the application so that requests from agents and
customers are either routed to the least-loaded web servers, or evenly distributed across all the available web
servers. Please note that it is mandatory to use a load balancer for a VPN less ECE environment to ensure
that agents working remotely without a VPN can seamlessly log into the system.

While the application is agnostic to the particular brand of load balancer used in the configuration, it does
require that the load balancer is configured to support “sticky sessions” with cookie-based persistence.

Use the following URL to do the health check of the ECE web-app pair:
https://<Webserver URI>/system/web/view/platform/common/login/root.jsp?partitionl
d=1.

Load Balancer Configuration Examples

Here are some essential configurations required on the load balancer. Please note that these are specific examples
tied to a particular load balancer and are provided for reference purposes only. Similar configurations should be
applied to the load balancer being used.

Cookie Persistence Configuration

This configuration enables the load balancer to generate cookies during the initial request and utilize them for
session stickiness in subsequent requests.

Target selection configuration
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Request Routing Configuration

This configuration aims to distribute the session load evenly across available nodes (web servers), with round
robin being the recommended method, though not the only option.

Edit target group attributes

Edl‘t target gl’OUp attributes Info Restore defaults

Target deregistration management

Deregistration delay (draining interval)
The ti it for in-fligh while deregistering a t

300 seconds

Traffic configuration

ou must turn on Anomaly mitigatior

seconds

ted random routin,
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Health Check Configuration

This involves load balancer monitoring to detect the operational status of the nodes.

Planning for High Availability Across Geographies

4

Health checks

Edit health check settings

Edit health check settings

The associated load balancer periodically sands requests, per the settings below, to the registered targets to test their status.

Health check protocol

HTTPS v

Health check path

4 cha

¥ Advanced health check settings

Health check port

® Traffic port

Override

Healthy threshold

Unhealthy thre:
The n

2

Timeout
The amou
29 seconds

Interval
The

30 seconds

Success codes
The HT
rani

Restore defaults

To achieve high availability across geographies, ECE can be deployed across two different geographical
locations. The load balancer needs to be configured so that at any given point of time, all requests are

redirected to web servers in one location.
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For Collocated Deployments

For details about installing these servers, see “Installation Process” on page 78.

Data Center 1 Data Center 2
l.....]

Virtual Server with one IP
Load Balancer Load Balancer

4 A

DMz DMz

Weh.-ServeM Web. Server 2

App Server 1 App Server 2

Primary Services

Secondary Services
Server &

Server

Messaging Cluster

Windows Server Failover Clustering (WSFC) Cluster
using AlwaysOn Availability Groups

i NodetsaL : ! NodezsaL i
: Server : : Server

Instance i i Instance

S

ittt :1:'_":'____]._|__ _|_.| ______________ __

I Windows Distributed File System 1

All'in one box 1 All'in one box 2

High Availability Across Geographies

In this deployment, the ECE components are installed on four VMs:

» On Side A:

O VM-1A: File server (Windows Distributed File System Nodel), Database server (Always On
Availability Group), Messaging server, Application server, Services server

o VM-2A: Web Server
» On Side B:

O VM-1B: File server (Windows Distributed File System Node2), Database server (Always On
Availability Group), Messaging server, Application server, Services server

o VM-2B: Web Server
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For Fully Distributed Deployments

For details about installing these servers, see “Installation Process” on page 78.

DMz

Data Center 1 Data Center 2

Load Balancer one B Load Balancer

< >

T e B

Web Server1  Web Server 2 Web Server 3  Web Server 4

DMz

App Server 1 App Server 2 App Server 3 App Server 4

Primary Services Server Secondary Services Server

Messaging Cluster

Windows Server Failover Clustering (WSFC) Cluster
using AlwaysOn Availability G

Node 1 Node 2 Node 3 Node 4
SQL Server SQL Server SQL Server SQL Server
Instance Instance Instance Instance

o

Windows Distributed File System

High Availability Across Geographies

In this deployment, following are the requirements to install the ECE components::

1.

2.
3.

30 VMs for 1500 Agents (No change in existing 12.6 OV As)

18 VMs for 1500 Agents (with new OV As specifications as provided with ECE 12.6 ES3)
22 VMs for 2500 Agents (with new OV As specifications as provided with ECE 12.6 ES3)
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» On Side A:
O VM-1A: File server (Windows Distributed File System Nodel)
O VM-2A: Database server (active and master databases)
O VM-3A: Database server (reports database)
O VM-4A: Messaging server
O VM-5A: Services server
O  VM-6A to VM-10A: Application server
O VMA-11A to VM-15A: Web Server

» On Side B:
VM-1B: File server (Windows Distributed File System Node 2)

VM-2B: Database server (active and master databases)

o
0
O VM-3B: Database server (reports database)
O VM-4B: Messaging server

o)

VM-5B: Services server

O  VM-6B to VM-10B: Application server
O VM-11B to VM-15B: Web Server

Installing ECE

» Follow the pre-installation tasks (page 31), installation tasks (page 78), and post-installation tasks (page 95),
to install ECE. To set up SSL, follow instructions in the “SSL Configuration” on page 139.
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Pre-Installation
Tasks

Preparing Virtual Machine

Disabling Loopback Adapter Configuration
Verifying Network Configuration

Configuring Port Numbers Between Components
Setting Up User Accounts and Permissions
Changing the Service Account Password
Preparing Database Server VMs

Preparing Web Server VMs

Configuring Virus Scanners

Verifying Unified CCE Configuration



This chapter describes pre-installation procedures that need to be completed before beginning the installation
process. As you need to prepare the installation environment in advance, read this installation guide and the
following documents before planning and implementing the installation:

»  System Requirements for Enterprise Chat and Email

»  Enterprise Chat and Email Design Guide

Preparing Virtual Machine

Obtain Installation Media

» Obtain the ECE installation media from a partner or by ordering from Cisco Systems, Inc.

Download OVA for ECE

1. Go to the Enterprise Chat and Email - 12.6(1) Download Software page:
https://software.cisco.com/download/home/268439622/type/286310764/release/12.6(1)

2. Download the Virtual Machine Templates file for the release. You can download:
O  For upto 400 agents: ECE_12.6_400_Win2019_vmv13_v1.0.ova
O  For 401-1500 agents: ECE_12.6_1500_Win2019_vmv13_vl1.0.ova
O  For 401-2500 agents: ECE_12.6_2500_Win2019_vmv13_v1.0.ova

This is only available from ECE 12.6 ES3 onwards.

3. Save the OVAs to your local drive.

Create Virtual Machines from the OVA

» Follow the VM Ware documentation to create virtual machines from the OVA. To determine the datastore on

which to deploy the new virtual machine, see the Cisco Contact Center Enterprise Installation and Upgrade
Guide.

Install Microsoft Windows Server

» Follow the Microsoft documentation to install Microsoft Windows Server 2019. While installing, make sure

you select the Custom: Install Windows only (advanced) option, and select Drive O to install Microsoft
Windows Server.

Install VMware Tools

» Follow the VMWare documentation to install the VMWare tools from the VMware vSphere Client. While
installing, make sure you choose the Typical installation option.
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Mounting and Unmounting ISO Files

To upload ISO image to data store:

1.

2
3
4,
5

Select the host in the vSphere client and click Configuration. Then click Storage in the left panel.
Select the datastore that will hold the ISO file.

Click Browse this datastore.

Click the Upload icon and select Upload file.

Browse to the location on your local drive where you saved the ISO file, and upload the ISO to the datastore.

To mount the ISO image:

1.

2
3
4,
5
6

Right-click the VM in the vSphere client and select Edit virtual machine settings.
Click Hardware and select CD[DVD Drive 1.

Check Connect at power on (Device status panel upper right).

Click the Datastore ISO File radio button and then click Browse.

Navigate to the data store where you uploaded the file.

Select the ISO.

To unmount the ISO image:

1.
2.
3.

Right-click the VM in the vSphere client and select Edit virtual machine settings.
Click Hardware and select CD|DVD Drive 1.

In the Device status panel, uncheck Connect at power on.

Verifying Signature File for ISO

To verify the signature file for ISO:

1.

Download and install openssl from https://slproweb.com/products/Win320penSSL.html
Any type of installer (either EXE or MSI) with any bit (32 or 64) can we downloaded from the link.

Install the download openssl using the instructions provided on the website. Have the openssl path added to
the system path environment variable so that openssl command can be launched from any path.

Place the downloaded ISO image, ISO image signature file, and the public key.der from CCO in the same
folder.

o ECE_12.6_Fresh.iso.signature
o ECE_12.6_Fresh.iso
O ReleaseCodeSign_publicKey.der

Launch the command prompt by right-clicking and choosing Run as administrator.

Execute the cli command in the command prompt to verify the authenticity and integrity of the CCO
downloaded ISO.
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Syntax: Openssl dgst -sha512 -keyform der -verify <Wédc/<@/.dw> -signature <50
Maﬁ&z)ﬂ).ﬂ'ﬁﬂatwe> <ISO Imaﬁ(»

For example: Openssl dgst -sha512 -keyform der -verify
ReleaseCodeSign_publicKey.der -signature ECE_12.6_Fresh.iso.signature
ECE_12.6_Fresh.iso

Upon successful verification output will be Verified OK and on failure Verification failed.

Disabling Loopback Adapter Configuration

ECE cannot be installed on VMs where Microsoft Loopback Adapter is configured. Before you proceed with the
installation, disable Loopback Adapter configuration on all VMs in the deployment.

Skip this section if the VMs in the configuration do not use the Loopback Adapter.

To disable Loopback Adapter:

1.

2
3
4,
5

Go to Start > Control Panel.

In the Control Panel window, click Hardware.

In the Devices and Printers section, click the Device Manager link.

In the Device Manager window, go to Network adapters and locate Microsoft Loopback Adapter.

Right-click Microsoft Loopback Adapter and select Disable.

Verifying Network Configuration

These tasks must be completed in all configurations in which components are installed on more than one VM.

To verify network configuration:

1.
2.

Internet Protocol Version 6 (IPv6) must be disabled on all servers.

Ensure that all the VMs are either assigned static IP addresses, or in cases where the IP address is assigned
dynamically, are set to renew the same IP address upon lease expiration.

Ensure that all VMs other than the web servers, are in the same Active Directory domain. The web servers
do not need to be installed in the same domain as other Enterprise Chat and Email components. They can be
located anywhere, for example, in a DMZ. Note that the application cannot be installed in a workgroup.

Ensure that all the required inbound and outbound ports that need to be opened for the flow of requests
between the various components have been opened before you begin the installation. For details, see the
“Configuring Port Numbers Between Components” on page 35.

For messaging, application, and services servers the ns lookup of the IP addresses should map to the fully
qualified domain names of the servers. Similarly, the ns Lookup of the fully qualified domain names should
map to the IP addresses of those servers.

Ensure that all the VMs are in the same LAN.
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7. Ensure that the system clocks of all the VMs are synchronized.

8. Ensure that all the servers, except the web server, are able to communicate with the database server at the

time of installation.

9. If multiple NICs are configured on ECE servers, set NIC metrics for each NIC. The lowest (default) metric
must be assigned to NIC that will be used for the ECE application.

Configuring Port Numbers Between Components

This section describes the ports that need to be opened for the flow of requests between the various components.
The following diagram shows the ECE system architecture. This will help you understand the communication

between the different components.
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The following table lists the inbound and outbound ports that need to be opened for the flow of requests between
the various components. The default port numbers are listed here. Ports that can be modified at the time of
installation, or by editing property files are identified with an asterisk (*).

From Server To Server Default Destination Ports and Protocols
Agent Workstation (Internet) Web Server » 80 [Protocol: HTTP]

» 443 [Protocol: HTTPS]
Finesse Desktop (Internet) Web Server » 80 [Protocol: HTTP]

» 443 [Protocol: HTTPS]

Application Server

Application Server

Application Server

Services Server

File Server

Database Server

» 15099 (RMI Registry port) [Protocol: RMI]*

» 49152 — 65535 (Dynamic port range used by RMI server
objects) [Protocol: TCP]

139 or 445 [Protocol: NETBIOS - TCP]

1433 [Protocol: TCP] *

Application Server

Application Server

Messaging Server

Application Server

15097 [Protocol: TCP] *

» 2434 [Protocol: TCP]*
» 6701 [Protocol: TCP]*

Application Server

SMTP Server

25 [Protocol: SMTP]

Application Server

SMTP or ESMTP Server (with SSL
enabled)

587 [Protocol: SMTP or ESMTP]

Application Server

Application Server

IMAP Server

IMAP Server (with SSL enabled)

143 [Protocol: IMAP]

993 [Protocol: IMAP]

Web Server

Application Server

9001 [Protocol: TCP]*

Messaging Server

Messaging Server

File Server

Messaging Server

139 or 445 [Protocol: NETBIOS - TCP]

15097 [Protocol - TCPJ*

Messaging Server

Database Server

1433 [Protocol: TCP]*

Services Server

Services Server

Application Server

File Server

6701 [Protocol: TCP]

139 or 445 [Protocol: NETBIOS - TCP]

Services Server

Database Server

1433 [Protocol: TCP] *

Services Server

Services Server

Messaging Server

Services Server

15097 [Protocol: TCP]*

47500 [Protocol: TCP]*

Services Server

SMTP or ESMTP Server

25 [Protocol: SMTP or ESMTP]

Services Server

SMTP or ESMTP Server (with SSL
enabled)

587 [Protocol: SMTP or ESMTP]

Services Server

Services Server

POP3 Server

POP3 Server (with SSL enabled)

110 [Protocol: POP3]

995 [Protocol: POP3]
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From Server To Server Default Destination Ports and Protocols

Services Server IMAP Server 143 [Protocol: IMAP]
Services Server IMAP Server (with SSL enabled) 993 [Protocol: IMAP]
Active Database Server File Sever Not applicable

Reports Database Server Active Database Server » 1433 [Protocol: TCP]*

» 135 [Port for Remote Procedure Call (RPC)]

» 5000-5020 (Port range for RPC ports required for
MSDTC to work across firewall)

Services Server Primary CTI Server 42027*
Services Server Secondary CTI Server 42028*
Services Server Media Routing Peripheral Gateway | 38002*
Services Server Primary Administration 1433 [Protocol: TCP]*

Workstation Database

Application Server Primary Administration 1433 [Protocol: TCP]*
Workstation Database

Application Server IdS Servers 443 & 8533

Application Server IdP (ADFS) Servers 443

Setting Up User Accounts and Permissions

You will need administrator privileges on the local system to perform the installation and run the ECE services
after installing the application.

@ Important: For all servers other than the ECE web server, you must use the same domain ac-

3 count to install the software environment and ECE. ECE web server can be installed in DMZ and
can have a different domain account. Use the service account to run the ECE services after in-
stalling the application (page 103).
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Setting Up Domain Account

» Request your IT department to create the following accounts. Make sure the passwords for these accounts
are not more than 30 characters. You will not be able to install the application, if the passwords exceed this
limit.

Caution: The recommendation is that you do not change the password of the Service Account
@ and SQL Services Account after the application is installed. If you must change it, make sure

that you update the login information for: all Windows and MSSQL services that use these

accounts and in IIS for: the Default and context Root folders under IIS > Sites > site for ECE.

Account Type Description Privileges Required

Installation Account You will use this account to install ECE. This can be an existing Administrator
user with Administrator privileges on the server.

This account, or any other account with same privileges can be
used in future to install ECE updates and do version upgrades.

Note: Password of this user account should not contain blank
spaces, single quotes, and double quotes.

Service Account This account is used to run the ECE Windows service after Log on as Service
installing the application.

This is an exclusive user for use by the ECE application.

SOL Services Account Dedicated domain user account for configuring and running SQL Log on as Service
server services.

This is an optional account. You would create this account If you
do not want the Service account to be used for running SQL
services.

This is an exclusive user for use by the ECE application.

Manage Services Account | This account is used to start and stop the ECE service. This can be | Manage Service
a local user or domain user.

This can be an existing user with Manage Service privileges on
the server.

Configuring Permissions on Active Directory Server

If you are using Windows authentication database connectivity, or the configuration includes more than one
database server VMs, perform these additional tasks on the Active Directory server. You will need administrator
privileges to complete these tasks. Contact your IT administrator for assistance if required.

To configure permissions:

1. Go to Start > Run > Command to launch the command window and run the following command. This sets
the Service Principal Names (SPN) to the domain account for MSSQL service on the database servers.

setspn -A MSSQLSvc/HOST:PORT accountname
setspn —A MSSQLSvc/HOSTinstancename accountname

Run this command for both short and fully qualified host names for all database servers. Use the SQL
Services Account for these tasks. If you did not create one, use the Service Account (page 37). For example,
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if there are two database servers, serv234 and serv235, with instance name as MSSQLSERVER and port as
1433, with the user account SQLSERVICEUSER in the domainl domain, then run the following commands.
If you are using Always On Availability Group clustering, then use the Listener Name (page 166) instead
of the server name.

setspn -A MSSQLSvc/serv234.company.na:1433 domain1\SQLSERVICEUSER

setspn -A MSSQLSvc/serv234.company.na:MSSQLSERVER domain1\SQLSERVICEUSER
setspn -A MSSQLSvc/serv234:1433 domain1\SQLSERVICEUSER

setspn -A MSSQLSvc/serv234:MSSQLSERVER domain1\SQLSERVICEUSER

setspn -A MSSQLSvc/serv235.company.na:1433 domain1\SQLSERVICEUSER

setspn —-A MSSQLSvc/serv235.company.na:MSSQLSERVER domain1\SQLSERVICEUSER
setspn -A MSSQLSvc/serv235:1433 domain1\SQLSERVICEUSER

setspn -A MSSQLSvc/serv235:MSSQLSERVER domain1\SQLSERVICEUSER

If you are using the Always On Availability Group clustering, then use the Listener Name (page 166)
instead of the server name in the following format:

setspn —-A MSSQLSvc/listener_hostname_FQDN:port_number SQL Service_Account.
For example, if there are two listeners with listener hostname FQDNs as listener1.egeng.info and
listener2.egeng.info and port as 1444, with the SQL service accounts as egeng\qeuser, then run
the following commands:

setspn -A MSSQLSvc/listener1.egeng.info:1444 egeng\qeuser

setspn -A MSSQLSvc/listener2.egeng.info:1444 egeng\geuser

Go to Start > Control Panel > Administrative Tools > Active Directory Users and Computers.

Navigate to the domain user account used for MSSQL service on the database servers. Right-click and select
Properties.

a. In the Properties window, click the Account tab. Ensure that the following options are not selected:
e Account is sensitive and cannot be delegated.

e Do not require Kerberos preauthentication.
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LRunner Properties 2l x|

Organization I Member OF I Dial-iry I Erwironment I Sessions
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General I Addiess  Account I Profile I Telephones I Delegation
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User logon name [pre-windowes 2000);
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Logon Hours... LogOnTo. I

™| &gcount s locked out

Account options:

[~ Smart card is required for interactive logan ;I
[~ Account is sensitive and cannot be delegated

[~ Use DES encryption types for this account

[~ Do not require Kerberos preauthentication ﬂ

—Account expires
& Meyver
€ Endof: [wiednesday, Januay 19, 2011 =l

(1] I Cancel I Apply I

Set account properties for domain user account

b. Click the Delegation tab. Ensure that the domain user account is trusted for delegation. For a more

secure configuration, you can select the Trust the user for delegation to specified services only
option and specify the service added in Step 1.

LRunnet Properties 2l
Organization I ember OF | Dialin I Envvironment I Sessions |
Remote control | Terminal Services Profile | COM+

General | Addiess | Account | Profile | Telephones  Delegation

Delegation iz a security-sensitive operation, which allows services to act on
behalf of another user.

Do nat tust this user for delegation

£ Trust this user for deleaation to any service [Kerberos anly)
™ Trust this user far delegation to specified services anly

& [Ise Kerberas only
) Use any authentication protacal
Semvices to which this account can present delegated credentials:

Service Type | User ar Computer | Port ‘ Service Mame | Dc

q | |
[ Expanded Add Remave

(1] I Cancel I Apply I

Set delegation properties for domain user account
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General I Operating System I Member OF
Delegation | Location | Managed By I Dialin

Delegation iz a security-sensitive operation, which allows services to act on
behalf of another user.

" Do nat tust this computer for delegation
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© Trust this computer for delegation to specified services only
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| [Use any authentication pratacal
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In the Active Directory Users and Computers tree, navigate to the database server. Ensure that it is trusted
for delegation. Repeat this step for each database server. For a more secure configuration, you can select the
Trust the user for delegation to specified services only option and specify the service added in Step 1.

oK I Cancel | Apply

Set delegation properties for database server

Changing the Service Account Password

To adhere to the organizational security policy, you must change the passwords at a periodic interval for the
following:

4

4

Web Server

Changing the Password

Application, Services and Messaging Server

To change the password for the Application, Services and Messaging server:

—

Now, open the File Explorer.

Restart the Cisco Service.

From the Windows Services Manager, stop the Cisco services.
Right click on Cisco Service and go to Properties.
In the Properties window, go to the Log On tab.

Specify the new service account password and click OK.

If there exists a mapped network drive e.g. 4, which is mapped to the ECE File Server installation directory,
disconnect it by right clicking on the drive.

To change the password for the Web server:

1.

Open the Internet Information Services (IIS) Manager.
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2. From the Connections pane, locate the website being used for ECE, for example, DefaMt Web Site.
3. Expand the website to see following virtual directories:

a. default

b. system
4. Configure the basic settings on all the virtual directories:

a. From the Actions pane, click the Basic Settings... button.

b. In the Edit Site window, click the Connect as... button.

c. In the Connect As window, select the Specific user option and click the Set... button.

d. In the Set Credentials window, provide the User name, and the new password in the Password and
Confirm password field.

5. Configure the advanced settings on all the virtual directories:
a. From the Actions pane, click the Advanced Settings button.
b. In the Advanced Settings window, select the Physical Path Credentials option.
c. In the Connect As window, select the Specific user option and click the Set... button

d. In the Set Credentials window, provide the User name, and the new password in the Password and
Confirm password field.

6. Restart IIS.

Setting up Distributed File System (DFS)

You need to perform this task if you are planning an HA deployment. For details, see “Appendix A: Distributed
File System Configuration” on page 155.

Preparing Database Server VMs

Install Microsoft SQL Server

Follow the Microsoft documentation to install Microsoft SQL Server 2019, Standard Edition or Enterprise
Edition. Make sure the required features for Microsoft SQL are installed on the VM and the collation settings are
configured properly.

Verifying Microsoft SQL Server Features
Ensure that the following Microsoft SQL Server features are installed.

» Instance Feature:

O Database Engine Services > Full Text and Semantic Extraction for Search
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» Shared Features
O Client Tools Connectivity
O Integration Services
O  Client Tools SDK
o SQL Client Connectivity SDK

Verifying Collation Settings

» Collation settings are typically chosen while installing SQL Server 2019. Since collations specify the rules
for how strings of character data are sorted and compared, based on particular languages, a particular type of
collation is required for the application to process and present information accurately.

On the Collation settings screen, choose the SQL Collation as SQL_Latinl_General_CP1_C1_AS and
select the following option: Dictionary order, case-insensitive, for use with 1252 Character Set. You
must use this collation.

Choosing Authentication Method for Database Connectivity

@ Important: If you are planning to use Always On Availability Group clustering (page 23), you
Y must use Windows Authentication.

» The application supports two methods of authentication for connecting to the database.

O SQL Server authentication: Make sure you enable mixed-mode authentication if you plan to use SQL
authentication for database connectivity.

O  Windows authentication
» As part of the installation process, you will be asked to select the authentication method. Your selection will

depend on the security policies of your organization, and should be consistent with the authentication
method configured in SQL Server.

If you choose Windows authentication, certain additional steps must be completed before you begin
installing the application. These steps are outlined in the “Setting Up User Accounts and Permissions” on
page 37.

Setting up for Always On Availability Group Clustering

You need to perform this task if you are planning an HA deployment. For details, see “Appendix B: SQL
Always-On Configuration” on page 161.

@ Important: The High Availability feature is available only for installations using Enterprise Edi-
:%/ tion of MSSQL.
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Installing SQL Server Management Studio (SSMS)

» Install SSMS tool on the database server. Install a version that is compatible with Microsoft SQL 2019.
Refer the Microsoft documentation for details about doing this task.

Creating SQL User for Installing ECE Databases

Skip this section if you want to use the default SA user to install the ECE databases.

» Create a user for installing the ECE databases and make sure the following roles are assigned to the user:
dbcreator, securityadmin, sysadmin

Assigning Permissions to Domain User

» Give sysadmin permission to the Service Account created for running the application. If you have created
a separate SQL Service Account for the database services, then assign the permission to that user (page 37).

Configuring Database Servers

Skip this section if the reports database is on the same instance as the active and master databases. If any
database is on a different instance, consult your administrator and verify that:

O  All database server VMs used in the configuration are in the same domain as all the other Enterprise
Chat and Email servers.

O  All databases must be either on named instances or on default instances. For example, if you are using
the default instance for the active and master databases, then use the default instance for the reports
database as well.

o If you are using Windows authentication, also ensure that the steps outlined in the following section
have been completed: “Configuring Permissions on Active Directory Server” on page 38. After you
have completed these tasks, you should be able to run a linked server query on each database from a
third machine acting as a SQL client.

O  Enable mixed-mode authentication if you plan to use SQL authentication for database connectivity.

Configuring Memory Settings

To configure memory settings:

1. Connect to DB server.

2. Under the Object Explorer section, right-click a server and select Properties.

3. In the Server Properties window, under the Select a Page section, select Memory.
4

Under the Server memory options section, select the Maximum and Minimum server memory (in MB):

o  For ECE Lite Environment: Set the Minimum server memory value as 3072 MB and the Maximum
server memory value as 10240 MB.
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o For ECE Fully Distributed Setup: Set the Minimum server memory value as 3072 MB and the
Maximum server memory value as 14336 MB.

5. Click OK.
Alternatively, you can configure the memory settings by executing the following T-SQL script.

» For ECE Lite Environment:

USE master
GO
sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
sp_configure 'min server memory', 3072;
GO
RECONFIGURE;
GO
sp_configure 'max server memory', 10240;
GO
RECONFIGURE;
GO
» For ECE Fully Distributed Setup:
USE master
GO
sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
sp_configure 'min server memory', 3072;
GO
RECONFIGURE;
GO
sp_configure 'max server memory', 14436;
GO
RECONFIGURE;
GO

Configuring Microsoft DTC Settings

The Microsoft Distributed Transaction Coordinator (DTC) service, a component of Microsoft Windows, is
responsible for coordinating transactions that span multiple resources like databases. MSDTC settings must be
configured on all the database servers in a configuration.
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Enable network DTC access on each database server VM.

To enable network DTC access:
1. Go to Start > Control Panel > Administrative Tools > Component Services.

2. In the console tree, browse Component Services > Computers > My Computer > Distributed
Transaction Coordinator > Local DTC.

3. Right-click Local DTC and from the menu select Properties.
4. In the Local DTC Properties window, go to the Security tab and set the following:

a. In the Security Settings section, select the following two options:
e Network DTC Access
e Enable XA Transactions
b. Within the Network DTC Access section, select the following four options:
e Allow Remote Clients
e Allow Remote Administration
e Transaction Manager Communication - Allow Inbound

e Transaction Manager Communication - Allow Outbound

c. In the DTC Logon Account section, set the value in the Account field to NT
Authority\NetworkService.

Click OK.
In the DTC Console Message box, click Yes.
Restart the machine.

Go to Start > All Programs > Administrative Tools > Services.

® N

In the Services window, locate the following two services and stop them.
o Distributed Transaction Coordinator

o SQL Server (MSSQLSERVER) for Microsoft SQL 2019.
9. Now, start the two services in the following order:

a. Distributed Transaction Coordinator

b. SQL Server (MSSQLSERVER) for Microsoft SQL 2019.
10. Next, go to Start > All Programs > Control Panel.

11. Open Windows Firewall, and in the Windows Firewall window, click the Allow an app or feature through
Windows Firewall link.

12. In the Allowed Programs window, click the Change Settings link and select the Distributed Transaction
Coordinator option. Click OK.
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Running Services

Make sure the following services are running. These services should be started using the SQL Services Account
that you have created for the ECE application. If you didn’t create a SQL Services Account, use the Service
Account created for the ECE application (page 38).

»

4

4

SQL Server Service

SQL Full-text Filter Daemon Launcher Service: This service is required for text searches.
SQL Server Agent Service: This service is used by the Reports module.

SQL Server Integration Service: This service is used by the Reports module.

SQL Server Browser Service: In configurations where database servers are configured to run on named
instances, and no listener port is configured, the SQL Server Browser service needs to be running when you
run the installer. This service does not have to be running if the database servers are configured to run on the
default instance. It is also not required if the database servers are configured to run on named instances, and
specific, static listener ports are configured for the named instances.

Windows Remote Management Service: This service is required only on the reports database.

To start the services:

1.
2.

Go to Start > Programs > Administrative Tools > Services.
For all the services, do the following:

a. Select a service and right-click to open the menu.

b. From the menu select Properties.

c. In the Properties window, go to Log On tab and ensure the service is started using the correct domain
account. These services should be started using the SQL Services Account that you have created for
the ECE application. If you didn’t create a SQL Services Account, use the Service Account created
for the ECE application (page 38).

Ensure that the SQL Server Service, SQL Full-text Filter Daemon Launcher, SQL Server Agent, Windows
Remote Management Service, SQL Server Integration Service, and SQL Server Browser services are
running.
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4. If they are not running, select the services one by one, and click Start to start the service.

O, Services = [ = -
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= Ed= H&E » = nw
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Start the SQL services

Preparing Web Server VMs

Configuring Roles and Features

This task is performed automatically by the installation program. You can choose to do it manually before
running the installation program.

Ensure that the following Roles and Features are installed for IIS.
» NET Extensibility 4.7

» ASP

» CGI

» ISAPI Extensions

» ISAPI Filters

» Server Side Includes

» Static Content

» Static Content Compression

» Dynamic Content Compression
» Directory Browsing

» Default Document
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Ensure that the following feature is not installed for IIS.

» WebDAV Publishing

To install the roles and features:

—

Go to Start > Control Panel > Administrative Tools > Server Manager.

In the Server Manager window, go to IIS section. In the IIS section, locate the Roles and Features section.

2
3. In the Role and Features section, check if the required role services are installed.
4

If any of the roles and features are not installed, from the Tasks menu, click the Add Roles and Features

button and run through the wizard to install the missing services. In the Server Roles section, expand the
Web Server (IIS) > Web Server list, and select the following:

O In the Common HTTP Features list, select:
e  Default Document
e Directory Browsing
e Static Content
O  In the Performance list, select:
e Static Content Compression
e Dynamic Content Compression
O In the Application Development list, select:
e .NET Extensibility 4.7
e ASP
e (CaI
e ISAPI Extensions
e ISAPI Filters

e Server Side Includes

5. In the Role and Features section, check if the WebDAYV Publishing feature is installed. If the feature is

installed, you need to uninstall it. From the Tasks menu, click the Remove Roles and Features button and

run through the wizard to uninstall the feature.

Installing Modules on Web Servers

This task is performed automatically by the installation program. You can choose to do it manually before

running the installation program.

» The Application Request Routing and URL Rewrite modules are required to be installed on the web server.
Download and install the modules from the Microsoft website. The installation programs are also available
in the Environment\Web Server folder of the installation package. After installing the module, restart

IIS.
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Configuring Permissions on [IS Config Folder

» Ensure that the user account you are going to use for installing the application (page 38) has read
permissions on the following folder: ZsystemrootZ\system32\inetsrv\config

Running the World Wide Web Publishing Service

» On all VMs where the web server is to be installed, ensure that the World Wide Web Publishing Service is
running.

Configuring Virus Scanners

Configuring SMTP Port in Virus Scanners

» Ensure that the virus scanner is configured to allow emails to be sent through the SMTP port (Port 25). In a
distributed installation, configure this setting on the services server and all application servers.

Configuring Virus Scanning Exclusions

To ensure that virus and malware scanning software on the servers do not interfere with the performance of the
application, certain folders and files must be excluded from continuous virus scanning. Since no files are
downloaded to these locations from the internet, it is safe to exclude these directories from virus scanning.

On the File, Messaging, Services, Application, and Web Servers

Follow the instructions for your virus scanning software to exclude the following folders and file types. On a
Windows 2019 Server machine, these exclusions must also be setup for Windows Defender.

Item Exclude Subfolders? Execute permissions
Windows File Protection -- Read, Write
All files of type LOG -- Read, Write
Pagefile.sys No Read, Write
DriveAECE_Home\ Yes [other than Storage] Read, Write
*rll No Read, Write
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On the Database Servers

Follow the instructions for your virus scanning software to exclude the following folders and file types. On a
Windows 2019 Server machine, these exclusions must also be setup for the Windows Defender.

Item Exclude Subfolders? Permissions
Windows File Protection - Read, Write
All files of type LOG, if any | -- | Read, Write
Pagefile.sys No Read, Write
Drive\Path, to M@%& Yes Read, Write
* mdf No Read, Write
* |df | No | Read, Write
* ndf No Read, Write
*.dat No Read, Write
*rll | No | Read, Write

Verifying Unified CCE Configuration

»  Verify that Unified CCE and Microsoft Active Directory (AD) have been installed on separate servers. Refer
to Unified CCE documentation for more details.

» Verify that the Unified CCE and AD servers are in the same network as the ECE servers and are accessible
from the ECE servers.Verify that the items to be used in ECE are configured in Unified CCE. These include:

O  Peripherals

O Application Instance

O Media Classes

O  Media Routing Domains (MRDs)

o Network Voice Response Units (Network VRUs)
o Call Type

O  Media Routing Peripheral Gateways (MR PGs)
O Script Selector

O  Agent Peripheral Gateway (Agent PG)
O Network Trunk Groups
O Network Trunks
O  Application Paths and Path Members
o Agents

O Skill Groups
o ICM Scripts
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O  Precision queues
o Expanded Call Context (ECC) Variables
o CTI Gateways (CG)

For details, see “Preparing Unified CCE for the Integration” on page 53.
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This chapter provides an overview of the process of setting up an integrated ECE-Unified CCE system. It
includes a note about the relationship between objects in the two systems.

Relationship Between Objects in Unified CCE and
ECE

This section provides a brief introduction to the relationship or “mapping” between objects that are used in both
Unified CCE and ECE.

The following table provides a high-level view of the relationship between various objects.

Unified CCE object Mapped in ECE to Notes

Agent User » An agent belongs to a peripheral.
Supervisor » A peripheral belongs to an agent
Administrator peripheral gateway (PG).

Skill group User group » A skill group belongs to a peripheral.

» A peripheral belongs to an agent PG.

Media routing domain Queue (Only selected skill groups and PQs of » Multiple queues can belong to a single

(MRD) the MRD) MRD.

Script selector Queue » A script selector can belong to only
one queue.

Typically, the mapping between these objects is set up by using the import feature available in the ECE
Administration Console. Once imported, these objects can be viewed from the department level nodes for these
objects (Queues, Users, and User Groups) in the Administration Console in ECE.

Designing Your Installation

See the Enterprise Chat and Email Design Guide (for Unified CCE) to evaluate available deployment models
and design the installation.

Installing Unified CCE

» Ensure that Unified CCE is installed and available for use. Verify that the following items are installed:
O Unified CCE Instance
O  Call Router Side A
O Call Router Side B
O Logger Side A
O Logger Side B
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O Primary Admin Workstation
O  Secondary Admin Workstation
O  Historic Data Server
O Network Interface Controllers (NIC) (Only required for Pre-routing)
O  Agent Peripheral Gateway (Agent PG)
O  Media Routing Peripheral Gateway (MR PG)
o CTI Server
O CUIC Database
O Java Telephony Application Programming Interface (JTAPI)
O  Cisco Finesse
See the following documents for help with installing and configuring the system:

»  Getting Started with Cisco Unified Contact Center Enterprise

»  Cisco Unified Contact Center Enterprise Installation Guide

Setting up Agent Desktops for Voice Call Routing

» A phone account must be configured for agents to be able to log in to Finesse.

Planning Unified CCE Configuration

To integrate Unified CCE with ECE, multiple objects have to be configured in Unified CCE. The specific
objects that have to be configured will depend on the activities (email, chat etc.) supported by the integrated
installation. This section describes the objects required for each activity type—inbound email, outbound email,
chat, callback, and delayed callback.

For deployments migrating from earlier Unified CCE versions with ECE, customers can choose to create new
Media Routing Domains and Media Classes for ECE or rename the existing ECE MRDs to match the ECE
MRDs detailed in this guide, using the Media Routing Domain and Media Class List tools.

The following objects must be configured in the order in which they are presented here. For configuration
details, refer to the following section: “Configuring Unified CCE” on page 56.

1. Application instance (page 56)

2. Media classes (page 57)

3. Media routing domains (MRD) (page 58)

4. Network voice response unit (Network VRU) (Not required for outbound email activities) (page 59)
5

Network voice response unit script (Network VRU script) (Not required for inbound email and outbound
email activities) (page 60)

6. Call type (page 60)
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7. Media routing peripheral gateway (MR PG) (page 60)

8. Agent desk settings (page 62)

9. Agent peripheral gateway (Agent PG) (page 62)

10. Application path (page 63)

11. Agents (page 64)

12. Skill groups (page 65)

13. Script selector (page 66)

14. Scripts (Not required for outbound email activities) (page 67)

15. Device target (Not required for inbound email, outbound email, and chat activities) (page 69)
16. Expanded Call Context (ECC) variables (page 70)

17. Cisco Finesse (page 77)

Configuring Unified CCE

This section describes the process of configuring Unified CCE objects that are required for the integration with
ECE. These objects must be configured in the order in which they are presented here. For details of these objects
refer to the Online Help and printed documentation for Unified CCE.

Configuring Application Instance

Application instances are configured for each installation of a multi-media feature in the configuration.

Configure a single application instance for integrating with ECE. This application instance is used for inbound
email, outbound email, chat, callback, and delayed callback activities.

To configure an application instance:

1. Go to Start > All Programs > Cisco Unified CCE Tools > Administration Tools > Configuration
Manager. You can also access the Configuration Manager using the Unified CCE Administration Tools
desktop shortcut.

2. In the Configuration Manager window, browse to Tools > List Tools > Application Instance List.
3. Double-click Application Instance List.

4. In the Application Instance List window, in the Select filter data section, click Retrieve. Then, in the
Application Instance section, click Add.

A new entry is created in the Application Instance section and the Attributes tab becomes editable.
5. On the Attributes tab, provide the following details:
O Name: Provide a name for the application instance.

O Application key: Provide a unique value for the key. Please note that ECE uses the application instance
name and not the application key to connect to Unified CCE.

56 Enterprise Chat and Email Installation and Configuration Guide



O  Application type: Set it to <Other>.

O  Permission level: Set it to Read only.

Click Save.

About Media Classes

A media class defines the type of requests you want to set up for routing on Unified CCE. Configure a media
class for each media supported by the ECE deployment. A media class is required for creating MRDs. It helps
categorize the MRDs based on media type (email, for example).

Create the following media classes:

4

4

4

4

An email media class for inbound emails.
An email media class for outbound emails.
A chat media class for chat.

Callback and Delayed callback use the existing Cisco_Vo1ice media class, which is already created by the
system.

Once a media-class for a particular media is created, all other objects required for that media class must also be
configured.

For more details about Media Classes, see the Scripting and Media Routing Guide for Cisco Unified
ICM/Contact Center Enterprise available at https://www.cisco.com/c/en/us/support/customer-
collaboration/unified-contact-center-enterprise/products-user-guide-list.html

Configuring Media Classes

To configure a media class:

1.

2
3.
4

Open the Configuration Manager.
In the Configuration Manager window, browse to Tools > List Tools > Media Class List.
Double-click Media Class List.

In the Media Class List window, in the Select filter data section, click Retrieve. Then, in the Media Class
section, click Add.

A new entry is created in the Media Class section and the Attributes tab becomes editable.

On the Attributes tab, provide the following details:

O Name: Provide a name for the media class. If the media class is meant to be used in ECE, use one of
the following names. Note that the names of media classes are case sensitive. Make sure that you use
the exact names as provided here.

e ECE_Email (for inbound email)
e ECE_Outbound (for outbound email)
e ECE_Chat (for chat)

Media classes are set in the ECE partition level setting - Media Classes - as ECE_Email,
ECE_Outbound, and ECE_Chat. If you use names other than these, you must change them in the
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partition level setting from the ECE Administration Console. Note that the names of media classes are
case sensitive.

In the Task section, set the following.
o Life: Set the value to 300 seconds.
o  Start timeout: Set the value to 30 seconds.

O  Max Duration: Set the value to 28800 seconds.

Click Save.

Configuring Media Routing Domains (MRDs)

An MRD is a collection of skill groups and services that are associated with a common communication medium.
Unified CCE uses an MRD to route tasks to agents who are associated with a skill group and a particular
medium. A media routing domain is created in Unified CCE for mapping to queues in ECE.

Create the following media routing domains:

4

4

4

4

For inbound email media class, create only one email media routing domain.
For outbound email media class, create only one email media routing domain.
For chat, create only one chat media routing domain.

For callback and delayed callback, use the existing voice media routing domain (Cisco_Voice) created by
the system.

For more details about Media Routing Domains, see the Scripting and Media Routing Guide for Cisco Unified
ICM/Contact Center Enterprise available at https://www.cisco.com/c/en/us/support/customer-
collaboration/unified-contact-center-enterprise/products-user-guide-list.html

To configure a media routing domain:

1.

2
3.
4

Open the Configuration Manager.
In the Configuration Manager window, browse to Tools > List Tools > Media Routing Domain List.
Double-click Media Routing Domain List.

In the Media Routing Domain List window, in the Select filter data section, click Retrieve. Then, in the
Media Routing Domain section, click Add.

A new entry is created and the Attributes tab becomes editable.

On the Attributes tab, provide the following details:
O Name: Provide a name for the media routing domain.

O Media class: Select a media class created for ECE (page 57). Make sure that you select the correct
media class for the MRD. For example:

e For inbound email MRD, select the ECE_Email media class.
e For outbound email MRD, the ECE_Outbound media class.
e For chat MRD, select the ECE_Chat media class.

58 Enterprise Chat and Email Installation and Configuration Guide



O Interruptible: You must select this option while creating MRDs for inbound and outbound emails.

@ Important: MRDs for emails cannot be non-interruptible.

In the Calls in Queue section, set the following:

O Max: Defines the maximum number of activities to be queued for the MRD. Refer the Solution Design
Guide for Cisco Unified Contact Center Enterprise for guidelines for maximum limits.

If agents are on holiday or the business is not available for elongated times to cater to emails due to Bank
holiday, long weekends or other reasons, emails go into the Default Exception Queue as no agent was
available in Unified CCE to cater to emails. This results in a lot of abandoned tasks in reporting.

Based on the business needs, it is recommended to update the Max time in queue value of inbound email
MRD. It is recommended to put the value as Total anticipated wait time/4. Total anticipated wait time can
be defined as the duration when the business is not able to respond to emails, for example, if it is a long
weekend, then 3 days no agent is available + some buffer time of 2 hours before agents can start responding,
so the value should be:

3 Days (3 * 24 * 60 * 60) = 259200 sec

2 Hours (2 * 60 * 60) = 7200 sec

Recommended value for Max time in queue = (259200 + 7200)/4 = 66600 sec
Click Save.

Configuring Network VRU

A Network VRU is required for supporting incoming activities to Unified CCE. Note that this Network VRU
configuration has no relationship with any physical Network VRU existing in your environment.

Configure a single Network VRU for ECE. This network VRU is used by inbound email, chat, callback, and
delayed callback activities. It is not required for outbound email activities.

To configure a Network VRU:

1.

2
3.
4

Open the Configuration Manager.
In the Configuration Manager window, browse to Tools > Explorer Tools > Network VRU Explorer.
Double-click Network VRU Explorer.

In the Network VRU window, in the Select filter data section, click Retrieve. Then, click [1] Add Network
VRU.

A new entry is created and a new set of tabs appear.

On the Network VRU tab, provide the following details:
O Name: Provide a name for the network VRU.

o Type: Set it to Type 2.
Click Save.
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Configuring Network VRU Scripts

Configure Network VRU scripts if you want to display dynamic content to chat customers (for example, wait
time, activity ID, etc) while chat requests are being processed by the system. This is an optional feature. The
dynamic messages are configured in ECE (See page 154 for details). The name of the Network VRU script that
is configured here is used while configuring the dynamic messages.

Network VRU scripts need to be configured only for chat, callback, and delayed callback activities.

To configure a Network VRU script:
1. Open the Configuration Manager.
2. In the Configuration Manager window, browse to Tools > List Tools > Network VRU Script List.

3. In the Network VRU Script List window, provide a Name and VRU script name and select the Network
VRU created for ECE (page 59).

4. Click the Save button.

Configuring Call Types

A call type is required to categorize a dialed number (for voice) or a script selector (for email). Call types are
used in configuring routing scripts.

Individual call types are required for the following activities: inbound email, outbound email, chat, callback, and
delayed callback activities. Make sure you complete these steps for each type of activity.

To configure a call type:

1.  Open the Configuration Manager.

2. In the Configuration Manager window, browse to Tools > List Tools > Call Type List.
3. Double-click Call Type List.
4

In the Call Type List window, in the Select filter data section, click Retrieve. Then, in the Call Type section,
click Add.

A new entry is created and the Attributes tab becomes editable.

5. On the Attributes tab, in the Name field, provide a name for the call type. Click Save.

Configuring Media Routing Peripheral Gateways (MR PGs)

An MR PG handles new activity routing requests initiated by ECE, over the connection established by the
embedded MR PIM (side A or side B). The MR PG provides routing instructions to ECE, while the Agent PG is
used to report agent state and status to Unified CCE. Also note that agents are not configured on MR PG. They
are always configured on the Agent PG.

Configure a single MR PG for ECE. This MR PG is used for inbound email, outbound email, chat, callback, and
delayed callback activities.

The MR PG configuration involves three steps:

» Configuring MR PG using the Configuration Manager: The details are described in this section.
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Installing MR PG: For details, see the Unified CCE Installation Guide.

Creating MR PIM for the installed MR PG: You need to create a single MR PIM for ECE. For details, see
the Unified CCE Installation Guide. While creating the MR PIM, you are asked to provide the Application
Connection Port number. As a best practice, use a port number that is greater than 2000. This port number is
required while configuring the External Agent Assignment Server (EAAS) (page 153).

To configure a media routing peripheral gateway (MR PG):

1.

2
3
4,
5

10.
11.

Open the Configuration Manager.

In the Configuration Manager window, browse to Tools > Explorer Tools > PG Explorer.
Double-click PG Explorer.

In the PG Explorer window, in the Select filter data section, click Retrieve. Then, click [1] Add PG.

On the Logical Controller tab, provide the following details:
O Name: Provide a name for the media routing peripheral gateway.

O  Client type: Set it to MediaRouting.
Click [2] Add Peripheral.
A new set of tabs appear.

On the Peripheral tab, provide the following details:
O Client type: Select MediaRouting.
O  Default desk settings: Select None.

O Enable Post Routing: Select the option.

On the Advanced tab, in the Network VRU field, from the dropdown list, select the Network VRU
configured for ECE (page 59).

On the Routing client tab, provide the following details:

O Name: Provide a name for the routing client.

O Default media routing domain: From the dropdown list, select None.

O Default call type: From the dropdown list, select None.

O  Client type: Set it to MediaRouting.

Click Save.

On the Default route tab, in the Media Routing Domain field, ensure that the Route: field is set to None.

Click Save. Note down the Logical controller ID generated in the Logical Controller tab. It is needed while
configuring MR PIM.

5\ Important: Now install the MR PG and configure the MR PIM. For more information, see the
Y Unified CCE Installation Guide.
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Configuring Agent Desk Settings

Agent desk settings are a common set of properties for a group of agents working on voice call requests. This is
required for configuring an Agent PG. At least one Agent Desk Setting must be configured for ECE.

To configure agent desk settings:

1.

2
3.
4

Open the Configuration Manager.
In the Configuration Manager window, browse to Tools > List Tools > Agent Desk Settings List.
Double-click Agent Desk Settings List.

In the Agent Desk Settings List window, in the Select filter data section, click Retrieve. Then, in the Agent
Desk Settings section, click Add.

A new entry is created and the Attributes tab becomes editable.

On the Attributes tab, in the Name field, provide a name for the agent desk setting group. Click Save.

Configuring Agent Peripheral Gateway (Agent PG)

An Agent PG is required for creating one or more peripherals that manage agent distribution within Unified
CCE. Configure an Agent PG using the Configuration Manager and then install it on the appropriate machine.

These Agent PGs are used for inbound email, outbound email, chat, callback, and delayed callback activities.

Note that you can also use an existing Agent PG if it is of the type Call Manger/Soft ACD.

To configure an agent peripheral gateway:

1.

2
3
4,
5

Open the Configuration Manager.

In the Configuration Manager window, browse to Tools > Explorer Tools > PG Explorer.
Double-click PG Explorer.

In the PG Explorer window, in the Select filter data section, click Retrieve. Then, click [1] Add PG.

On the Logical Controller tab, provide the following details:
O Name: Provide a name for the agent peripheral gateway.
O Client type: Set it to CUCM or Generic.

O Primary CTI address: Provide the address of the primary CTI server in the format
IP_Address:Port_Nwmber. You can either provide the IP address, or the host name. You do not need to
configure this option if you are using Unified CCE 12.0(1).

O Secondary CTI address: Provide the address of the secondary CTI server in the format
IP_Address:Port_Nwmber. You can either provide the IP address, or the host name. The secondary CTI
address is needed only if the Unified CCE system is duplexed. You do not need to configure this option
if you are using Unified CCE 12.0(1).

Click [2] Add Peripheral.
A new set of tabs appear.

On the Peripheral tab, do the following:
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O Default desk settings: From the dropdown list, select the agent desk settings configured for ECE
(page 62).
O Enable post routing: Select the option.
8. On the Routing client tab, in the Name field, provide a name for the routing client.
9. On the Agent Distribution tab, do the following:
a. Click New.
b. Select the Enable agent reporting option.
c. Select the Agent event detail option.
d. In the Currently Selected Site section, set the following:

e Administration & Data Server site name: Provide the host name of the machine where
distributor is installed.

e Agent Real time data: Select the option.

10. Click Save.

Configuring Application Path

An application path is required to open a communication channel with a CTI server associated with an Agent
PG. It is used for agent and task status reporting. For each Agent PG, create an application path that ECE will
use to connect to the Agent PG. You must create a new application path for ECE.

Create a single application path and add all the MRD-peripheral combinations for the Agent PG to the
application path member list. The application path is used for inbound email, outbound email, chat, callback, and
delayed callback activities.

Access to the application object filter is restricted. Log in as a super user to enable or disable the application
object filter. For details about the super user password, see the Configuration Guide for Cisco Unified
ICM/Contact Center Enterprise available at
https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_installation_and_configuration_guides_lis
t.html

To configure an application path:
1. Open the Configuration Manager.

2. In the Configuration Manager window, from the menu, go to Options > Application Object Filter.
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3. In the Application Object Filter window, in the Disable / Enable application object filter section, in the
Superuser password field, provide the password of the superuser and click the Disable button. Click OK.

Application Object Filter -

Disable / Enable application object fiter

[Cee |

Change superuser password

0ld password
MNew password
Confirm password Change

ak Cancel ‘ Help |

Provide the password of the superuser

4. In the Configuration Manager window, browse to Tools > List Tools > Application Path List.
5. Double-click Application Path List.

6. In the Application Path List window, in the Select filter data section, in the Application Instance field select
the application instance configured for ECE (page 56). Click Retrieve.

7. In the Application Path section, click Add.
A new entry is created and the Attributes tab becomes editable.

8. On the Attributes tab, provide the following details:

o Application Instance: From the dropdown list, select the application instance configured for ECE
(page 56).

O  Peripheral Gateway: From the dropdown list, select an agent peripheral gateway configured for ECE
(page 62).
O Name: This field is auto-populated.

In the Application Path Members section, click the Add button and set the following:
O  Peripheral: From the dropdown list, select the agent peripheral configured for ECE (page 62).
O Media routing domain: From the dropdown list, select an MRD configured for ECE (page 58).

Add all the MRD-peripheral combinations for the Agent PG to the application path member list.
Click Save.
9. In the Configuration Manager window, go to Options > Application Object Filter.

10. In the Application Object Filter window, in the Disable / Enable application object filter section, click the
Enable button. Click OK.

Configuring Agents

An agent is created in Unified CCE for mapping to users in ECE. Create all agents for whom routing or reporting
is done in Unified CCE. If you plan to use Precision Routing, you need to assign attributes to agents. For details,
see “Assigning Attributes to Agents” on page 72.
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Create agents for handling inbound email, outbound email, chat, callback, and delayed callback activities.

To configure an agent:

1.

2
3.
4

Open the Configuration Manager.

In the Configuration Manager window, browse to Tools > Explorer Tools > Agent Explorer.

Double-click Agent Explorer.

In the Agent Explorer window, in the Select filter data section, in the Peripheral field select an agent
peripheral. Click Retrieve.

Click the [1]Add Agent button.

A new entry is created and a new set of tabs appear.

On the Agent tab, provide the following details:

o

Enable logins: Select the option.

Enable Single sign-on (SSO): Select this option if you want to use single sign-on for the agent.
Password fields are disabled if you select this option.

First name: Provide the first name.
Last name: Provide the last name.

Login name: Provide the login name for the agent. For callback and delayed callback agents, the login
name should match the User ID provided while configuring End users from the Cisco Unified
Communication Manager Administration user interface.

Password: Provide the password for the agent. Make sure the password does not contain the following
characters: = (equal to) and ; (semicolon) as ECE does not allow the users to login if these characters
are present in the passwords. Password fields are disabled if single sign-on option is selected for the
agent.

Enterprise name: This field is auto-populated.

Click Save.

Configuring Skill Groups

%\ Important: If you are planning to have multiple departments in ECE, then ensure that you create
% department specific skill groups.

A skill group is created in Unified CCE for mapping to user groups in ECE. The skill group members (agents)
are administered and managed in Unified CCE. A skill group (with associated skill group members) is used in
scripts to facilitate routing through Unified CCE to the skill group. This is used for inbound email, outbound
email, chat, callback, and delayed callback activities.

To configure a skill group:

1.
2.
3.

Open the Configuration Manager.

In the Configuration Manager window, browse to Tools > Explorer Tools > Skill Group Explorer.

Double-click Skill Group Explorer.
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4. In the Skill Group Explorer window, in the Select filter data section, select an agent peripheral. Click
Retrieve.

5. Click the [1]JAdd Skill group button.
A new entry is created and a new set of tabs appear.

6. On the Skill Group tab, provide the following details:
O Media routing domain: From the dropdown list, select an MRD configured for ECE (page 58).
O Peripheral number: Provide a unique peripheral number.
O Peripheral name: Provide a name for the skill group.
O Name: This field is auto-populated.

O ICM picks the agent: Select the option.
7. On the Skill Group Members tab, do the following:

a. Click the Add button.

b. From the Add Skill Group Member window, select the agents to be added in the skill group. Click OK.
8. Click the Add Route button.

A new tab appears.

9. On the Route tab, in the Name field provide the name for the route and click Save.

Configuring Dialed Number/Script Selectors

A script selector is a keyword that identifies the routing script for an activity request from ECE to Unified CCE.
Script selectors are used in routing scripts as part of the Dialed Number node.

Individual script selectors are required for the following activities: inbound email, outbound email, chat,
callback, and delayed callback activities. Make sure to complete these steps for each type of activity.

5\ Important: If you are planning to have multiple departments in ECE, then ensure that you create
'Y department specific script selectors.

To configure a script selector:
1.  Open the Configuration Manager.

2. In the Configuration Manager window, browse to Tools > List Tools > Dialed Number/ Script Selector
List.

3. Double-click Dialed Number/ Script Selector List.

4. In the Dialed Number/ Script Selector List window, in the Select filter data section, in the Routing client
field select the routing client configured for MR PG (page 61). Click Retrieve.

5. In the Dialed Number/ Script Selector section, click Add.
A new entry is created and the Attributes tab becomes editable.

6. On the Attributes tab, provide the following details:
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O Routing client: From the dropdown list, select the routing client configured for the MR PG in step 9 in
“Configuring Media Routing Peripheral Gateways (MR PGs)” on page 60.

O Media routing domain: From the dropdown list, select the MRD configured for ECE (page 58).
O Name: Provide a name for the script selector.

7. Click the Dialed Number Mapping tab. Click Add.

8. On the Dialed Number Map Entry window, associate the script selector with a call type.

9. Click OK to save the entry. Then click Save to save the script selector configuration.

Creating Scripts

A routing script determines the path and target object for an activity routed from ECE to Unified CCE. Individual
routing scripts are required for the following activities: inbound email, chat, callback, and delayed callback
activities. Make sure to complete these steps for all these activities. You do not need routing scripts for outbound
email activities.

Universal queues and Precision queues can be used in the scripts configured for ECE. Precision queues cannot be
used if you are using Unified CCE 11.0(1) version.

For details about creating universal queues, see the Scripting and Media Routing Guide for Unified CCE
available at https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_user_guide_list.html. Make
sure to use the guide that matches the version of the product that you are using. To find the right version, refer
to the Cisco Unified Contact Center Enterprise (Unified CCE) Software Compatibility Guide available at
https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_device_support_tables_list.html.

For details about configuring Precision Routing, see “Configuring Precision Routing” on page 71.

To use the Personalized Activity Assignment feature available in ECE, you need to create some addition objects
(Enterprise Skill Groups and Enterprise Routes) and the scripts need to be configured a certain way. For details,
see “Creating Objects in Unified CCE for Personalized Activity Assignment” on page 72.

The following procedure shows how to set up a particular script. To find out more about setting up different
types of scripts to meet your routing requirements, see the Scripting and Media Routing Guide for Unified CCE.

To create a script:

1. Go to Start > All Programs > Cisco Unified CCE Tools > Administration Tools > Script Editor. You
can also access the Script Editor using the Unified CCE Administration Tools desktop shortcut.

2. In the Script Editor window, click the New button.
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3. In the Create A New Script window, select the Routing script option.

Create A New Script

Chooze the type of script to create:

state.

Fiouting zcript: A routing zcript handles calls
delivered by a routing client.

Adminigtrative script: An adminiztrative script
unz at a specified interval and updates internal

Cancel

Select the Routing Script option

A new script editor opens. The Start node is added by default to the script editor.

4. In the Script Editor window, go to View > Palette.

The Palette window opens.

5. In the Palette window, on the Queue tab, click the Queue button, and click in the script editor. The Queue to
Skill Group node is added to the script editor.

6. Double-click the Queue to Skill Group node to open the Queue to Skill Group Properties window.

7. In the Queue to Skill Group Properties window, on the Queue tab, in the Skill Group column, select a skill

Add Targets... |

group.
g Queue to Skill Group Properties
Queue lConnedion Labels

Queue type Target references

Priority 5 Change... {+ Explicit target references

Using Skill Groups " Lookup target references by expression
e

Target Requery Disabled ~

Skill Group Consider If Route Translation Route | ~
EN_SKG =]

=1 B 2 S

Delete Row

0K

Cancel

Validate
]
Move
[
Help

Select a skill group

8. Next, in the Palette window, on the General tab, click the Line Connector button and configure the success
and error paths for each node. This creates the routing path of the script.

9. Click the Validate Script button to check if the script is created properly. If there are any errors, fix them.

10. Click the Save button to save the script.
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To display dynamic content (page 154) to chat customers (for example, wait time, activity ID, etc.) while chat
requests are being processed by the system, ensure that the Run External Script node is configured.

11. In the ICM script, add the Run External Script node and select the Network VRU script created on page 60.

After creating a script, map the script to a call type, MRD, and script selector. Also set the run schedule for the
script.

12. In the Script Editor window, go to Script > Call Type Manager.
13. In the Call Type Manager window, in the Call Directory tab, do the following:

a. In the Media Routing Domain field, from the dropdown list, select the MRD configured for ECE
(page 58).

b. In the Script Type Selector field, from the dropdown list, select the script selector created for the MRD
(page 66).

c. Next, click the Add button. The Add Call Type Selector Entry window appears. In the Call type field,
select the call type configured for ECE (page 60). Click OK.

Call Type Manager -
Call Directory ] Schedules | Call Type Tree |
Media Routing Domain: |EMT ﬂ
Script Type Selector:  |[TETI= TR hd
Add...
App String 1 App String 2 Call Type Scheduled Script Mody
odiy...
eMail {4l Customers}
Delete
Sort
L]
Move
]
oK Cancel | ponly Help

Map the script to a call type, MRD, and script selector

14. In the Call Type Manager window, in the Schedule tab, do the following:
a. In the Call type field, from the dropdown list, select the same call type you selected in Step 13.

b. Next, click the Add button. In the Add Call Type Schedule window that appears, do the following:
i. In the Script tab, select the script configured for ECE (page 67).
ii. In the Period tab, set a schedule for the script.
iii. Click OK.
15. Click OK to close the Call Type Manager window.

Configuring Device Targets

@ Important: Skip this section if you are using Agent targeting rules.
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Individual device targets are required for routing voice calls for callback and delayed callback activities.
Complete these steps for all these activities. Device targets are not needed for inbound email, outbound email,
and chat activities.

To configure a device target:

1. Open the Configuration Manager.

2. In the Configuration Manager window, browse to Tools > Explorer Tools > Device Target Explorer.
3. Double-click Device Target Explorer.

4. In the Device Target Explorer window, click Add Device Target.

5

Provide the name and global address, which is the host name of the Unified CCE server followed by the
agent extension, in the following format: MWMf&CEffwm Agent_Extension

6. Provide the configuration parameter in the following format. The string before the agent extension must be
exactly as specified: /devtype CiscoPhone /dn Agent Extension

7. Click the Add Label button.
The Label tab appears.

8. On the Label tab, set the following:
O Routing client: From the dropdown list, select the MR PG configured for ECE (page 60).
O Label: Provide the name of the label. The label name must be the AﬂW_ExtWéom

9. Click Save.

Configuring Expanded Call Context (ECC) Variables

ECC variables are used in Unified CCE scripts to facilitate and influence routing. ECC variables have a
maximum length of 256 characters. Both Scalar and Array ECC variables are supported.

ECC variables are required for inbound email, outbound email, chat, callback, and delayed callback activities.
Create the following ECC variables:

» For chat, inbound and outbound email activities: user.ece.activity.id

» For callback and delayed callback activities: user.ece.activity.id, user.ece.customer.name

5\ Important: The two ECC variables (user.ece.activity.id and user.ece.customer.name) in ICM are

' automatically added to the default ECC variable payload if there no other payloads configured.
However, if you have already configured multiple payloads, the variables are not added to any of
them, and you need to add them manually to the default payload.

To configure an ECC variable:
1. Open the Configuration Manager.
2. In the Configuration Manager window, browse to Tools > Miscellaneous Tools > System Information.

3. In the System Information window, in the General section, select the Expanded call context enabled
option. Click Save.
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In the Configuration Manager window, browse to Tools > List Tools > Expanded Call Variable List.
Double-click Expanded Call Variable List.

In the Expanded Call Variable List window, in the Select filter data section, click Retrieve. Then, in the
Expanded Call Variable section, click the Add button.

Type the name and length of the ECC variable. A maximum of 256 characters are allowed. Make sure to use

the exact names as provided here.
O user.ece.activity.id (needed for all types of activities)

O user.ece.customer.name (needed for callback and delayed callback activities)

Click Save.

Configuring Precision Routing

Precision Routing provides multidimensional routing with simple configuration, scripting, and reporting. For
details about Precision Routing, see the Precision Queues chapter in Administration Guide for Cisco Unified
Contact Center Enterprise.

To configure precision routing, create the following objects:

1.

2
3.
4

Create attributes (page 71)
Assign attributes to agents (page 72)
Create precision queues (page 72)

Add precision queue node to the scripts (page 72)

7\ Important: If you are planning to have multiple departments in ECE, then ensure that you
' configure department specific precision queues.

Creating Attributes

To create an attribute:

1.

2
3
4,
5
6
7

Launch the CCE Web Administration page, using the URL: https://server Namel cceadmin/
Login using the administrator credentials.

Navigate to Organization > Skills. Click the Attributes tab to configure attributes.

In the Attributes tab, click New.

In the Name field, type a unique attribute name.

From the Type dropdown list, select the type of attribute, which can be Boolean or Proficiency.

From the Default dropdown list, select from True or False for Boolean or a number between 1-10 for
Proficiency.

Click Save.
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Assigning Attributes to Agents

To assign attributes to agents:

1.

2
3
4,
5

Launch the CCE Web Administration page, using the URL: https://server Namel cceadmin/

Login using the administrator credentials.

Navigate to Users > Agent.

In the list of agents, select an agent to assign attributes.

On the Attributes tab add the required attributes to agent and set the values for the attributes. click Save.

Creating Precision Queues

To create a precision queue:

1.

2
3
4,
5

Launch the CCE Web Administration page, using the URL: https://server Namel cceadmin/

Login using the administrator credentials.

Navigate to Organization > Skills. Click the Precision Queues tab.

In the Precision Queues tab, click New.

On the New Precision Queue page, provide the following details:

a.
b.

C.

Provide a name for the queue.
Select a Media Routing Domain (page 58) created for ECE.

Set the values for Service Level Type, Service Level Threshold, Agent Order, Bucket Interval to meet
your business needs.

Create the steps for the precision queue and in the expressions use the attributes created for ECE.

Adding Precision Queue Node to the Scripts

4

In the scripts for ECE, add the precision Queue node. For details about doing this task see the Precision
Queues chapter in the Administration Guide for Cisco Unified Contact Center Enterprise.

Creating Objects in Unified CCE for Personalized Activity Assignment

The personalized activity assignment feature in ECE allows you to assign activities pertaining to a case to the
agent who last sent a response for that case. For details about personalized activity assignment settings and how
to configure these in ECE, see the Enterprise Chat and Email Administrator’s Guide to Administration Console.
Along with these settings in ECE, you need to configure the scripts in Unified CCE in a certain way to support
personalized activity assignment.

Create the following objects in Unified CCE:

1.

Create Enterprise Skill Groups (page 73).

2. Create an Enterprise Route (page 73).
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3.

Add the Queue to Agent node in the routing script (page 73).

Creating Enterprise Skill Group

To create enterprise skill groups:

1.

2
3
4.
5

Open the Configuration Manager.

In the Configuration Manager window, browse to Tools > List Tools > Enterprise Skill Group List.
Double-click Enterprise Skill Group List.

In the Enterprise Skill Group List window, in the Select filter data section, click Retrieve.

Click the Add button.

A new entry is created and the Attributes tab appears.

On the Attributes tab, do the following:

a. Provide a name for the enterprise skill group.

b. In the Skill Groups section, click the Add button and from the Add Skill Groups window, select the
skill groups created for working on emails (page 65). Click OK to close the window.

Click the Save button.

Creating Enterprise Routes

To create enterprise routes:

1.

2
3
4,
5

Open the Configuration Manager.

In the Configuration Manager window, browse to Tools > List Tools > Enterprise Route List.
Double-click Enterprise Route List.

In the Enterprise Route List window, in the Select filter data section, click Retrieve.

Click the Add button.

A new entry is created and the Attributes tab appears.

On the Attributes tab, do the following:

a. Provide a name for the enterprise route.

b. In the Routes section, click the Add button and from the Add Routes window, select the Routes created
for emails (page 66). Click OK to close the window.

Click the Save button.

Adding the Queue to Agent Node in Scripts

To add the Queue to Agent Node in scripts:

1.

Open the script you are using for routing emails in ECE.
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Add the Queue to Agent node in the script and configure the following:

a. Peripheral: Select the <Select Agent by SkillTargetID> option.

b. Agent Expression: Set the value as Call.PreferredAgentID.

c. Consider If: Set the value as 1=1.

d. Enterprise Skill Group: Select the enterprise skill group created on page 73.
e. Enterprise Route: Select the enterprise route created on page 73.

f.  Queue if agent not logged in: Select this option if personalized emails should queue when an agent is
not available.

g. Click OK to close the window.

te Queue to Agent Properties -
GQueue to Agert | Connection Labels ]
Queue to Agent type
Select using indirect references
Target Reguery Disabled
Peripheral Agent Expression Consider If Enterprise Skill | Enterprise Rout Rt ~ |
1 =Select Agent by SkilTarget Call PreferredAgentiD | 1=1 Defaul\ECE ECE
2
3 Validate
: |
[ =
d L]
2 Move
8 +
10 J
11
12
13
14 ~
< m >
¥ Queue f agent not logged in
DK Cancel Help

Configure the Queue to Agent node

Adding MR PIM for ECE

To add PG and PIM for MRPG:

1.

ook wn

On the CCE Peripheral Gateway on Side A, from Cisco Unified CCE Tools, click Peripheral Gateway
Setup.

On the Components Setup screen, in the Instance Components panel, click the Add button.
On the Components Setup screen, in the Instance Components panel, click on peripheral gateway.
In the Peripheral Gateways Properties screen, slosh client type as Media routing. Then click Next.

In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box, click
Add, select PIM1, and configure with the Client Type of Media Routing as follows:

a. Check Enabled.

b. In the Peripheral name field, enter MR.
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c. In the Peripheral ID field, enter the Peripheral ID for the Media Routing Peripheral Gateway that you
are not using for any other purpose.

d. In the Application Hostname (1) field, enter the hostname or the IP address of the ECE services server
VM. If you have installed two services servers for high availability, provide the information for the
primary services server on Side A.

e. In the Application Connection Port (1) field, enter the port number on the ECE services server VM
that the PIM will use to communicate with the application. The default port is 38001.

f. In the Application Hostname (2) field, enter the enter the hostname or the IP address of the secondary
ECE services server VM on Side B. Set this value only if you have installed two services servers for
high availability.

g. In the Application Connection Port (2) field, enter the port number on the ECE services server VM
that the PIM will use to communicate with the application. The default port is 38001. Set this value
only if you have installed two services servers for high availability.

h. In the Heartbeat interval (sec) field, enter 5.

i. In the Reconnect interval (sec) field, enter 10.

j-  Select the Enable Secured Connection option if you want to use the secure PII feature. You will be

prompted to update the Application connection ports. Check the Port Utilization Guide for Cisco
Unified Contact Center to find the port number to be used for secure connection.

k. Click OK.

Accept defaults and click Next until the Setup Complete screen opens.

On the Setup Complete screen, check Yes to start the service. Then click Finish.
Click Exit Setup.

Repeat these steps for the CCE Peripheral Gateway on Side B.

Adding Agent PG PIM for ECE

To add PG and PIM for Agent PG:

1.

A

On the CCE Peripheral Gateway on Side A, from the Cisco Unified CCE Tools, select the Peripheral
Gateway Setup option.

On the Components Setup screen, in the Instance Components panel, click the Add button.
Select peripheral gateway and click it. PG1A will be created.

On the Components Setup screen, in the Instance Components panel, click on peripheral gateway.
In the Peripheral Gateways Properties screen, slosh client type as CUCM. Then click Next.

In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box, click
Add, select PIM1, and configure with the Client Type of CUCM as follows:

a. Check Enabled.

b. In the Peripheral name field, enter Agent PG.
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c. In the Peripheral ID field, enter the Peripheral ID for the Agent PG that you are not using for any
other purpose.

d. In the CUCM section, provide the CUCM server details with username and password.
e. Click the OK button.

Click Next until the Setup Complete screen opens.

On the Setup Complete screen, check Yes to start the service. Then click Finish.

Click Exit Setup.

Repeat these steps for the CCE Peripheral Gateway on Side B.

Adding CTI for ECE

To add CTI for ECE:

1.

On the CCE Peripheral Gateway on Side A, from Cisco Unified CCE Tools, click Peripheral Gateway
Setup.

On the Components Setup screen, in the Instance Components panel, click the Add button.
The Component selection screen opens.

Click on CTI server. In the CTI server component screen, select the check box for secure port, if you want
to use secure port. Click the Next button.

Click Next until the Setup Complete screen opens.
On the Setup Complete screen, check Yes to start the service. Then click Finish.
Click Exit Setup.

Repeat these steps for the CCE Peripheral Gateway on Side B.

Configuring the System for Multiple Agent PGs

Multiple Agent PGs can be used for Unified CCE installations. Note that a unique application path and
associated application path members are needed for each Agent PG. The application path is used by the EAMS
Service to connect and communicate with the Agent PG.

To configure the system for multiple Agent PGs:

1.
2.
3.

Create the Agent PGs. For Unified CCE installations, see page 62.
In Unified CCE, configure agents (page 64) and skill groups (page 65).

From the ECE Administration Console, add the new Agent PG. For each Agent PG that is added, a EAMS
instance is created in the System Console. Refer to the Enterprise Chat and Email Administrators Guide to
Administration Console for details about adding new Agent PGs.

Log in to the ECE System Console.
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5. Browse to Shared Resource > Services > Unified CCE > EAMS. In the List pane, select the EAMS
process. In the Properties pane, in the Maximum number of instances field increase the value to match the
number of Agent PGs you are adding.

6. Browse to Partitions > rartition. In the Properties pane, on the Services tab, set the number of instances for
the EAMS service to match the number of Agent PGs you are adding.

For details about steps 4-6, see the Enterprise Chat and Email Administrator's Guide to System Console.

Configuring Finesse

Agents always access ECE through Finesse. After installing ECE, configure Finesse to add the ECE gadget. For
details about doing this task, “Configuring Finesse” on page 101.
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Installation Process

» Installation Overview
» Installing ECE

» Installation Details



This chapter provides an overview of how to install the application. Before beginning the installation, ensure that
you have complied with all the prerequisites listed in “Pre-Installation Tasks” on page 31.

Installation Overview

You can do a collocated deployment, where all components, except for the web server, are installed on the same
VM and the web server is installed on a separate VM. The web server may be installed outside the firewall, if
required. Or, you can do a distributed-server installation, where each component is installed on a separate VM.

When each component is on a different VM, the installation program is run on each server separately. Make sure
you install the file server first, followed by the database server. Note that the installer should always be launched
from the machine meant to be File server as only the Database server can be installed remotely. Since the
database is installed remotely when file server is being installed, select both the file server and the database
components at the same time in the installation wizard. The program will ask you for the details of the database
server as you work through the installation.

If you are installing two components, for example, application and services server components, on the same VM,
make sure that you install both application server and services server at the same time. The installation program
can only be run once per server.

The valid sequence for running the installation program is:

Install the following components first:

1. File server + Database server

The following components can be installed in any order:

2. Messaging server

3. Application server

4. Services server

The following server can only be installed after Application server has been installed:
5. Web server

If you plan to have multiple application and web servers, run the installer on all the VMs where these
components need to be installed. If you plan to install a cluster of messaging servers, make sure you install all
the messaging servers. Likewise, if you are planning to have two services server, then make sure you install both
the services servers. You can add additional servers at any point after installing the application, but always make
sure to run the installation program on the new servers to add them to the deployment.

For 400 Agent Deployments
Install the components on two VMs:
» VM-1: File server, Database server, Messaging server, Application server, Services server

» VM-2: Web Server
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For 400 Agent Deployments (HA)

Install the components on four VMs:

» On Side A:

O VM-1A: File server (Windows Distributed File System Nodel), Database server (Always On
Availability Group), Messaging server, Application server, Services server

O VM-2A: Web Server
» On Side B:

O VM-1B: Messaging server, Application server, Services server

(Already configured while setting up Side A and should not be installed again: File server (Windows
Distributed File System Node2), Database server (Always On Availability Group))

o VM-2B: Web Server

For 401-1500 Agent Deployments
Install the components on following VMs:
» VM-1: File server
» VM-2: Database server (active and master databases)
» VM-3: Database server (Reports database)
» VM-4: Messaging server
» VM-5: Services Server
» VM-6-VM10: Application server
» VM-11-15: Web Server

For 401-1500 Agent Deployments (HA)

Install the components on following VMs:
» On Side A:
O VM-1A: File server (Windows Distributed File System Nodel)
O VM-2A: Database server (active and master databases)
O VM-3A: Database server (reports database)
O VM-4A: Messaging server
O VM-5A: Services server
O  VM-6A to VM-10A: Application server
O VMA-11A to VM-15A: Web Server

» On Side B:
O VM-4B: Messaging server

O VM-5B: Services server
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O  VM-6B to VM-10B: Application server
O VM-11B to VM-15B: Web Server

(Already configured while setting up Side A and should not be installed again: VM-1B: File server
(Windows Distributed File System Node 2), VM-2B: Database server (active and master databases),

VM-3B: Database server (reports database))

For 401-2500 Agent Deployments

Install the components on following VMs:

»

4

4

VM-1: File server

VM-2: Database server (active and master databases)
VM-3: Database server (Reports database)

VM-4: Messaging server

VM-5: Services Server

VM-6-VM-8: Application server

VM-9- VM-11: Web Server

For 401-2500 Agent Deployments (HA)

Install the components on following VMs:

»

On Side A:
O VM-1A: File server (Windows Distributed File System Nodel)

o

VM-2A: Database server (active and master databases)

o

VM-3A: Database server (reports database)
O VM-4A: Messaging server

O VM-5A: Services server

O VM-6A to VM-8A: Application server

O  VMA-9A to VM-11A: Web Server

On Side B:

O VM-4B: Messaging server

O VM-5B: Services server

O VM-6B to VM-8B: Application server

o VM-9B to VM-11B: Web Server

(Already configured while setting up Side A and should not be installed again: VM-1B: File server
(Windows Distributed File System Node 2), VM-2B: Database server (active and master databases),

VM-3B: Database server (reports database))
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Installing ECE

This section talks about installing the application. In a distributed-server installation, repeat these tasks on all
VMs in your configuration.

To install ECE:

1. Start the installation by using the physical installation media or a mounted ISO file. Run setup.exe to
launch the installation program.

Alternatively, you can create a temporary directory on any drive on your server. For example, ¢:\ 7eunyp. Copy
the contents of the installation package to the 7eusp folder on your local machine where you are running the
installer. Run setup.exe from the ¢:\7emp\Application directory.

2. When the Introduction window appears, read the installation instructions. Click Next.

3. In the License Agreement window, review the licensing terms and select the I accept the terms of the
License Agreement option. Click Next.

oL, Enterprise Chat and Email M

License Agreement

™ Intreduction
License Agreement End User License Agreement

m|>

Installation Options
ECE Parameters IMPORTANT: PLEASE READ THIS END USER LICENSE AGREEMENT
— CAREFULLY. DOWNLOADING, INSTALLING OR USING CISCO OR
CISCO-SUPPLIED SOFTWARE CONSTITUTES ACCEPTANCE OF THIS
AGREEMENT.

Installing ECE Server,

aes 880

Installation Complete

CISCO I8 WILLING TO LICENSE THE SOFTWARE TO YOU ONLY UPON THE
CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS
LICENSE AGREEMENT. BY DOWNLOADING OR INSTALLING THE SOFTWARE,
OR USING THE EQUIPMENT THAT CONTAINS THIS SOFTWARE, YOU ARE
BINDING YOURSELF AND THE BUSINESS ENTITY THAT YOU REPRESENT
(COLLECTIVELY, "CUSTOMER") TO THIS AGREEMENT. IF YOU DO NOT AGREE
TO ALL OF THE TERMS OF THIS AGREEMENT, THEN CISCO IS UNWILLING TO
LICENSE THE SOFTWARE TO YOU AND (A) DO NOT DOWNLOAD, INSTALL OR
USE THE SOFTWARE, AND (B) YOU MAY RETURN THE SOFTWARE FOR AFULL
REFUND, OR, IF THE SOFTWARE I§ SUPPLIED AS PART OF ANOTHER PRODUCT,
YOU MAY RETURN THE ENTIRE PRODUCT FOR A FULL REFUND. YOUR RIGHT
TO RETURN AND REFUND EXPIRES 30 DAYS AFTER PURCHASE FROM CISCOOR. |~

Soapt the terms of 1he Libensa Agreement

to NOT 2502t the tems of the License Agreement

e [

Read and accept the terms of the License Agreement

4. In the Installation Options window, select from the following components. Make sure you select all the
components you wish to install. For details, see “Installation Overview” on page 79.

File Server
Messaging Server
Application Server
Web Server

Services Server

© 0 0O O o

Database
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Click Next.

k|

™ Introduction

™ License Agreement
A Installation Options
@ ECE Parameters

@ Summary

@ Installing ECE Server.
@ Installation Complete

Cancel

Enterprise Chat and Email [= | = [

Installation Options

Feature Set: |Custom

- [wfFile Server

[ [w]Database

<
Description

v

~

File Server
This option will install the file system component for Enterprise Chat and Email

= Back | |

Mext =

Select installation options

Based on the components you choose to install, you will see a different set of screens. The installation program
for ECE has on-screen help that describes the information that needs to be provided for each screen. If you need

to refer to the fields that each screen displays, see the following sections.

o

o O O O

o

5. Review the information displayed in the Summary window, and click Install.

File Server Details on page 84

Database Server Details on page 85

Web Server Details on page 90

Messaging Server Details on page 92

Application Server Details on page 93

Services Server Details on page 94

6. In the Install Complete window, click the Finish button to complete the installation process.

A summary of the installation is saved in
ECE_HoME\eServicelinstallation\logs\installation_summary_server Name.txt.

After the installation is completed, perform the post-installation tasks (page 95).

Installation Process

83



Installation Details

File Server Details

# Field Name

Description

Enterprise Chat and Email Home Directory

Value

1. File Server Directory/NAS
path/ DFS Path

Provide the path of the directory where you would like to
install Enterprise Chat and Email. For example,
Install _Drive\Cisco, or

\\SharedSpace\Cisco, if the file server is installed on a
NAS device or DFS.

Note: NAS is supported on non-HA environment while DFS
is supported on HA environment.

Make sure that the path and folder name do not contain
any of the following characters: *?<>|+"%",@

Domain User Account Parameters

2. Domain user name User name of the domain user account created for use by
the application. For more information, refer to “Setting Up
User Accounts and Permissions” on page 37. User name
should be provided in the format: Domain\username

3. Domain user password Password for the domain user.

File server details
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Database Server Details

# Field Name

File Sever Parameters

‘ Description

Value

1. File Server Name/NAS Path/
DFS Path

The fully qualified domain name of the file server. If the file
server is installed on a NAS device or DFS, provide the
path to the shared folder. For example,
\\SharedSpace\Cisco.

Note: NAS is supported on non-HA environment while
DFS is supported on HA environment.

Make sure you provide the DNS host name and not the IP
address of the server.

Cisco Application Context Root

2. Context Root Name

The name used to identify the document root of the Web
Server. The context root of a web application determines
which URLs are delegated to the web application.

Note: You should refrain from changing the value of the
Context Root Name to a non-default value as it disallows
users from accessing the ECE application URL and a 404
error is observed.

Also, make sure there are no spaces or special
characters in the name of the context root.

system

Cisco System Administrator Account

3. User name

4. Password

User name for the system administrator. This is the first
user that gets created for accessing the system partition.

Password for the system administrator.

Note: The password should have at least eight characters
and should be a mix of numbers and letters. For example,
passworda123.

Do not use the following characters in the password:
< (less than), > (greater than), ; (semi colon), : (colon),
= (equal to), \ (back slash)

sa

Cisco Partition Administrator Account and Partition Details

5. User name

User name for the partition administrator. This is the first
user that gets created for accessing the business
partition.

pa

6. Password

Password for the partition administrator.

Note: The password should have at least eight characters
and should be a mix of numbers and alphabets. For
example, passwordal123.

Do not use the following characters in the password:
< (less than), > (greater than), ; (semi colon), : (colon),
= (equal to), \ (back slash)
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# Field Name Description Value
7. Partition name Name for the business partition. Make sure that the name | default
does not contain any spaces or special characters. Also,
the partition name should be different than the context
root name.
8. Description of partition Description for the partition.
Installation Identifiers
9. Unique name for this Provide a unique name for this installation. For example:
installation PROD, PRD1, TEST, TST2, or DEMO. The length of the
name must be between 1 and 4 characters long. The
name must not contain any spaces or special characters.
10. 4-digit identifier for this Provide a 4-digit numerical value, between 2001 and 9998,
installation that will be used internally as system ID.
Knowledge Base Primary Language
11. | Knowledge Base Primary The default language for the Knowledge Base. English (US)

Language

Default Notification Parameters

12. | Default SMTP server

13. Notification mail redirection
from address

14. Notification mail redirection
to address

SOL Server Database Authentication

The SMTP server to be used to send email notifications.

All notification emails are sent from this email address.

All notification emails are sent to this email address.

15. | Authentication

Authentication type to be used while connecting to the
database. Set the value as SQL Server Authentication
mode or Windows Authentication mode. If you are using
MSSQL Server Always On Availability Group Clustering,
select the authentication type as Windows
Authentication.

Note: If you selected Windows Authentication as the only
mode of authentication while installing SQL Server, you
must set the value as Windows Authentication mode.

Master Database Parameters

16. | Server name

17. | Database name

Name of the local or remote server on which you want to
install the master database. If you are using MSSQL
Server Always On Availability Group clustering, specify
the Listener name (page 166).

Note: Make sure you provide the DNS host name and not
the IP address.

Name of the master database. The installation program
creates a database with the name you provide here.
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# Field Name Description Value
18. | Server instance name Name of the MSSQL Server instance to be used while
creating the database. Set this value only if you are using
a named instance, and not the default instance. If you are
using MSSQL Server Always On Availability Group
clustering, provide the name of the Listener instance.
Note: You can skip configuring this field when the value of
the Server name field is set as the Listener name.
19. | Database listener port Port number of the MSSQL Server or the Listener name. 1433/1444
20. | Datafile path Path to the folder on the database server, where you want
to create the data file. For example, D: \MSSQL\Data.
21. Datafile initial size (MB) Minimum size of the data file for the database. 100
22. Datafile maximum size (MB) Maximum size of the data file for the database. Unlimited
23. | Datafile increment size (MB) Additional file size limit that will be allocated to the 10
database after the initial size is full.
24. | Logfile initial size (MB) Minimum size of the log file. 25
25. Logfile maximum size (MB) Maximum size of the log file. Unlimited

26. Database administrator user
name

27. | Database administrator
password

28. | Cisco Database user name

User name of the database administrator for MSSQL
Server. If you have created a separate user for installing
Enterprise Chat and Email databases, provide the name of
that user (page 44).

Note: This property needs to be configured only if you are
using the SQL Server Authentication mode.

Password of the database administrator.

Note: This property needs to be configured only if you are
using the SAL Server Authentication mode.

User name required to connect to the master database.
The installation program creates the database and its
user.

29. | Cisco Database password

Active Database Parameters

Password for the master database user.

30. | Server name

Name of the local or remote server on which you want to
install the active database.

Note: It must be the same server on which the master
database is installed.

31. Database name

Name of the active database. The installation program
creates a database with the name you provide here.

32. Server instance name

Name of the MSSQL Server instance to be used while
creating the database. This should match the value set for
the master database instance name.

Note: You can skip configuring this field when the value of
the Server name field is set as the Listener name.
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# Field Name Description Value
33. | Database listener port Port number of MSSQL Server or the Listener Name. This | 1433/1444
should match the value set for the master database.
34. | Datafile path Path to the folder on the database server, where you want
to create the data file. For example, C:\MSSQL\Data.
35. | Datafile initial size (MB) Minimum size of the data file for the database. 2048
36. Datafile maximum size (MB) Maximum size of the data file for the database. Unlimited
37. Datafile increment size (MB) Additional file size limit that will be allocated to the 500
database after the initial size is full.
38. | Logfile initial size (MB) Minimum size of the log file. 1024
39. | Logfile maximum size (MB) Maximum size of the log file. Unlimited
40. | Database administrator user User name of the database administrator for MSSQL
name Server. If you have created a separate user for installing
Enterprise Chat and Email databases, provide the name of
that user (page 44).
Note: This property needs to be configured only if you are
using the SQL Server Authentication mode.
41. | Database administrator Password of the database administrator.
password Note: This property needs to be configured only if you are
using the SAL Server Authentication mode.
42. | Cisco Database user name User name required to connect to the database. The
installation program will create this user.
Note: This property needs to be configured only if you are
using the SQL Server Authentication mode.
43. | Cisco Database password Password for the database user.

Active Database Filegroup Parameters

Note: This property needs to be configured only if you are
using the SAL Server Authentication mode.

44.

Filegroup Datafile 1 Name

Provide the name of the first file group to be created for
the active database.

45.

46.

47.

Filegroup Datafile 1 Path

Filegroup Datafile 2 Name

Filegroup Datafile 2 Path

Provide the location for the first filegroup. Make sure you
provide the path to the drive that is created for storing file
groups.

Provide the name of the second file group to be created
for the active database.

Provide the location for the second filegroup. Make sure
you provide the path to the drive that is created for storing
file groups.

48.

Filegroup Datafile 3 Name

Provide the name of the third file group to be created for
the active database.

49.

Filegroup Datafile 3 Path

Provide the location for the third filegroup. Make sure you
provide the path to the drive that is created for storing file
groups.
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# Field Name

50. | Filegroup Datafile 4 Name

51. | Filegroup Datafile 4 Path

Reports Database Parameters

Description

Provide the name of the fourth file group to be created for
the active database.

Provide the location for the fourth filegroup. Make sure
you provide the path to the drive that is created for storing
file groups.

Value

52. | Server name

Name of the local or remote server on which the reports
database should be installed. If you are using MSSQL
Server Always On Availability Group clustering, specify
the Listener name for the reports database (page 166).

Note: Make sure you provide the DNS host name and not
the IP address of the server.

53. Database name

Name of the reports database. The installation program
creates a database with the name you type here.

54. Database server instance

Name of the MSSQL Server instance to be used while
creating the database. Set this value only if you are using
a named instance, and not the default instance.

> If you are using MSSQL Server Always On Availability
Group clustering, provide the name of the Listener
instance.

» Note: You can skip configuring this field when the
value of the Server name field is set as the Listener
name.

55. | Database listener port Port number of the MSSQL Server or the Listener Name. 1433/1444

56. | Datafile path Path to the folder on the database server, where you want
to create the data file. For example, D: \MSSQL\Data.

57. Datafile initial size (MB) Minimum size of the data file for the database. 1024

58. | Datafile maximum size (MB) Maximum size of the data file for the database. Unlimited

59. | Datafile increment size (MB) Additional file size limit that will be allocated to the 500
database after the initial size is full.

60. | Logfile initial size (MB) Minimum size of the log file. 512
Maximum size of the log file. Unlimited

61. Logfile maximum size (MB)

62. | Database administrator user
name

63. | Database administrator
password

User name of the database administrator for MSSQL
Server. If you have created a separate user for installing
Enterprise Chat and Email databases, provide the name of
that user (page 44).

Note: This property needs to be configured only if you are
using the SAL Server Authentication mode.

Password of the database administrator.

Note: This property needs to be configured only if you are
using the SQL Server Authentication mode.
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# Field Name Description Value

64. | Cisco Database user name User name required to connect to the reports database.
The installation program will create this user.

Note: This property needs to be configured only if you are
using the SQL Server Authentication mode.

65. | Cisco Database password Password for the database user.

Note: This property needs to be configured only if you are
using the SQL Server Authentication mode.

Reports Database Filegroup Parameters

66. | Filegroup Datafile 1 Name Provide the name of the first file group to be created for
the reports database.

67. | Filegroup Datafile 1 Path Provide the location for the first filegroup. Make sure you
provide the path to the drive that is created for storing file
groups.

68. | Filegroup Datafile 2 Name Provide the name of the second file group to be created

for the reports database.

69. | Filegroup Datafile 2 Path Provide the location for the second filegroup. Make sure
you provide the path to the drive that is created for storing
file groups.

70. | Filegroup Datafile 3 Name Provide the name of the third file group to be created for

the reports database.

71. | Filegroup Datafile 3 Path Provide the location for the third filegroup. Make sure you

provide the path to the drive that is created for storing file
groups.
72. | Filegroup Datafile 4 Name Provide the name of the fourth file group to be created for

the reports database.

73. | Filegroup Datafile 4 Path Provide the location for the fourth filegroup. Make sure
you provide the path to the drive that is created for storing
file groups.

Domain User Account Parameters

74. | Domain user name User name of the domain user account you created for
use by the application. For more information, refer to
“Setting Up User Accounts and Permissions” on page 37.
User name should be provided in the format:
Domain\username

75. | Domain user password Password for the domain user.

Database server details

Web Server Details

The installation program automatically installs and configures IIS on the web server. If IIS is already installed, it
will be used by the application. The installation program will check to see if all the required components and
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extensions are available. If not, it will prompt for confirmation to make changes to IIS. If you prefer to make
these changes manually, follow instructions in “Preparing Web Server VMs” on page 48.

# Field Name Description Value

Application Server Parameters

1. Application server name Type the name of the application server for which you want
to configure the web server.

Note: Make sure you provide the DNS host name and not
the IP address of the server.

2. Jetty HTTP Port Jetty HTTP listener port of the application server where all
the HTTP requests are handled.

Note: This port should match the port number provided
while installing the application server (page 93).

Enterprise Chat and Email Directory

3. Enterprise Chat and Email Provide the path of the directory where you would like to
Home Directory install ECE. For example, Znsall _Drive\Cisco.

Note: Make sure that the path and folder name do not
contain any of the following characters: *?<>|+A"%",@

1IS Web Site Parameters

4. IIS Web Site Name Name of the IIS Web Site on which the application is to be | Default Web Site
configured.

Cisco Application Context Root

5. Context Root Name Provide the same context root name which was provided at
the time of installing the Cisco database server (page 85).

Cisco Partition Name

6. Partition Name Provide the name for the business partition. Make sure you
provide the same name which was provided at the time of
installing the Cisco database server (page 85).

Domain User Account Parameters

7. Domain user name User name of the domain user account you created for use
by the application. For more information, refer to “Setting
Up User Accounts and Permissions” on page 37. User
name should be provided in the format: Domain\username

8. Domain user password Password for the domain user.

Web server details
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Messaging Server Details

The installation program automatically installs and configures JDK and ActiveMQ as part of the installation.
These software are installed in the ECE Home directory. For example, Zustall, _Drive\Cisco\jdk.

# Field Name Description Value

File Server Parameters

1. File Server name/NAS Path/ | The fully qualified domain name of the file server. If the file
DFS Path server is installed on a NAS device or DFS, provide the path
to the shared folder. For example,
\\SharedSpace\Cisco.

Note: NAS is supported on non-HA environment while DFS
is supported on HA environment.

Make sure you provide the DNS host name and not the IP
address of the server.

Enterprise Chat and Email Home Directory

2. Enterprise Chat and Email Provide the path of the directory where you would like to
Home Directory install Enterprise Chat and Email. For example,

Install Drive\Cisco. The installation program also

installs ActiveMQ and JDK at the same location.

Note: Make sure that the path and folder name do not
contain any of the following characters: *?<>|+A"%",@

ActiveMQ Parameters

3. ActiveMQ Port ActiveMQ listener port used by JMS clients to connect to 15097
ActiveMQ messaging server. The port number can be
between 1024-65535.

4. Admin ActiveMQ Port ActiveMQ Admin listener port used for administering and 15096
monitoring resources on the server. The port number can
be between 1024-65535.

Domain User Account Parameters

5. Domain user name User name of the domain user account you created for use
by the application. For more information, refer to “Setting
Up User Accounts and Permissions” on page 37. User
name should be provided in the format:
Domain\username

6. Domain user password Password for the domain user.

Messaging server details
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Application Server Details

The installation program automatically installs and configures JDK and Jetty as part of the installation. These
software are installed in the ECE Home directory. For example, Zustall, _Drive\Cisco\jdk.

# Field Name Description Value

File Server Parameters

1. File Server name/ NAS The fully qualified domain name of the file server. If the file
Path/ DFS Path server is installed on a NAS device or DFS, provide the path to
the shared folder. For example, \\SharedSpace\Cisco

Note: NAS is supported on non-HA environment while DFS is
supported on HA environment.

Make sure you provide the DNS host name and not the IP
address of the server.

Enterprise Chat and Email Home Directory

2. Enterprise Chat and Provide the path of the directory where you would like to install
Email Home Directory ECE. For example, Znstall Drive\Cisco. The installation
program also installs Jetty and JDK at the same location.

Note: Make sure that the path and folder name do not contain
any of the following characters: *?<>[+1"%",@

Jetty Parameters

3. Jetty HTTP port Jetty HTTP listener port where all the HTTP requests are 9001
handled. The port number can be between 1024-65535.

4. Jetty HTTP SSL Port Jetty HTTPS listener port where all the SSL requests are 9002
handled. The port number can be between 1024-65535.

5. Jetty Stop Port Jetty shutdown command listener port. This port is used for 15095
issuing shutdown command to stop Jetty. The port number can
be between 1024-65535.

Domain User Account Parameters

6. Domain user name User name of the domain user account you created for use by
the application. For more information, refer to “Setting Up User
Accounts and Permissions” on page 37. User name should be
provided in the format: Domain\username

7. Domain user password Password for the domain user.

Application server details
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Services Server Details

The installation program automatically installs and configures JDK as part of the installation. JDK is installed in
the ECE Home directory. For example, Znstall,_Drive\Cisco\jdk.

# Field Name Description Value

File Server Parameters

1. File Server name/NAS Path/ | The fully qualified domain name of the file server. If the file
DFS Path server is installed on a NAS device or DFS, provide the path
to the shared folder. For example, \\SharedSpace\Cisco

Note: NAS is supported on non-HA environment while DFS
is supported on HA environment.

Make sure you provide the DNS host name and not the IP
address of the server.

Enterprise Chat and Email Home Directory

2. Enterprise Chat and Email Provide the path of the directory where you would like to
Home Directory install ECE. For example, Zustall Drive\Cisco. The
installation program also installs JOK at the same location.

Note: Make sure that the path and folder name do not
contain any of the following characters: *?<>|+1"%",@

RMI and RMID Parameters

3. RMI registry port Port number used by the Remote Method Invocation (RMI) | 15099
registry naming service.

4. RMI activation port Port number used by the RMI Daemon Process. 15098

Organization Information

5. Name Provide the name of the organization. Make sure that the
name does not contain any special characters.

6. Business Unit Provide the business unit name. Make sure that the value
does not contain any special characters.

7. Location Provide the location of your organization. Make sure that
the value does not contain any special characters.

8. Country Select the country from the dropdown list.

Domain User Account Parameters

9. Domain user name User name of the domain user account you created for use
by the application. For more information, refer to “Setting
Up User Accounts and Permissions” on page 37. User name
should be provided in the format: Domain\username

10. | Domain user password Password for the domain user.

Services server details
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Post-Installation
Tasks

Configuring Permissions on |IS Config Folder
Assigning Permissions on ECE Home Directory
Configuring SSL for Secure Connections
Always On Availability Group Clustering Tasks
Creating an Encrypted SQL Server Database
Configuring SMTP Server Relay Address List
Configuring Finesse

Configuring Single Sign-0n

Starting ECE

Stopping ECE

Signing in to ECE

Integrating ECE with Unified CCE

Configuring Important Settings

Configuring Clickjacking Protection



» Adding Data Source in CUIC for ECE Reports

» Uninstalling ECE
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This chapter guides you through the tasks to be performed after installing the system. It also describes the
process of uninstalling ECE.

Configuring Permissions on IIS Config Folder

»  Skip this task if it was done as part of the pre-installation tasks (page 50). Ensure that the user account that
you used for installing the application (page 37) has read permissions on the following folder on the web
server: Zsystemroot/\system32\inetsrv\config.

Assigning Permissions on ECE Home Directory

The Service Account created for running the ECE application needs Full Control permission on the ECE home
directory. You must perform this task on the file server before starting the application.

To assign permissions on the ECE home directory:

1. Right-click the ECE home directory.

2. Select Properties.

3. In the Properties window, go to the Sharing tab and click Advanced Sharing.
4. In the Advanced Sharing window, click Permissions.
5

In the Permissions window, click the Add button and add the Service Account (page 37) created for ECE.
Assign the Full Control permission to the user.

» Click Apply.

Configuring SSL for Secure Connections

» You must set up Secure Sockets Layer (SSL) for more secure connections between browsers and the servers
in your installation. This is a required step. See “SSL Configuration” on page 139 for details.

Always On Availability Group Clustering Tasks

» Perform all the tasks listed in “Post-Installation Tasks” on page 168.
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Creating an Encrypted SQL Server Database

This is an optional task and you need to do it only if you want to encrypt the databases. This feature is available
only for the Enterprise edition of MSSQL. You can do this task any time after installing the ECE application.

If you are using Always On Availability Group clustering, perform this task on all the nodes.

Encrypting Primary Node

Perform these tasks on the primary node.

To create an encrypted SQL server database:

1. Create a master key in the master database. This key is then used to create the server certificate that can be
used to secure the database encryption key. Connect to the master database and run the following query.

USE master
GO
CREATE MASTER KEY ENCRYPTION BY PASSWORD = 'companyal23'
GO

2. Backup the master key. This creates a certificate in the master database.
BACKUP MASTER KEY TO FILE = 'c:\temp\masterkey'

ENCRYPTION BY PASSWORD = 'companyal23’

GO

3. Now create the server certificate database encryption key ("DEK").
USE master
GO
CREATE CERTIFICATE DEKCert WITH SUBJECT = 'DEK Certificate'
GO

4. Create a backup of the server certificate database encryption key (“DEK”).
BACKUP CERTIFICATE DEKCert TO FILE = 'c:\DEKCert'

WITH PRIVATE KEY ( FILE = 'c:\temp\DEKCertPrivKey' ,
ENCRYPTION BY PASSWORD = 'companyal123' )
GO

5. Create database encryption key for the database where you wish to configure transparent data encryption. In
the following query, eGActiveDB _name is the name of the active database.

USE egActiveDB_name

GO

CREATE DATABASE ENCRYPTION KEY

WITH ALGORITHM = AES_128

ENCRYPTION BY SERVER CERTIFICATE DEKCert
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GO

You now have all the prerequisites for enabling transparent data encryption, so database encryption can be
enabled.

6. Enable database encryption. Run the following query where eGActiveDB name is the name of the active
database.

ALTER DATABASE eGActiveDB _name SET ENCRYPTION ON

By setting encryption on, a background task starts encrypting all the data pages and the log file. This can
take a considerable amount of time, depending on the size of the database.

Database maintenance operations should not be performed when this encryption scan is running.

7. To query the status of the database encryption and its percentage completion, query the new
sys.dm_database_encryption_keys DMV
SELECT DB_NAME(e.database_id) AS DatabaseName,
e.database_id,
e.encryption_state,
CASE e.encryption_state
WHEN O THEN 'No database encryption key present, no encryption'
WHEN 1 THEN 'Unencrypted'
WHEN 2 THEN 'Encryption in progress'
WHEN 3 THEN 'Encrypted'
WHEN 4 THEN 'Key change in progress'
WHEN 5 THEN 'Decryption in progress'
END AS encryption_state_desc,
c.name,
e.percent_complete
FROM sys.dm_database_encryption_keys AS e
LEFT JOIN master.sys.certificates AS ¢

ON e.encryptor_thumbprint = c.thumbprint

Encrypting Other Nodes

To encrypt other nodes:
1. Copy the c:\temp folder from the first node to the other nodes.

2. Create a master key in the master database. This key is then used to create the server certificate that can be
used to secure the database encryption key. Connect to the master database and run the following query.

USE master

GO

CREATE MASTER KEY ENCRYPTION BY PASSWORD = 'companyal123'
GO
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3. Now create the server certificate.
USE master
GO
CREATE CERTIFICATE TDE_Test_Cert FROM FILE = 'c:\temp\DEKCert'
WITH PRIVATE KEY (FILE = 'c:\temp\DEKCertPrivKey',
DECRYPTION BY PASSWORD = 'companyal123'); GO

4. Enable database encryption. Run the following query where eGActiveDB _nameis the name of the active
database.

ALTER DATABASE egActiveDB _name SET ENCRYPTION ON

By setting encryption on, a background task starts encrypting all the data pages and the log file. This can
take a considerable amount of time, depending on the size of the database.

Database maintenance operations should not be performed when this encryption scan is running.

5. To query the status of the database encryption and its percentage completion, query the new
sys.dm_database_encryption_keys DMV

SELECT DB_NAME(e.database_id) AS DatabaseName,
e.database_id,
e.encryption_state,
CASE e.encryption_state
WHEN O THEN 'No database encryption key present, no encryption'
WHEN 1 THEN 'Unencrypted'
WHEN

THEN 'Encryption in progress'

WHEN

2

WHEN 3 THEN 'Encrypted'
4 THEN 'Key change in progress'
5

WHEN THEN 'Decryption in progress'
END AS encryption_state_desc,

c.name,

e.percent_complete
FROM sys.dm_database_encryption_keys AS e
LEFT JOIN master.sys.certificates AS ¢

ON e.encryptor_thumbprint = c.thumbprint

Configuring SMTP Server Relay Address List

» The default SMTP server configured during the installation process is used to send notifications.

To allow the system to successfully send such emails, verify that the IP addresses of all the application
servers in the configuration are added to the relay address list of the SMTP server.
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Configuring Finesse

Perform these tasks after installing ECE. Cisco Finesse enables the use of custom gadgets for Voice &
Multichannel (ECE), facilitating the ECE user interface to be embedded within a gadget to provide contact
center agents a unified desktop experience.

7\ Important: Before you begin the configuration, ensure that the Finesse VM and software are
% installed and ready for use. Also, ensure that ECE is installed.

Configuring Finesse Files

You need to perform these tasks only if you are using a load balancer for the web servers.

To configure the ece_config.js file:

1. On the ECE web server, open the
ECE _tHome\eService\templates\finesselgadget\agent\ece_config.js file in a text editor.

2. Locate the following property in the file: var web_server_name =

3. Replace the value of the property with the host name of the load balancer used for the installation.

Configuring Finesse Settings and Layout

Perform these tasks from any local machine. You will need access to the following xml files on the ECE web
server:

» ECE Home\eServiceltemplates\finesselgadget\layout:
O agent.xml
O solve.xml
O cobrowse.xml

To configure the Finesse settings and layout:

1. Launch the URL: https:// Fnesse Server Namel cfadmin Login as a finesse administrator.
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2. Configure the Contact Center CTI Server Settings and Contact Center Enterprise Administration & Data
Server Settings. To configure a secure connection, select the Enable SSL encryption option in the Contact
Center CTI Server Settings section and provide the secure ports. For details about doing this configuration,
see the Cisco Finesse Administration Guide.

alnaln
CIsco

Cisco Finesse Administration Sign Out

Contact Center Enterprise Administration & Data Server Settings

Contact Center Enterprise Administration & Data Server Settings
y
\ Primary Host/IP Address 0.10.29.8 Domain poe
Call
Variables Backup Host/IP Address Usemame administrator
Layouts
Database Port 433 Password
AW Database Name em115_awdb
Revert
Contact Center Enterprise CTI Server Settings
Contact Center Enterprise CT| Server Settings
Reasons A Side Host/IP Address 0.10.28.179 B Side Host/IP Address
FH A Side Port 42067 B Side Port
Team Peripheral 1D 5000
Resources
able encryption

Test Connection

Configure the settings

3. From the Desktops Layout section, configure the layout for ECE, Solve, and Cobrowse gadgets. XML
contents for the ECE, Solve, and Cobrowse gadget tabs are available in the following files on the ECE web
server:

O ECE tHome\eServiceltemplates\finesselgadget\layout\agent.xml: After copying the
content of the agent.xml file, in the gadget tag, replace the web server name with the host name of
the load balancer used for ECE web servers. This task needs to be performed only if you are using a
load balancer for ECE web servers.

O ECE_tHome\eServiceltemplates\finesselgadget\layout\solve.xml: After copying the
content of the solve.xml file, make the following changes in the gadget tag:

i. Replace EGAIN_WEBSERVER_OR_LOADBALANCER with the eGain Solve for Cisco web server. If the
installation has more than one web servers, provide the name of the load balancer.

ii. Replace CONTEXT_ROOT with the context root of eGain Solve for Cisco.

O ECE tHome\eServiceltemplates\finesselgadget\layout\cobrowse.xml: You need to
configure this only if you are using the Cobrowse gadget in Finesse. After copying the content of the
cobrowse.xml file, make the following changes in the in the gadget tag:

i. Replace the EGAIN_WEBSERVER_OR_LOADBALANCER with the eGain Solve for Cisco web server. If
the installation has more than one web servers, provide the name of the load balancer.
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ii. Replace the CONTEXT_ROOT with the context root of eGain Solve for Cisco.

Refer the Finesse documentation to see how gadgets are added in Finesse.

Configuring Single Sign-On

» Single sign-on is available for all users of the application. For details about doing this task, see the
Enterprise Chat and Email Administrator’s Guide to Administration Console (For UCCE). If you are
planning to use single sign-on while accessing any of the ECE consoles outside of Finesse, you must also
complete the tasks in the section: “Single Sign-On Configuration” on page 113.

Starting ECE

There is no mandatory sequence that should be followed while starting ECE. All the VMs on which components
are installed should be running and available on the network.

@ Important: Run the application using the same domain account that was used for installing
2/ the application (page 37).

To start ECE:

If you get the following error while starting the Cisco Service, see “Troubleshooting Application Start-Up
Issues” on page 104: Error 1069: The service did not start due to login failure.

@ Important: The CISCO service cannot be restarted via the Windows Service Manager. Instead,
% to restart the service, you can stop it and then start it again.

» In collocated installation:

O On the server where application, messaging, services, file, and database components are installed, start
the Cisco Service from the Windows Services panel.

» In a distributed-server installation:
Ensure that all the VMs in the configuration are available and connected to the network.

a. Start Cisco Service on the messaging server by starting the Cisco Windows service from the Windows
Services panel. If you have installed a cluster of messaging servers, you would need to start the
application on all the servers in the cluster.

b. On each services server, start the application by starting the Cisco Windows service from the Windows
Services panel.

c.  On each application server, start the application by starting the Cisco Windows service from the
Windows Services panel.
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Troubleshooting Application Start-Up Issues

Perform these tasks if you get the following error while starting the Cisco service: Error 1069: The
service did not start due to login failure.

To troubleshoot:
1. In the Windows service panel, right-click the Cisco Service and from the menu select Properties.

2. In the Properties window, go to the Log On tab and provide the password of the domain user account
(page 37) and click Apply.

3. Start the Cisco Service.

Stopping ECE

If you need to stop the application at any point during the post-installation tasks, follow the steps in this section.

In a distributed environment, stop the application on the following servers. There is no mandatory sequence that
should be followed while stopping the application.

» The application servers
» The messaging servers

» The services servers

To stop ECE:

» In a collocated installation:

O On the server where application, web, messaging, services, file, and database components are installed,
stop the Cisco Service from the Windows Services panel.

» In a distributed-server installation:

a. On each application server VM, stop the Cisco Service from the Windows Services panel. Open the
Windows Task Manager and verify that none of the java processes are running.

b. On the messaging server VM, stop the Cisco Service from the Windows Services panel. If you have
installed a cluster of messaging servers, you would need to stop the application on all the servers in the
cluster. Open the Windows Task Manager and verify that none of the java processes are running.

c.  On each services server VM, stop the Cisco Service from the Windows Services panel. If you have
installed two services servers, stop the application on both servers. Open the Windows Task Manager
and verify that none of the java processes (the services) are running.
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Signing in to ECE

Signing in to Agent Console

To sign in to the Agent Console:

1.

Ensure that the desktops meet the requirements outlined in System Requirements for Enterprise Chat and
Email.

Access the Finesse URL from a browser and sign in to Finesse: https:// Finesse Server Namel desktop

Click on the Manage Chat and Email tab. If Single Sign-On is enabled, then the agent will be logged in
automatically. If not, enter the username and password and click Sign In.

Signing in to All Other Consoles

A system partition and a business partition are created during the installation. To begin using the application, you
log in to the business partition.

To sign in to the business partition:

1.

Ensure that you have followed the instructions in the Enterprise Chat and Email Browser Settings Guide
document to configure your browser, and that the desktops meet the requirements outlined in System
Requirements for Enterprise Chat and Email.

Type the URL http:// Weé_:ermww.com/ Partition, name in your browser, where
Weé_:eruenww.com is the fully qualified domain name of your web server and Partition, name is the
virtual directory created for this partition. During the installation, you are prompted to provide the partition
name in the Partition Administrator Account and Partition window. This is used to create the virtual
directory. If you have configured the web server to use SSL, then the URL is

https:// Waé_fermcow‘wm/ Partition, name.

Always use the fully qualified domain name of the web server when you type the URL to access ECE.

In the Sign In window, type the user name and password you had set up for the partition administrator in the
Partition Administrator Login Parameters window during the installation. Click the Log In button.

Integrating ECE with Unified CCE

Integration between ECE and Unified CCE is enabled and configured through the Administration Console.

To integrate ECE with Unified CCE:

1.
2.

In the global-level Top menu, click the Integration option.

In the Left menu, navigate to Unified CCE > Unified CCE.
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3. In the Unified CCE Details space, under the AWDB Details tab, provide the following details for the
Primary AWDB. If any of these configurations change at a later point in Unified CCE, you must update the
details here as well.

O  Authentication: Select from Windows Authentication or SQL Authentication.

O Unified CCE Administration Host Name: The server name or IP address of the Unified CCE host.
O Active: Set to Yes.

O  SQL Server Database Name: The name of the AWDB database.

O Port Number: Set the value to match the port configured in Unified CCE. By default the value is set to
1433.

O Database Administrator Login Name: The database administrator’s user name. This value needs to be
set only when using SQL Authentication.

o Database Administrator Login Password: The database administrator password. This value needs to
be set only when using SQL Authentication.

O Maximum Capacity: The maximum number of allowed connections to be made to the AWDB. By
default, this is set to 360.

Unified CCE Details: Unified CCE
General AWDE Details
Primary AWDB
Authentication® SQL Server Authentication w

Unified CCE Administration Host B
host.domain.com

Name*

Active [ @)

SQL Server Database Name* cm125_awdb
Port Number* 1433

Database Administrator Login

\ sa
Name*

Database Administrator Login
Password*

Maximum Capacity* 360

Provide the primary AWDB server details

4. If you have a secondary AWDB and wish to apply it to your integration, provide the necessary details in the
Secondary AWDB section.

5. Click the Save button.

6. Under the Configuration tab, set the following:

O  Select the Application Instance.
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O Click the Add @ button to select the Agent Peripheral Gateways that apply.

@ Important: When you save your changes, your system is permanently connected to your Uni-
% fied GCE installation. This cannot be undone.

Unified CCE Details: Unified CCE

Application Instance

Agent Peripheral Gateways (1]

Name

Provide configuration details

7. Click the Save button. Your system is now connected with Unified CCE. To complete the integration, you
must configure your media classes. and import the MRDs users and skill groups from the Unified CCE
system. For details about doing this task, see the Enterprise Chat and Email Administrator’s Guide to
Administration Console.

Note: For PCCE 2K deployment, application Instance with the name “MultiChannel” is created
@ automatically and is required while integrating with ECE via Administration console.
For 4K/12K deployment, an application instance is created manually, and there is no restriction on the
nomenclature for the application instance. The process is same as of integrating ECE with UCCE

Configuring Important Settings

This section introduces the main settings that allow you to configure various aspects of the application. Some
settings are configured at the partition level, while others have to be set up for each department.

These settings are of two types:

1. Mandatory settings: These settings are configured during installation, and must be verified before using the
application. Settings related to ESMTP protocol, must be configured manually if you are using ESMTP
protocol for email notifications.

2. Optional settings: Although it is not mandatory to change these settings, you are likely to feel the need to
configure them for your business.
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Mandatory Settings

At the partition level
Navigate to Partition > Apps > General Settings and configure the following setting:
» External URL of Application

The following settings are updated during installation, but we recommend that you log in to the application as a
partition administrator, and verify and update them from the Administration Console, if required. The application
starts using this information as soon as the installation is complete.

» Default SMTP Server Settings
» From: address for notification from Service

» To: address for notification from Service

At the department level

This setting is automatically updated for the first department created by the installation program. For all
subsequent departments, the administrator must configure it.

» From email address for alarm

Optional Settings

Although it is not mandatory to change these settings, you are likely to feel the need to configure them for your
business.

At the partition level
» Customer departmentalization
» Session time out
» Inactive time out

» Chat auto-pushback settings

At the department level
» Business calendar time zone
» Autopushback time (minutes after logout)

For a complete list of all available settings, refer to the Enterprise Chat and Email Administrator’s Guide to
Administration Console.
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Configuring Clickjacking Protection

About Clickjacking Protection

Clickjacking is a malicious technique of tricking a web user into performing an unwanted action unintentionally
by rendering invisible page elements like hyperlinks underneath legitimate clickable content. These attacks are
done to reveal confidential and sensitive information or to gain control of the victim’s system.

The Clickjacking Protection is a self-service feature. It provides an option to configure the desired domains that
are allowed to embed the applications like ECE Agent Console, in an iframe, in the Finesse Desktop.

Configuring Clickjacking Protection

In the Web Server, IIS Outbound rules can now be modified manually to allow framing for desired parent
domains only.

1.

A

7.
8.

On the web server, click the Start menu, go to Control Panel > Administrative Tools, and select Internet
Information Services (IIS) Manager.

In the Connections pane, select the name of the server and browse to Sites > Wes  Site. Name. Please note
that the web_site Name would be the IIS website used for ECE deployments.

In the Actions pane on the right, from the Edit Site section, click the Basic Settings... link.
In the Edit Site window, the Physical Path field defines the path for the web.config file.
Browse to the location on your local drive and open the web.config file in a text editor.

To allow domainl\.com and domain2\.com, replace all occurrences of following string:
wsname=((http[s]?)(:| % 3A)(/| % 2F)(/| % 2F)([_0-9a-z-.@: % \+~#=]*)) with the following string:
wsname=((http[s]?)(:| % 3A)(/| %2F)(/| % 2F)([a-z0-9.]+?)(domain1\.com|domain2\.com)(&amp;| %26|$))

Note that the domains to be allowed are specified in simple brackets and are separated by the | character.
Save changes to the file.

Restart IIS.

In the IIS Manager, verify that for all the outbound rules that are applied to the headers or the content of the
HTTP response, the wsname query parameter has been updated.

Adding Data Source in CUIC for ECE Reports

The following ECE reports can be accessed in the Cisco Unified Intelligence Center (CUIC) via historical

templates:
» Chat Volume by Queue
» Email Volume By Queue
» Agent Work Summary
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To access these reports from CUIC, you need to add the ECE Reports Database as a data source in CUIC.

Creating a Database User on ECE Reports Database

If the reports database is part of the always-on group, create the database login with the same name on all nodes
of the cluster starting with the current primary node and map database login to reports database of each node.
Refer to the Microsoft documentation for maintaining SQL logins and permissions for user databases in always
on cluster.

To create a database user on ECE reports database:
1. Create a SQL login on the reports database server, for example, ReportsDataReader.
2. Create a new role on the reports database server:
CREATE ROLE db_executor;
GRANT EXECUTE TO db_executor;
3. Map the user to the ECE reports database and set the Default Schema as dbo.
4. Assign the following database role memberships to the database user ReportsDataReader:
O public
O db_datareader

O db_executor

B Login Properties - ReportsDataReader - m] *
Selecta page IT Seript ~ @) Help
K General
& Server Roles
& Lser Mapping Users mapped to this login
& Securables Map Database User Default Schema -
£ Status IH egdb_mairte
[0  eGMasterDB
[0  eGMasterDB
IH eGMasterDB
O eGReportsDB
O eGReportsDE...
eGReportsDB. ReportsDataReader
[0  master
[0  model
IH madb
O tempdb
‘Connection 2
Server:
Database role membership for: eGReportsDB_126es1
Connection [] db_accessadmin
USSUHVVMO685 Administrator [] db_backupoperator
¥ View connection properties | [[] db_datareader
[ db_datawriter
[] db_ddladmin
[] db_denydatareadsr
[] db_denydatawriter
Progress e
[] db_owner
Ready [] db_securityadmin
[ public

Cancel

Create a database user
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Adding Data Source in CUIC for ECE Reports

See the Cisco Unified Intelligence Center Report Customization Guide for steps on adding a data source in
CUIC.

Make sure you set the following values on the data source details page:

» In the Datasource Host field, provide the name of the server where the ECE reports database is installed. In
case of always on cluster for reports database, connect to the reports database using always on default cluster
name or load balancer name.

» In the Database name field, provide the name of the ECE reports database.

» In the Database User ID field, provide the name of the SQL user created on the ECE reports database
server (page 110).

Uninstalling ECE

The application needs to be uninstalled from the following servers. The uninstallation program can be run in any
order on these servers.

» Application Server
» Messaging Server
» Services Server
» Web Server
» File Server
To ensure that critical data is not lost, the program does not uninstall the following components:
» The databases
» The following folders on the file server:
e FCE HOMFE\eService\lstorage

o FCE HOME\eService\logs

@ Important: After the uninstaller runs on all the servers, you must delete these components
3 manually to make the servers ready for the reinstallation of ECE on the same servers.

Preparing to Uninstall

Stopping the Application

» Before you begin the uninstallation process, make sure you stop ECE. For details, refer to “Stopping ECE”
on page 104.
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Stopping lIS

4

Stop IIS (World Wide Web Publishing Service) on all web servers in the installation.

Uninstalling ECE

To uninstall ECE:

1.

2
3.
4

e

Go to Start > Settings > Control Panel.
Click Programs in the Control Panel window.
Click Programs and Features in the Programs window.

From the list of currently installed programs, right-click Enterprise Chat and Email and select
Uninstall/Change.

In the Uninstall Enterprise Chat and Email window, click the Uninstall button.

When the uninstallation is complete, you are given a choice of restarting the server right away, or doing it
later.

On the database server, go to the SQL Server Management Studio and delete the following, if required.
O Go to Databases and delete the databases.
O  Go to Security > Logins and delete the logins created for the databases.

O Go to SQL Server Agent > Jobs and delete the SQL Jobs for the databases. The jobs related to your
databases will have the database name in the end. For example, populate smy_eGReportsDB.

On the file server, manually delete the following folders:
O ECE _HOME\eServicelstorage

O ECE_HOME\eService\logs

Performing Post Uninstallation Tasks

Starting lIS

»

Start IIS (World Wide Web Publishing Service) on all web servers in the installation.
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7\ Important: Perform these tasks only if you are planning to use single sign-on while accessing
: any of the ECE consoles outside of Finesse.

About Single Sign-On with Cisco IDS

Single Sign-On with Cisco IDS requires that ECE is connected to Active Directory Federation Services (AD FS).
You can use one of the following options for AD FS:

» Single AD FS: In a single AD FS deployment, Resource Federation Server and Account Federation Server

are installed on the same machine (page 114).

Split AD FS: In a split AD FS deployment, Resource Federation Server and Account Federation Server are
installed on separate machines (page 122).

Configuring Single AD FS Deployment

In a single AD FS deployment, Resource Federation Server and Account Federation Server are installed on the
same machine.

Configuring Relying Party Trust for ECE

Perform these tasks on the server where Resource Federation Server and Account Federation Server are installed.

To configure relying party trust for ECE in single AD FS:

1. Go to the Start menu and open AD FS Management console.

2. In the AD FS Management console, navigate to AD FS > Trust Relationships > Relying Party Trust.
3. In the Actions section, go to Relying Party Trust, and click Add Relying Party Trust...
O ADFS (==
!@ File Action View Window Help
% 2E H
L - Service Display Name Enabled Type RelyingRa s -
4 [ Tiust Reletionships Add Relying Party Trast..
Add Mon-Claims-Aware Relying...
| Attribute Stores Vi N
a || Authentication Policies e
“| Per Relying Party Trust MNew Window from Here
G Refresh
ﬂ Help =
4.

In the Add Relying Party Trust Wizard that appears, do the following:

a. On the Welcome screen, click Start.
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b. On the Select Data Source screen, select the Enter data about the reply party manually option and

click Next.

@
@
@
@
@
@
@
@

® ®

Select Data Source

Steps

Welcome

Select Data Source
Specify Display Name
Choose Profile
Corfigure Certificate
Corfigure URL
Conrfigure |dentfiers

Configure Muttifactor
Authentication Now?

Choose lssuance
Authorization Rules

Ready to Add Trust
Finish

Add Relying Party Trust Wizard .

Select an option that this wizand will use to obtain data about this relying party:

) Import data about the relying party published online or on a local network

Use this option to import the necessary data and certfficates from a relying party organization that publishes
its federation metadata online or on a local network.

Federation metadata address (host name or URL):

Example: fs.contoso.com or hitps://www contoso.com/app

O Import data about the relying party from a file

Use this option to import the necessary data and certificates from a relying party organization that has
exported its federation metadata to afile. Ensure that this file is from a trusted source. This wizard will not
validate the source of the file

Federation metadata file location:

Enter data about the relying party manually
ECessary data about this relying party organization.

‘ < Previous H Next > H Cancel

Select the Enter data about the reply party manually option

c.  On the Specify Display Name screen, provide a Display name for the relying party. Click Next.
s Add Relying Party Trust Wizard =T
Specify Display Name
Steps Enter the display name and any optional notes for this relying party.

@ Welcome Digplay name:

@ Select Data Source vawS5 Console]

@ Specify Display Name Notes:

@ Choose Profile ~
@ Configure Certflicate

@ Configure URL

@ Configure Idertifiers

@ Configure Multifactor v

[ ]

e @

Authentication Now?

Choose Issuance
Authorization Rules

Ready to Add Trust
Finish

< Previous | | Nexd > | | Cancel

Provide a display name
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d. On the Choose Profile screen, select AD FS profile and click Next.

L

Choose Profile

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Corfigure Certfficate
@ Corfigure URL

@ Corfigure Identifiers

@ Configure Multifactor
Authertication Now?

@ Choose lssuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Add Relying Party Trust Wizard

This wizard uses corfiguration profiles to aid in creating the relying party trust. Choose the appropriate
Garetrerromete-Eacthis refying party trust.

poTTs relying parties that are interoperable with new AD FS features, such as
ryption and the SAML 2.0 protocol

(O ADFS 1.0and 1.1 profile
This profile supports relying parties that are interoperable with AD FS 1.0and 1.1

< Previous | | Nexd > | | Cancel

Select AD FS profile

e. On the Configure Certificate screen, click Next.

f.  On the Configure URL screen, set the following:
i. Select the Enable support for the SAML 2.0 Web SSO protocol option.

ii. In the Relying Party SAML 2.0 SSO server URL field provide the URL in the format:
https:// Web Server Or lLoad, Balancer Serverl/system/SAML/SSO/POST.controller.
Replace Web Server Or Load, Balancer Server with the ECE web server name or the Load balancer
SErver name.

A
Configure URL

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Configure Cartfficate
@ Configure URL

@ Configure |dentifiers

@ Configure Multifactor
Authentication Now?

@ Choose Issuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Add Relying Party Trust Wizard

AD FS supports the WS-Trust, WS-Federation and SAML 2.0 Web 550 protocols for relying parties.

VW 5-Federation, SAML, or both are used by the relying party, select the check boxes for them and specify the

URLs to use. Support forthe WS-Trust protocol is always enabled for a relying party.

[] Enable suppart forthe WS-Federation Passive protocal

The WS-Federation Passive protocol URL supports Web-browser-based claims providers using the
WS-Federation Passive protocol

Relying party WS-Federation Passive protocol URL:

Example: https:/As.contoso .com/adfs s/

Enable support for the SAML 2.0 WebSS0 protocol
The SAM = 07 service IURL supports Web-browserbased claims providers using the

TR
SAML 2.0 WebSS0O protocol.

elying party SAML 2.0 S50 service URL:
/v 2w 55 egeng info/system/SAML/S 50/ “Controller

Example: hitps://www contoso.com/adfs/1s/

< Previous | | Next > | | Cancel

Configure the URL

116  Enterprise Chat and Email Installation and Configuration Guide



should be in the format: https:// Web_Server Or load, Balancer Serverl. Replace
Web _Server Or lLoad, Balancer Server with the ECE web server name or the Load balancer server name.
Click Next.

1

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Corfigure Certfficate
@ Corfigure URL

@ Corfigure Identifiers

@ Corfigure Muttifactor
Authertication Now?

@ Choose lssuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Configure Identifiers

Add Relying Party Trust Wizard -

Relying parties may be identified by one or more unique identifier strings. Specify the identifiers for this relying
party trust.

Relying party trust identifier.
bitps://v2wEGegenginfo] 7 | Add

Example: https://fs contoso com/adfs/services/trust

Relying party trust identifiers:

Configure the identifiers

relying party trust at this time option.

On the Configure Identifiers screen, provide the Replying party trust identifier and click Add. Value

On the next screen, select the I do not want to configure multi-factor authentication settings for the

i.  On the Choose Issuance Authorization Rules screen, select the Permit all users to access this relying
party option.

1

Add Relying Party Trust Wizard -

Choose Issuance Authorization Rules

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Corfigure Certificate
@ Corfigure URL

@ Corfigure Identifiers

@ Corfigure Muttifactor
Authertication Now?

@ Choose lssuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Issuance authonization nules determine whether a user is permitted to receive claims forthe relying party.
Choose one of the following options for the initial behavior of this relying party’s issuance authorization rules.

Permit all users to access this relying party

5g onfigured to permit all users to access this relying party. The relying
party service or application may

the user access

sl deny

O Deny all users access to this refying party

The issuance authorization rules will be corfigured to deny all users access to this relying party. You must
|ater add issuance authorization rules to enable any users to access this relying party.

You can change the issuance authorization nules for this relying party trust by selecting the relying party trust
and clicking Edit Claim Rules in the Actions pane:

‘ < Previous H Next > H Cancsl

Select the Permit all users to access this relying party option
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j- On the Ready to add trust screen, click Next.

k. Uncheck the Open the Edit Claim Rules dialogue for this relying party trust when the wizard
closes option and click Close. At the end, an entry is created in the Relying Provider Trusts list.

5. In the Relying Provider Trusts list, select the trust created for ECE, and in the actions section click
Properties.

6. In the Properties window, go to the Endpoints tab and click the Add SAML.. button.

V2W55 Properties -

| Monitoring | |dentifiers I Encryption I Signature | Accepted Claims |
Organization | Endpoirts ‘ Proxy Endpoints | MNotes I Advanced |

Specify the endpoints to use for SAML and WS-FederationPassive protocols
URL Index  Binding Default Re
W5-Federation Passive Endpoints
https //v2w55.egeng info./ POST Yes
SAML Assertion Consumer Endpoints
https://v2w55 egeng infoirst... 0 POST Mo
< m >
(( [[AcdsamL..
e |
Click Add SAML

7. In the Add an Endpoint window, set the following:
a. Select the Endpoint type as SAML Logout.

b. Specify the Trusted URL as https://ADES server/adfs/ls/?wa=wsignoutcleanupl.0. Replace
ADES_server with the single AD FS server name.

c. Click OK.

Add an Endpoint -

Endpoirt type:
[sAML Logout vl

Binding:
[posT v]

Indesc: |0 =

Trusted URL
|https:/'f’ ADFS_server/adfs/s/ Pwa=wsignoutcleanup1.0| |
Example: hitps://sts.contoso .com/adfs/s

Response URL:

Example: https://sts.contoso .com/logout

Create an end point

8. In the Relying Provider Trusts list, select the trust created for ECE, and in the actions section click Edit
Claim Rules.
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In the Edit Claim Rules window, in the Issuance Transform Rules tab, click the Add Rule... button.

In the Add Transform Claim Rule wizard that opens, do the following:

a. On the Choose Rule Type screen, from the Claim rule template dropdown, select Send LDAP
Attributes as Claims. Click Next.

L] Add Transform Claim Rule Wizard -

Select Rule Template

Steps Select the template for the claim rule that you want to create from the following list. The description provides
@ Choose Rule Type details about each claim rule template
@ Corfigure Claim Rule Claim rule template:

|Ser|d LDAP Attributes as Claims / v

Claim rule template description:

Using the Send LDAP Attribute as Claims rule template you can select attributes from an LDAP attribute
store such as Active Directory to send as claims to the relying party. Multiple attributes may be sent as
multiple claims from a single rule using this rule type. For example, you can use this nule template to create
a rule that will extract attribute values for authenticated users from the displayName and telephoneNumber
Active Directory attributes and then send those values as two different outgoing claims. This rule may also
be used to send all of the user's group memberships. If you want to only send individual group
memberships, use the Send Group Membership as a Claim rule template

ot

Select the claim rule template

b. On the Configure Rule screen, set the following:

i. Provide the Claim rule name.

ii. Define mapping of LDAP attribute and the outgoing claim type. Select Name ID as the outgoing
claim type name. Click Finish to go back to the Edit Claim Rules for single AD FS window.

Single Sign-0n Configuration 119



Configure Rule

Steps *You can corfigure this rule to send the values of LDAP attributes as claims. Select an attribute store from
@ Choose Rule Type ‘which to extract LDAR attibutes. Specify how the attributes will map to the outgeing claim types that will be
issued from the nile
@ Configure Claim Rule
Claim rule name:

‘Account name to Name D /

Rule template: AP Attributes as Claims

Adtribute store.

‘Adlve Directary ) |

Mapping of LDAP attributes to outgoing claim types:

LHMLDAPxﬁbm (Szlzaiacpelo Onteime-slaim Type (Selact ortype to add more)
g User-Principal-Name: vINama [Iv] ) v
I

Configure the rule

10. In the Edit Claim Rules window, in the Issuance Authorization Rules tab, ensure that the rule permits access
to all users. Click OK to close the window.

—Issuanee Transform Rules | lssuance Authorization Rules | Delegation Authorization Rules

The following authorization rules specify the users that will be permitted access to the relying
party. When the list does not contain a rule, all users will be denied access.

<’Oﬁﬁu\e Name lssued Claims
Wo Al Users Permit

Check the authorization rules
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11. In the Relying Provider Trusts list, double-click the relying party trust which you created. In the Properties

window that opens, go to the Advanced tab and set the Secure hash algorithm to SHA-1. Click OK to
close the window.

‘ Monitoring | Identifiers | Encryption | Signature I MM[

| Orgarization | Endpoints | Proxy Endpoints | Motes | Advanced

| S bt

wm [sHA1 D
[ ok [ cancad ][ evly

Set the secure hash algorithm

12. Next, in the AD FS Management console, go to the Authentication Policy > Per Relying Party Trust.

Locate the Relying Party Trust created for ECE, and in the Actions section click Edit Custom Primary
Authentication.

W File Action View Window Help

-8 *
«= 2= @
5] ADFS Per Relying Party Trust | Actions
l: g i:,‘i::m.mmps Relyng Party Wl
Relying Party Trusts with global authentication settings onk .
W S e o - ’
| Relying Party Trusts e New Window from Here
Relying Party Trusts with custern authentication settings | Refresh
Authentication Pelicies
Device Registration Service
| Per Relying Party Trust ﬂ Help

Edit Custom Multifactor Authentic...
Edit Custom Primary Authentication
Properties

ﬂ Help

Change the authentication policy for ECE
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13. In the Edit Authentication Policy window, in the Primary tab, select the Users are required to provide
credentials each time at sign in option. Click OK to close the window.

Edit Authentication Policy for V2W55 -

Primary | Mulifactor

Corfigure custom authentication settings for this relying party trust.

=T OIoBa] authentication policy SeRings, HaMTte=suythentication Policies node

Users are required to provide credertials each time at sign ig

[ ok |[ caneel |[ ey |

Edit the authentication policy

Configuring Split AD FS Deployment

In a split AD FS deployment, Resource Federation Server and Account Federation Server are installed on
separate machines. Resource Federation Server acts as shared AD FS and Account Federation Server acts as
customer AD FS.

Configuring split AD FS includes:
» Adding Security Certificates for the AD FS Domains
» Configuring Relying Party Trust for Shared AD FS in Customer AD FS
» Configuring Claims Provider Trust for Customer AD FS in Shared AD FS
» Configuring Relying Party Trust for ECE in Shared AD FS

Adding Security Certificates for the AD FS Domains

» If Customer AD FS and Shared AD FS are installed in different domain, you need to add certificates of the
domains to the Trusted Root Certification Authorities store of the servers. On the Customer AD FS server,
add the certificate of the Shared AD FS and vice versa. Contact your IT department to do this task.
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Configuring Relying Party Trust for Shared AD FS in Customer AD FS

Perform these tasks on the server where customer AD FS is installed.

To configure replying party trust for shared AD FS in customer AD FS:

1. Go

to the Start menu and open the AD FS Management console.

2. In the AD FS Management console, navigate to AD FS > Trust Relationships > Relying Party Trust.

3. In the Actions section, go to Relying Party Trust, and click Add Relying Party Trust...

4

| Relying Party Trust:
it

| Authentication Policies

Bres

L ADFS
i File Action View Window Help
= 7= |
| ADFS Relying Party Trusts Actions
4 - -Srervlc; | hi ) Display Name Enabled Type Identifier
# & Trust Relationships [ hitps://uslewmi2 eng na/ No WS-T...hitps://uslewm02.engna/
—Ctans PTEvIeniyet || g5 yMSC05 Console Yes WS-T...  https//vmscD5.ego irfo/

View

Mew Window from Here

Click Add Relying Party Trust

|G Refresh
H Help

https://uslewm02.eng.na/

4. In the Add Relying Party Trust Wizard that appears, do the following:

a. On the Select Data Source screen, set the following options:

Update from Federation Metadata...

i. Select the Import data about the relying party published on online or on a local network

option.

ii. In the Federation metadata address field, provide the Shared AD FS server name.

iii. Click Next.
1

Select Data Source

Add Relying Party Trust Wizard

Steps Select an option that this wizard will use to obtain data about this relying party:
@ Welcome

(®) Import data about the relying party published online or on a local network
@ Select Data Source

Mo e TTeCesE Ayt
its federation metadata online or on a local network

@ Conrfigure Muttifactor
Authentication Now?

ederation metadata address (host name or URL):
@ Choose Issuance

iCales from a relying party organization that publishes

Authorization Rules psadfs01.egdemo.ifol

__—

@ Readyto Add Trust

mm Contoso.com/app
@ Finish O Import data about the relying party from a file
Use this option to import the necessary data and certfficates from a relying party organization that has
validate the source of the file

Federation metadata file location:

() Enter data about the relying party manually
Use this option to manually input the necessary data about this relying party organization.

exported its federation metadata to a file. Ensure that this file is from a trusted source.  This wizard will not

Next >

< Previous ‘ ‘ ‘ ‘ Cancsl

Select the data source options
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b. On the Specify Display Name screen, provide the Display name. Click Next.
=

(%] Add Relying Party Trust Wizard

Specify Display Name

Steps Enterthe display name and any optional notes for this relying party.
@ Welcome Display name

@ Select Data Source Shared ADFS| d

@ Specify Display Name Notes:

@ Configure Multifactor
Authertication Now?

@ Choose lssuance
Authorization Rules

@ Readyto Add Trust
@ Finish

< Previous | | Nexd > | | Cancel

Provide a display name

c. In the screens that follow, do not alter the default values. Continue to click the Next button in the
wizard until a trust is created. At the end, an entry is created in the Relying Party Trusts list.

5. In the AD FS Management console, navigate to Services > Claim Descriptions.

6. In the Actions section, go to Claim Descriptions, and click Add Claim Descriptions...

s ADFS [= | = =
§a File Action View Window Help
==
| ADFS Claim Descriptions Actions
L Se.”é‘: . Name Short Name Claim Type| ~ | | Clai inti cac
| Endpoints e =
. N E-Mail Address email http://sche Add Claim Description...
- Given Mame given_name http://sche
Name unigue_name hittp://sche View 4
ST Ll uen hito://schg New Window from Here
_ Claims Provider Trusts Common Name: commonname hittp://sche
7| Relying Party Trusts AD FS 1x E-Mail Address  adfs Temail hitp://sche || (G Refresh
| Attribute Stores Group group http://sche ﬂ Help
I [ | Authentication Policies ADF5 1x UPN adfs lupn hittp-//sche =
Role role http://sche Cust Name ID -
Sumame Family_name http://sche Properties
PPID ppid http://sche o
Name ID sub hitp://sche | | #% Delete
Authentication time stamp auth_time http://sche E Help
Authertication method authmethod http://sche
Deny only group SID denyonlysid http://sche
Deny only primary 51D denyonlyprimarysid http://sche

Click Add Claim Description

7. In the Add a Claim Description window, provide the following details:
a. Set the Display name as Cust Name ID.
b. Set the Claim identifier as http://schemas.xmlsoap.org/ws/2005/05/identity/claims/CustNamelD

c. Select the Publish the claim description in federation metadata as a claim type that this
Federation Service can accept option.
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d. Select the Publish the claim description in federation metadata as a claim type that this

Federation Service can send option.

e. Click OK to close the window.

You can add a claim description to identify and describe this claim for later use
Display name

[Cust Name 1D

Claim identfier:

|hﬂp Ssct org/ws/2005/05/identity/claims/Cust NamelD

Example: http://schemas xmlsoap.org/ws/2005/05/idertity/claims/emailaddress
Description:

™ Publish this claim description in federation metadata as a claim type that this Federation
Service can accept

™ Publish this claim description in federation metadata as a claim type that this Federation
Service can send

Provide the claim description

In the Relying Party Trusts list, select the Shared AD FS entry and in the Actions section, click Edit Claims

Rules.

W File Action View Window Help

Click Edit Claims Rules

-5 %
@ 2E B
] ADFs Relying Party Trusts | Actions
e Ehipley. Hame, ratied  Te e | Relying Pary Trusts A
4[] Trust Relationships @ Fitps//uslz - No WST. i .
[ Claims Provider Trusts PTTIS005 Console Yes WST.. iy Add Relying Party Trust...
[~ Relying Party Trusts < Shared ADFS Yes WS- Add Mon-Claims-Aware Relying Party Trust...
7] Attribute Stores Vi »
b [ Authentication Policies e
MNew Window from Here
|G Refresh
ﬂ Help
iSharedADES ——
ration Metadata...
.
(it Claim Rules...
[
Properties
K Delete
ﬂ Help

In the Edit Claim Rules for Shared AD FS window, in the Issuance Transform Rules tab, click the Add

Rule... button.

In the Add Transform Claim Rule wizard that opens, do the following:
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a.  On the Choose Rule Type screen, from the Claim rule template, select Send LDAP Attributes as
Claims. Click Next.

Select Rule Template

Steps Select the template for the claim rule that you want to create from the following list. The description provides
@ Choose Rule Type details about each claim rule template.
@ Corfigure Claim Rule Claim rule template:

Send LDAF Attibutes as Claims /. v

Claim rule template description:

Using the Send LDAF Attribute as Claims nule template you can select attributes from an LDAP attibute
store such as Active Directory to send as claims to the refying party. Multiple attributes may be sent as
muttiple claims from a single rule using this rule type. For example, you can use this rule template to create
a rule that will extract attribute values for authenticated users from the displayMame and telephone Number
Active Directory attributes and then send those values as two different outgoing claims. This rule may also
be used to send all of the user's group memberships. F you want to only send individual group
memberships, use the Send Group Membership as a Claim rule template.

<Frevious | [ Net> | [ Cancel

Select the claim rule template

b. On the Configure Claim Rule screen, do the following:
i. Provide a claim rule name.

ii. Define mapping of LDAP attribute and the outgoing claim type. The outgoing claim type name must
be unique across all the claims defined in all relying party trusts created on this AD FS server. Click
Finish to go back to the Edit Claim Rules for Shared AD FS window.

Configure Rule

Steps You can corfigure this rule to send the values of LDAP attributes as claims. Select an attribute store from
@ Choose Rule Type which to extract LDAP attributes. Specify how the attibutes will map to the outgeing claim types that will be
issued from the rule.

@ Configure Claim Rule

Sam-Account-Name to Cust Name ID/

butes as Claims

Attribute store:

|Actwe Directory v

Mapping of LDAP attributes to outgoing claim types:

W Qutgeing Claim Type (Select or type to add mol

add more)
User-Principal-Name ] Cust Mame 10| A
1 W

Configure the claim rule
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10. In the Edit Claim Rules for Shared AD FS window, in the Issuance Authorization Rules tab, ensure that the
rule permits access to all users. Click OK to close the window.

N Edit Claim Rules for Shared ADFS - | = [
Issuance Transform Rules | lssuance Authorization Rules | Delegation Authorization Rules
The following authorization nules specify the users that will be permitted access to the relying
party. When the list does not cortain a rule, all users will be denied access
Lerer Rl Name lssusd Claims
< 1 Pemit Accessto All Users Permit
Add Rule.. | | EdtRue . | | Remove Rule . |

Check the authorization rules

11. In the Relying Party Trusts list, double-click the relying party trust which you created. In the Properties
window that opens, go to the Advanced tab and set the Secure hash algorithm to SHA-1. Click OK to
close the window.

Shared ADFS Properties -

| Monitoring | |dentifiers I Encryption I Signature | Accepted Claims
Organization | Endpoirts I Praxy Endpoints | Notes ‘ Advanced

Specify T < trust

Secure hash algorithm: | SHA1 \)

\

Set the secure hash algorithm

Configuring Claims Provider Trust for Customer AD FS in Shared AD FS

Perform these tasks on the server where shared AD FS is installed.

To configure claims provider trust for customer AD FS in shared AD FS:

1. Go to the Start menu and open the AD FS Management console.
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2. In the AD FS Management console, navigate to AD FS > Trust Relationships > Claims Provider Trust.

3. In the Actions section, go to Claim Provider Trusts, and click Add Claims Provider Trust...
o ADFS [=[ox]
g File Action View Window Help
s 2
| ADFS Claims Provider Trusts
I [ Service

Display Name i i
4 [ Trust Relationships = Claims Provider Trusts

a
| Claims Provider Trusts Add Claims Provider Trust...
“| Relying Party Trusts View N
| Attribute Stores
w New Window from H
[ Authentication Policies o NI RIS
|G Refresh
Help
Active Directory -

Update from Federation Metadata...
Edit Claim Rules...
Disable

Properties

Add claims provider trust

4. In the Add Claims Provider Trust Wizard that appears, do the following:

a.  On the Select Data Source screen, set the following options:
i. Select the Import data about the claims provider published on online or on a local network

option.

ii. In the Federation metadata address field, provide the Customer AD FS server name.

iii. Click Next.

) Add Claims Provider Trust Wizard -

Select Data Source

Steps Select an option that this wizard will use to obtain data about this claims provider:

@ Welcome
®! Import data about the claims provider published online or on a local networ
@ Select Data Source " .
Use this optrormrermm = oM a claims provider organization that

@ Readyto Add Trust publishes its federation metadata unhn’e oron a local network
@ Finish

[Eration metadata address (host name or URL):

lewm 04 egdemo infal /

Example: fs fabrikam com or hips /7S Tabrikam com/

(O Import data about the claims provider from a file

Use this option to import the necessary data and certificates from a claims provider organization that has
provided its federation metadata in a file.

Federation metadata file location:

() Entter claims provider trust data manually

Use this option to manually input the necessary data about this claims provider organization.

< Previous | | Next > | | Cancel

Set the data source

b. In the Specify Display Name screen, provide the Display name. Click Next.

c. In the screens that follow, do not alter the default values. Continue to click the Next button in the

wizard until a trust is created. At the end, an entry is created in the Claim Provider Trusts list.
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In the Claim Provider Trusts list, select the Shared AD FS entry and click Edit Claim Rules.

\a ADFS - [ =[]

%File Action View Window Help
& | 21 [T

| ADFs Claims Provider Trusts Actions

1 Service " . h
= } Display Name Claims Provider Trusts =
4 [ Trust Relationships -
5 Claims Provider Trusts Sive Directory Add Claims Provider Trust...
= Customer ADFS
_| Relying Party Trusts View »
1 Attribute St
| mne st New Window from Here
4 || Authentication Policies
| Per Relying Party Trust |G Refresh
Help
Customer ADFS =
ion Metadata...
Edit Claim Rules...
Disable
Properties
K Delete
Help

Edit the claim rules

In the Edit Claim Rules for Customer AD FS window, in the Acceptance Transform Rules tab, click the Add

Rule... button.

In the Add Transform Claim Rule wizard that opens, do the following:

a. On the Choose Rule Type screen, select Transform an Incoming Claim as the claim rule template.

Click Next.

L% Add Transform Claim Rule Wizard =1
Select Rule Template

Steps Select the template for the claim rule that you want to create from the following list. The description provides
details about Izt

@ Choose Rule Type

@ Configure Claim Rule Claim rule template:

|T|ansform an Incoming Claim / w
Claim rule template descrpfion:

Using the Transform an Incoming Claim nule template you can select an incoming claim, change its claim
type, and optionally change its claim value. For example, you can use this rule template to create a rule
that will send a role claim with the same claim value of an incoming group claim. You can also use this
rule to send a group claim with @ claim value of "Purchasers" when there is an incoming group claim with
a value of "Admins"”. Muttiple claims with the same claim type may be emitted from this rule. Sources of
incoming claims vary based on the rules being edited. For more information on the sources of incoming
claime, click Help.

<Provoun | [t

Choose the claim rule template

b. On the Configure Claim Rule screen, set the following:

i. Provide the claim rule name as Cust Name ID.
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ii. In the Incoming claim type field provide the name as
http://schemas.xmlsoap.org/ws/2005/05/identity/claims/CustNamelID. This is the same value as
provided while creating the claim rule description (page 124).

iii. Set the Outgoing claim type as Cust Name ID.

iv. Select the Pass through all claim values option.

Edit Rule - Cust Name ID -

You can corfigure this rule to map an incoming claim type to an outgoing claim type. As an option, you can
also map an incoming claim value to an outgoing claim value. Specify the incoming claim type to map to the
outgoing claim type and whether the claim value should be mapped to a new claim value.

Claim rule name:

[Eust Hame 1]

Rule template: Transform an Incoming Claim

Incoming claim type: |Mtp:f/schemas xmisoap.ong/ws/2005/05/Adentity./clai v |
Unspecified

Outgeing claim type: [cust Name 1D v]
Unspecified

® Pass through all claim values

() Replace an incoming claim value with a differert outgeing claim value

Browse:
O Replace incoming e-mail suffix claims with a new e-mail suffoc
e e L

Configure the claim rule

c. Click Finish. Claim is created and is displayed in the Edit Claim Rules for Customer AD FS window.

7. In the Claim Provider Trusts list, double-click the claim provider trust which you created. In the Properties
window that opens, go to the Advanced tab and set the Secure hash algorithm to SHA-1. Click OK to
close the window.

Customer ADFS Properties -

| Monitoring | Idertifiers I Certificates | Encryption
| Offered Claims | Organization | Endpaints | Notes | Advanced

Specify the secure hash algorithm to use for this claims provider trust.

Secure hash algorithm: |SHA—1 ) )

Set the secure hash algorithm
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Configuring Relying Party Trust for ECE in Shared AD FS

Perform these tasks on the server where shared AD FS is installed.

To configure relying party trust for ECE in shared AD FS:

1.
2.

4.

Go to the Start menu and open AD FS Management console.

In the AD FS Management console, navigate to AD FS > Trust Relationships > Relying Party Trust.

In the Actions section, go to Relying Party Trust, and click Add Relying Party Trust...

a

a2 |z BHE

ADFS

3 File Action View Window Help

| ADFS
~ Service
4 || Trust Relationships

-

TP T ItEr T
—_Relying Party Trust
| Attribute Stores
4 | Authentication Policies

| Per Relying Party Trust

Display Name Enabled Type
Device Registration Service Yes WS-T...

Relying Party Trusts Actions

Relyipg-Rarey—Frusts
Add Relying Party Trust..

Add Mon-Claims-Aware Relying...
View
MNew Window fram Here

1@ Refresh

H Help

In the Add Relying Party Trust Wizard that appears, do the following:

a. On the Welco

me screen, click Start.

b.  On the Select Data Source screen, select the Enter data about the reply party manually option and

click Next.

1

Select Data Source

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Corfigure Cerificate
@ Configure URL

@ Corfigure dentfiers

@ Corfigure Multifactor
Authentication Now?

@ Choose Issuance
Authorization Rules

@ Ready to Add Trust
@ Finish

Add Relying Party Trust Wizard

Select an option that this wizard will use to obtain data about this relying party:

) Import data about the relying party published online or on a local network

Use this option to import the necessary data and certificates from a relying party onganization that publishes

its federation metadata online or on a local network:

Federation metadata address (host name or URL):

Example: fs.contoso.com or https://www contoso.com/app

() Import data about the relying party from a file

Use this option to import the necessary data and certfficates from a relying party organization that has
exported its federation metadata to a file. Ensure that this file is from a trusted source.  This wizard will not

validate the source of the file

Federation metadata file location:

Enter data about the relying party manually

Seation 10 Dpui-the-rT=Cessary data about this relying party organization

‘ « Previous H Nexdt >

‘ ‘ Cancel

Select the Enter data

about the reply party manually option

Single Sign-0n Configuration

131



c.  On the Specify Display Name screen, provide a Display name for the relying party. Click Next.

@

Add Relying Party Trust Wizard

Specify Display Name

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Configure Certflicate
@ Configure URL

@ Configure |dentifiers

@ Configure Multifactor
Authentication Now?

@ Choose Issuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Enter the display name and any optional notes for this relying party.

Display name:

v2w55 Cansole| /

Notes:
A
v

< Previous | | Nexd > | | Cancel

Provide a display name

d. On the Choose Profile screen, select AD FS profile and click Next.

1

Choose Profile

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Corfigure Certfficate
@ Corfigure URL

@ Corfigure Identifiers

@ Corfigure Muttifactor
Authertication Now?

@ Choose lssuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Add Relying Party Trust Wizard

This wizard uses configuration profiles to aid in creating the refying party trust. Choose the appropriate
copfiauretierrerette-facthis relying party tust.

AD FS profile

= wppoTTE relying parties that are interoperable with new AD FS features. such as
security token encryption and the SAML 2.0 protocol

() ADFS 1.0and 1.1 profile
This profile supports relying parties that are interoperable with AD FS 1.0and 1.1

< Previous Nexd > | | Cancel

Select AD FS profile

e. On the configure Certificate screen, click Next.

f.  On the Configure URL screen, set the following:
i. Select the Enable support for the SAML 2.0 Web SSO protocol option.
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ii. In the Relying Party SAML 2.0 SSO server URL field provide the URL in the format:
https:// Web Server Or lLoad, Balancer Server/system/SAML/SSO/POST.controller.
Replace Web Server Or lLoad, Balancer Server with the ECE web server name or the Load balancer
server name.

o
Configure URL

Steps

@ Welcome

@ Select Data Source
@ Specify Display Name
@ Choose Profile

@ Configure Cartfficate
@ Configure URL

@ Configure |dentifiers

@ Configure Multifactor
Authentication Now?

@ Choose Issuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Add Relying Party Trust Wizard

AD FS supports the WS-Trust, WS-Federation and SAML 2.0 Web550 protocols for relying parties. I
WS-Federation, SAML, or both are used by the relying party, select the check baxes for them and specify the

URLs to use. Support for the WS-Trust protocol is always enabled for a relying party.

["] Enable support for the WS-Federation Passive protocol

The WS-Federation Passive protocel URL supports Web-browserbased claims providers using the
WS-Federation Passive protocol

Relying party WS-Federation Passive protocol URL:

Example: https:/As.contoso .com/adfs s/

Enable support for the SAML 2.0 WebSS0 protocol
The SAM = 07 service |URL supports Web-browser-based claims providers using the

TR
SAML 2.0 WebSS0 protocal.

elying party SAML 2.0 S50 service URL:
/v 2w55 egeng info/system/SAML/S 50/ “Controller

Example: hitps://www contoso.com/adfs/1s/

< Previous | |

Next >

| | Cancel

Configure the URL

g.  On the Configure Identifiers screen, provide the Replying party trust identifier and click Add. Value
should be in the format: https:// Web_Server Or load, Balancer Serverl. Replace
Web _Server Or lLoad, Balancer Server with the ECE web server name or the Load balancer server name.

Click Next.

1

Configure Identifiers

Steps
@ Welcome

@ Select Data Source

@ Choose Profile
@ Corfigure Certfficate
@ Corfigure URL
@ Corfigure Identifiers

@ Corfigure Muttifactor
Authertication Now?

@ Choose lssuance
Authorization Rules

@ Readyto Add Trust
@ Finish

Add Relying Party Trust Wizard

Relying parties may be identified by one or more unique identifier strings. Specify the identifiers for this relying

party trust.

Relying party trust identifier.
® Specty Display Name hiips //v2wBb egenginfol] 7

Example: https://fs contoso com/adfs/services/trust

Relying party trust identifiers:

Configure the identifiers
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h. On the next screen, select the I do not want to configure multi-factor authentication settings for the
relying party trust at this time option.

i.  On the Choose Issuance Authorization Rules screen, select the Permit all users to access this relying
party option.

L% Add Relying Party Trust Wizard -
Choose Issuance Authorization Rules

Steps Issuance authonization nules determine whether a user is permitted to receive claims forthe relying party.
@ Welcome Choose one of the following options for the initial behavior of this refying party’s issuance authorization rules.

@ Select Data Source

®) Pemit all users to access this relying party

® Specify Display Name ssugnce authorization orfigured to pemit all users to access this refying party. The relying

party service or appication may stll deny the User access

@ Choose Profile

@ Corfigure Certificate O Deny all users access to this refying party

@ Corfigurs URL The issuance authorization nules will be configured to dery all users access to this relying party. You must
|ater add issuance authorization rules to enable any users to access this relying party.
@ Corfigure Identifiers

@ Corfigure Muttifactor
Authertication Now? You can change the issuance authorization nules for this relying party trust by selecting the relying party trust
and clicking Edit Claim Rules in the Actions pane:
@ Choose lssuance
Authorization Rules

@ Readyto Add Trust
@ Finish

‘ < Previous H Next > H Cancsl

Select the Permit all users to access this relying party option

j- On the Ready to add trust screen, click Next.

k. Uncheck the Open the Edit Claim Rules dialogue for this relying party trust when the wizard
closes option and click Close. At the end, an entry is created in the Relying Provider Trusts list.

In the Relying Provider Trusts list, select the trust created for ECE, and in the actions section click
Properties.

In the Properties window, go to the Endpoints tab and click the Add SAML.. button.

V2W55 Properties -

| Monitoring | |dentifiers I Encryption I Signature | Accepted Claims |
Organization | Endpoirts ‘ Proxy Endpoints | MNotes I Advanced |

Specify the endpoints to use for SAML and WS-FederationPassive protocols
URL Index  Binding Default Re
W5-Federation Passive Endpoints
https //v2w55.egeng info./ POST Yes
SAML Assertion Consumer Endpoints
https://v2w55 egeng infoirst... 0 POST Mo
< m >
Add SAML...
Click Add SAML
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7.

In the Add an Endpoint window, set the following:

a. Select the Endpoint type as SAML Logout.

b. Specify the Trusted URL as https://shared, ADFES server/adfs/ls/2wa=wsignoutcleanup1.0.

Replace sharved, ADES_server with the Shared AD FS server name.
c. Click OK.

Add an Endpoint -

Endpoint type
[SAML Logout v

Binding
[FosT v]

Index; ° v
Trusted URL:
‘Hﬂps //Shared_ADFS_server/adfs/ls/ Pwa=wsignoutcleanup 1.0] |

Example: https://sts contoso.com/adfs/s
Response URL:

Example: https://sts contoso.com/logout

Create an end point

In the Relying Provider Trusts list, select the trust created for ECE, and in the actions section click Edit

Claim Rules.

In the Edit Claim Rules window, in the Issuance Transform Rules tab, click the Add Rule... button.

In the Add Transform Claim Rule wizard that opens, do the following:

a. On the Select Rule Template screen, from the Claim rule template dropdown, select Transform an

Incoming Claim. Click Next.

L% Add Transform Claim Rule Wizard .
Select Rule Template

Steps Select the template for the claim rule that you want to create from the following list. The description provides

@ Choose Rule Type details about each claim rule template.

@ Configure Claim Rule laim rule template
|T|ansform an Incoming Claim / w

Claim rule template description

Using the Transform an Incoming Claim rule template you can select an incoming claim, change its claim
type, and optionally change its claim value. For example, you can use this rule template to create a nule
that will send a role claim with the same claim value of an incoming group claim. You can also use this
rule to send a group claim with a claim value of "Purchasers” when there is an incoming group claim with
a value of "Admins”. Muttiple claims with the same claim type may be emitted from this rule. Sources of
incoming claims wary based on the rules being edited. For more information on the sources of incoming
claime, click Help.

Select the claim rule template
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b. On the Configure Rule screen, set the following:
i. Provide the Claim rule name.

ii. In the Incoming claim type field provide the name of the outgoing claim specified in the Relying
Party trust wizard (page 126).

iii. In the Outgoing claim type dropdown, select the Name ID option.

% Add Transform Claim Rule Wizard 3
Configure Rule

Steps You can configure this rule to map an incoming claim type to an outgoing claim type. As an option, you can
@ Choose Rule Type also map an incoming claim value to an outgeing claim value. Specify the incoming claim type to map to the
outgoing claim type and whether the claim value should be mapped to a new claim value

@ Corfigure Claim Rule
[aim rule name:

Cust Name IC to Name ID /

Rule template: Transform an Incoming Claim

@e |Cusl Name ID w ‘

Unspecified
utgoing claim type [Name 1D} ) hd ‘
Outgoing name |0 format: |un5pggﬂied b ‘

®) Pass through all claim values

() Replace an incoming claim value with a different outgoing claim value

() Replace incoming e-mail suffc claims with a new e-mail suffoc

< Previous | | Finish | | Cancel

Configure the rule

10. In the Edit Claim Rules window, in the Issuance Authorization Rules tab, ensure that the rule permits access
to all users. Click OK to close the window.

G Edit Claim Rules for uslewm02.eng.na [ [ =]

Issuance Transform Rules | lssuance Authorization Rules | Delegation Authorization Rules

The following authorization rules specify the users that will be permitted access to the relying
party. When the list does not contain a rule, all users will be denied access

<'ﬁﬂu\e Name lssued Claims
Wﬂ All Users Pemit

Add Rule... | [ Edt Rule.. | | Remove Rule... |

ok ][ Gen |[ ]

Check the authorization rules
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11. In the Relying Provider Trusts list, double-click the relying party trust which you created. In the Properties

window that opens, go to the Advanced tab and set the Secure hash algorithm to SHA-1. Click OK to
close the window.

‘ Monitoring | Identifiers | Encryption | Signature I MM[

| Orgarization | Endpoints | Proxy Endpoints | Motes | Advanced

| S bt

wm [sHA1 D
[ ok [ cancad ][ evly

Set the secure hash algorithm

12. Next, in the AD FS Management console, go to the Authentication Policy > Per Relying Party Trust.

Locate the Relying Party Trust created for ECE, and in the Actions section click Edit Custom Primary
Authentication.

W File Action View Window Help

-8 *
«= 2= @
5] ADFS Per Relying Party Trust | Actions
l: g i:,‘i::m.mmps Relyng Party Wl
Relying Party Trusts with global authentication settings onk .
W S e o - ’
| Relying Party Trusts e New Window from Here
Relying Party Trusts with custern authentication settings | Refresh
Authentication Pelicies
Device Registration Service
| Per Relying Party Trust ﬂ Help

Edit Custom Multifactor Authentic...
Edit Custom Primary Authentication
Properties

ﬂ Help

Change the authentication policy for ECE
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In the Edit Authentication Policy window, in the Primary tab, select the Users are required to provide

13.
credentials each time at sign in option. Click OK to close the window.
Edit Authentication Policy for V2W55 -
Primary | Mulifactor
Corfigure custom authentication settings for this relying party trust.
T Tloha anthentication policy setings. navarelythentication Policies node
< Users are required to provide credertials each time at sign ig
[ ok |[ caneel |[ ey |

Edit the authentication policy

Configuring Single Sign-0n in ECE

Follow instruction in the “Single Sign-On” chapter of the Enterprise Chat and Email Administrator’s Guide

4
to Administration Console to complete the single sign-on configuration in ECE.
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SSL Configuration

Installing a Security Certificate
Binding the Certificate to the Application Website
Testing SSL Access

Configuring SSL or TLS for Retriever and Dispatcher Services



Secure Sockets Layer (SSL) is widely used to create a secure communication channel between web browsers and
servers. Set up SSL for more secure connections to your ECE installation by following the procedures described
in this chapter. If the configuration uses a load balancer, configure SSL on the load balancer.

@ Important: You must perform these tasks before using the application.

Installing a Security Certificate

This section explains the procedures that you must perform to acquire a certificate and install it on the web
server. These include:

» Generating a Certificate Signing Request
» Submitting the Certificate Request

» Installing the Certificate on the Web Server

Generating a Certificate Signing Request
This procedure creates a new certificate request, which is then sent to a Certificate Authority (CA) for
processing. If successful, the CA will send back a file containing a validated certificate.
To generate a certificate request:

1. Click the Start menu, go to Control Panel > Administrative Tools, and select Internet Information
Services (IIS) Manager.

2. In the Connections pane, select the name of the server, and when the page is refreshed, double-click Server
Certificates. The window is refreshed.

3. In the Actions pane on the right, click the Create Certificate Request... link.

CEl Internet Information Services (IIS) Manager - |=
) [%» usmHosTIWES & | = f @~
File View Help

Connections - Actions

rer Y Ué‘ Server Certificates imp 8

:_i Start Page Use this feature to request and manage certificates that
4L 3 H%pMHOSﬁWH (USPMHOS| the Web server can use with websites configured for
i [ot Application Pools ssL.
[--[&] Sites Create Domain Certificate...
Filter: - Go

Complete Certificate Request..,

= Create Self-Signed Certificate...

MName lssued To

Enable Automatic Rebind of
Renewed Certificate

@ Help

< mn >

< m > [=f] Features View | = Content View

Reachy L=

Click the Create Certificate Request link
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In the Distinguished Name Properties window, enter information about the company and the site to be

secured:

o Common Name: The fully qualified domain name (FQDN) of your server. This must match exactly
what users type in the web browser to get to the application. If you are using a load balancer, enter the
name of the server on which the load balancer is installed.

O Organization: The legal name of your organization. This should not be abbreviated and should include
suffixes such as Inc, Corp, or LLC.

O Organizational Unit: The division of your organization handling the certificate.

o City/locality: The city where your organization is located.

O  State/province: The complete name of the state or region where your organization is located.

O  Country/region: The two-letter ISO code for the country where your organization is located.

Click Next.

In the Cryptographic Service Provider window, select a cryptographic service provider and set the required
bit length. The greater the bit length, the stronger the security. Click Next.

Request Certificate _

Cryptographic Service Provider Properties

g

Select a cryptographic service provider and a bit length. The bit length of the encryption key determines the
certificate's encryption strength. The greater the bit length, the stronger the security. However, a greater bit
length may decrease performance.

Cryptographic service provider:

|M\crosof‘t RSA SChannel Cryptographic Provider w
Bit length:
2043 v
oo ][]

Select a cryptographic service provider and bit length
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6. In the File Name window, click the Assistance ... button and browse to the location where you wish to save
the certificate signing request file. Ensure that you enter a file name for the certificate signing request file.

. o e
Click Finish.
Request Certificate _
l File Name

alr

Specify the file name for the certificate request. This information can be sent to a certification authority for

signing.

Specify a file name for the certificate request:

|C:\Users\Admin\stramr\Desktﬂp\{nmpany.mm\(sr.txt | EI

Enter the location and file name

Once you have generated a certificate signing request, you can submit the certificate request to a certificate
authority.

Submitting the Certificate Request

To submit the certificate request:

» Go to the website of the company that issues SSL certificates (such as VeriSign), and submit your certificate
request. Make sure you provide the same information as you provided while generating the certificate
signing request. To submit the request, you will need the certificate request file that you generated
(page 140).

Once the request is processed, the vendor will generate the certificate and send it to you.

Installing the Certificate on the Web Server

Once you receive the certificate from your vendor, install it on all web servers. If you are using load balancer,
install it on the load balancer server.

@ Important: You need to install the certificate for the website that was specified when the web
2% server component was installed.

To install the certificate on the web server:

1. Click the Start menu, go to Administrative Tools, and select Internet Information Services (ILS)
Manager.
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2. In the Connections pane, select the name of the server, and when the page is refreshed, double-click Server
Certificates. The window is refreshed.

3. In the Actions pane on the right, click the Complete Certificate Request... link.

€3 » USPMHOSTIWIS »

i E Start Page
y USPMHOSTIW15 (USPMHOS
@ Application Pools
|.> [&] Sites

% Server Certificates

Use this feature to request and manage certificates that
the Web server can use with websites configured for

SSL.

Filter: + ¥ Go -

MName Issued To

« [

Complete Certificate Reque:
—_—  —

Create Domain Certificat
Create Self-Signed Certificate...

Enable Automatic Rebind of
Renewed Certificate

e Help

Click the Complete Certificate Request link

4. In the Specify Certificate Authority Response window, complete these tasks:

O Click the Assistance ... button and select the server certificate that you received from the certificate

authority. If the certificate doesn't have a .cer file extension, select to view all types.

o  Enter a name for the certificate. Click OK.

* ||| Specify Certificate Authority Response

response.

Complete a previously created certificate request by retrieving the file that contains the certificate authority's

File name containing the certification authority's response:

| CA\Users\Administrator\Desktoph\company.combcsr.cer ‘ II'

Friendly name:

| Company.com certificate]

Select a certificate store for the new certificate:

| Personal

v]

| | Cancel

Browse to the server certificate file

5. Verify that the certificate is added to the list of server certificates.

Repeat this process on all web servers.
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Binding the Certificate to the Application Website

This procedure uses Internet Services Manager to configure the virtual directory to require SSL for access to the

application URL.

Important: You need to configure the SSL access for the website that was selected when
the web server component was selected.

To bind the certificate to the application URL:

1. Click the Start menu, go to Administrative Tools, and select Internet Information Services (ILS)

Manager.

2. In the Connections pane, select the name of the server and browse to Sites > Web_Site. Name.

3. In the Actions pane on the right, from the Edit Site section, click the Bindings... link.

HE Internet Information Services (I15) Manager

2— € » USSUHVINOTOE » Sites b Default Web Site »

File View Help
Connections
o - L] -
-y Start Page
e “'a USSUHVINGTD6 (EGEMG\qeuser)
-2} Application Pools

v -[&] Site
&) Default Web Site
53 Server Farm

@ Default Web Site Home

Filter: - Go .
ASP.NET A
NET NET NET Errar

Authorizat... Compilation Pages

e E ©

L

NET {MET Profile .NET Roles
Glohalization
- i3
3 R
NET Trust .NET Users  Application
Levels Settings

Connection Machine Key Pages and

Ready

Select the Web_Site_Name.

]

4. In the Site Bindings window, click the Add... button.

Site Bindings
Type Host Name Port IP Address Binding Informa...
http 20 *
https 443 *
£

Click the Add button

5. In the Add Site Bindings window, complete these tasks:
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o Type: Select https.
o IP address: Select All Unassigned.

O Port: Default value is 443. If IIS is configured to use a different port for https, enter that port number.

O  SSL certificate: Select the certificate that you installed. Click OK.

Add Site Binding

Type: IP address: Port:
https ~ | |All Unassigned v| |4-43
Host name:

[ Require Server Name Indication

[] Disable HTTP/2
[] Disable OCSP Stapling

S5L certificate:
Mot selected hd Select...

Select SSL certificate

The site binding for port 443 is displayed.

? X

Cancel

Restart the IIS Service. Make sure that both websites have started.

Clients browsing to this virtual directory must now use HTTPS.

Testing SSL Access

To test SSL access to ECE:

1.
2.

Open your web browser.

Use HTTP in the URL for the application. For example, http:// Web_server FQDNI Partition, name

You should see a message asking you to view the page over a secure channel.

Now use HTTPS in the URL for the application. For example, https:// Web_Server FQDN/ Partition, name.

In the security message that appears, click the View certificate button.

After verifying the certificate information, click OK, then click Yes to proceed to the URL.

The ECE login window appears.
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Configuring SSL or TLS for Retriever and Dispatcher
Services

You need to perform these tasks only if you want to enable the retriever and dispatcher services to work with
SSL or TLS enabled mail servers. POP3, IMAP, SMTP, and ESMTP protocols are supported.

To configure TLS and SSL, you must:

O Install the certificates on the file server. (page 146)

a. Modify the alias configuration (page 147)

On the File Server

If your POP3, IMAP, SMTP, and ESMTP servers are installed on different machines, obtain the certificates for
all the servers and install them on the file server.

Perform these tasks on the file server. In case of Distributed File Server, perform these tasks on the Active Node.

Installing Certificates

To configure SSL or TLS on the file server:

1. Obtain the certificate for the SSL or TLS enabled mail server on which the email alias is configured. If your
POP3, IMAP, SMTP, and ESMTP servers are installed on different machines, obtain the certificates for all
the servers.

2. Copy the certificates to a location in £CE£_HOME.

3. Open the Command window and navigate to the bin folder in /OK_ #ome, the installation folder for JDK.
For example, the command will look like:

cd Install Drive\ ECE_HomeNenv\jdk\bin
4. Execute the following command to install the certificate:

keytool -import -trustcacerts -alias ALIAS NAME -keystore
"..\lib\security\cacerts" =-file "CERTIFICATE FILE PATH"

where:

CERTIFICATE_FILE _PATH is the complete path to the certificate that you copied in Step 2, including the
name of the file.

Alias_Nameis any name you want to assign to the certificate.

For example the command will look like:

keytool -import -trustcacerts -alias emailcertificate -keystore
"..\lib\security\cacerts" -file "D:\eG\ms_exchange_certificate.cer"

5. When prompted, provide the keystore password. If you had changed the keystore password earlier, provide
that password. If not, provide the default password, changeit.

6. Confirm the action when prompted.

7. To verify that the certificate is installed successfully, run the following command:
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keytool -list -v -keystore "..\lib\security\cacerts" -alias ALIAS NAME
where Alias_Nameis the name you assigned to the certificate in Step 4.

For example, the command will look like:
keytool -list -v -keystore "..\lib\security\cacerts" -alias emailcertificate
When prompted, provide the keystore password.

The output will list the installed certificate.

Deleting Certificates

Certificates generally have an expiry date. When your certificate expires, you might need to delete the old
certificates and install new ones. The following section describes the steps for deleting the certificates. After
deleting the certificates, repeat the steps in “Installing Certificates” on page 146 to install new certificates.

To delete a certificate:

1.

Open the Command window and navigate to the bin folder in jDK_ omee, the installation folder for JDK.
For example, the command will look like:

cd Install Drive\ ECE_Home\env\jdk\bin

Execute the following command to delete the certificate:

keytool -delete -alias ALzAS NAME -keystore "..\lib\security\cacerts"

where:

Alias_Name is the name you assigned to the certificate in Step 4.

For example the command will look like:

keytool -delete -alias emailcertificate -keystore "..\lib\security\cacerts"”

When prompted, provide the keystore password. If you had changed the keystore password earlier, provide
that password. If not, provide the default password, changeit.

In the Administration Console

To enable SSL for specific aliases:

1.

Log into the application as an administrator who can modify the email alias configuration and go to the
Administration Console.

In the Tree pane, browse to Administration > Departments > Depastiment_Name > Email > Aliases.
In the List pane, select the appropriate email alias.

In the Properties pane, go to the Servers tab and edit the following fields.
O  Connection type: Set this to SSL or TLS.

O  Port: Enter the secure port number.
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Properties: Marketing

General  Servers

Incoming Name Value

QOutgoing Server type POP3 ~
Server name * EMS2K
User name * user@company
Password * i [}
Verify password * D [}
Connection type 5L ~
Port * 995
Folder * inbox

Configure the alias properties

5. Repeat these steps for the Outgoing mail server, if required.

6. Save the changes.
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This chapter provides an overview of the process of setting up ECE-Unified CCE objects.

Configuring Variables in ECE

While sending new activity requests from a queue to Unified CCE, EAAS sends call variables and ECC
variables to Unified CCE as task context. By default, the following activity attributes are sent to Unified CCE as
ECC variables.

» For inbound and outbound email activities: activity_id
» For chat activities: activity_id
» For callback and delayed callback activities: activity_id, customer_name

If you need to pass on other attributes of the activity as call variables or ECC variables to Unified CCE, you need
to configure them in ECE. These variables can then be used in Unified CCE scripts to configure conditions. For
details, see the Unified CCE scripts documentation. If you plan to configure these variables as ECC variables in
ECE, you need to first create the ECC variables in Unified CCE. For details, see the Unified CCE
documentation.

You can also create variables for custom activity attributes. For details about creating variables, see the “Call
Variables” chapter in the Enterprise Chat and Email Administrator's Guide to Routing and Workflows.

Verifying Mapping of Objects in the Administration
Console

To verify that Unified CCE objects have been mapped correctly in the ECE
Administration Console:

1. Launch the URL: http://ECE_Web_Serverd D@‘W_Pﬂ//ddam

2. Login as the partition administrator (user name and password that were configured during the installation of
ECE). Go to the Administration Console.

3. Under the appropriate department, browse to the User > Users node in the Administration tree, to verify that
all users mapping to the administrators, supervisors, and agents, which were selected at the time of
importing the objects, are displayed. For details, see the Enterprise Chat and Email Administrator’s Guide
to Administration Console.

4. Under the appropriate department, click the User > Groups node in the Administration tree to verify that all
user groups mapping to the skill groups, which were selected at the time of importing the objects, are
displayed. For details, see the Enterprise Chat and Email Administrator’s Guide to Administration Console.

5. Under the appropriate department, click the Workflow > Queues node in the Administration tree, and verify
that all queues mapping to the MRDs, which were selected at the time of importing the objects, are
displayed. For details, see the Enterprise Chat and Email Administrator’s Guide to Routing and Workflows.
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Setting up Business Objects in the Administration
Console

See the following guides for the details of the procedures mentioned in this section:

4

4

4

Enterprise Chat and Email Administrator’s Guide to Routing and Workflows
Enterprise Chat and Email Administrator’s Guide to Email Resources

Enterprise Chat and Email Administrator’s Guide to Chat and Collaboration Resources

To set up ECE business objects in the Administration Console:

1.
2.
3.

Launch the URL: http://ECE_Web_Serverd Dg‘xﬂtﬁ%/tétéom
Log in as the partition administrator and go to the Knowledge Base Console.

In the Knowledge Base tree, browse to Departments > Department_Name > Content > Shared > Standard
> Email. Create an article in each of the sub-nodes to set up one option each for a header, greeting,
signature, footer, and auto acknowledgments that can be used in responses to incoming activities in the
department.

Go to the Administration Console.

In the Administration tree, browse to the Administration > Departments > Department_Nome >
Classifications > Categories node. Create categories.

These categories will be used later in a workflow (see page 151).

Now, browse to the Email > Aliases node. Create an alias to serve as the entry point for emails into the
system.

Then, browse to the Workflow > Workflows > Inbound node to create an inbound workflow for this alias.
The workflow will route incoming emails. Add the alias created in Step 6 to the Start node. Add the email
queue to the Queue node. Select the auto-acknowledgment KB article created earlier (see page 151) for the
Auto-acknowledgment node. Select the categories created in Step 5 for the Classifications node.

Browse to the Chat > Entry points node. Create new entry points by assigning the appropriate templates.
To route chats and call back activities that enter from this entry point, use an auto-configured queue. Make
the entry points active. The configuration steps for entry points are different for different types of activities
and routing options.

The activity types for which you need to create entry points are: Chat, Callback, Delayed callback.

In the Properties pane, click the Show HTML button. The code used to generate a chat hyperlink to that
entry point is displayed. Copy this link code into a Notepad file. Edit the code as explained in the Enterprise
Chat and Email Administrator’s Guide to Chat and Collaboration Resources.
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Setting Up Services in the System Console

Service processes are managed at the system level as shared resources across partitions. Service instances are
managed within partitions.

See Enterprise Chat and Email Administrator's Guide to System Console for the details of the procedures
mentioned in this section.

This section helps you set up processes and instances for the following services:

4

»

Retriever: Gets incoming emails from configured aliases and parses them.

Workflow Cache: Maintains the files that store information about objects used in workflows.
Workflow Engine: Applies workflows on emails to automate their routing and handling.
Dispatcher: Sends outgoing emails out of the system.

External Agent Assignment Service (EAAS): Identifies new activities that arrive into an external
assignment queue, and routes requests for each of these activities to Unified CCE for routing to take place
through Unified CCE.

External Agent Messaging Service (EAMS): Assigns activities to target agents or user groups (skill
groups) identified by Unified CCE, and reports the status of both the activity and the agent to Unified CCE
throughout the life cycle of the given activity.

Context Service: This service synchronizes activities and customer’s information between the Cisco ECE
and Cisco Context Service. This service only applies to systems using Cisco Context Service. For details on
Context Service availability, visit https://help.webex.com/community/context-service. Note that Cisco
Context Service is deprecated from Release 12.0(1) onward.

To set up ECE services in the System Console:

See Enterprise Chat and Email Administrator's Guide to System Console for the details of the procedures
mentioned in this section.

1.

Open a new browser window, and launch the URL: http://ECE Web_ Serverl Context Root. Log in as the
system administrator (user name and password that were configured during the installation of ECE). Go to
the System Console.

Browse to the Partitions > rartition.> Services > Email > Retriever node. Click the Retriever instance to
use in the partition, and select the email alias that you had created earlier in the Administration Console (see
page 151).

Restart the Retriever process and instance based on the notification message that appears. Browse to Shared
Resource > Services > Retriever, and stop and start the Retriever process for the system. Also ensure that
the start type for the service process is set to automatic.

Navigate back to the Partitions > rastition > Services > Retriever node. Ensure that the start type for the
service instance is set to automatic. Stop and start the Retriever instance.

Browse to Shared Resource > Services > Workflow > Workflow Cache and verify that the Workflow
Cache process is running. If the process is in a stopped state, start the process by clicking the Run button.
Also ensure that the start type for the service process is set to automatic.

Browse to Partitions > rastition > Services > Workflow > Workflow Cache and ensure that the start type
for the service instance is set to automatic. Start the Workflow Cache instance.
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10.

11.

12.

13.

14.

15.

16.

Browse to Shared Resource > Services > Workflow > Workflow Engine and verify that the Workflow
Engine process is running. If the process is in a stopped state, start the process by clicking the Run button.
Also ensure that the start type for the service process is set to automatic.

Browse to Partitions > Partition > Services > Workflow > Workflow Engine and ensure that the start type
for the service instance is set to automatic. Start the Workflow Engine instance.

Browse to Shared Resource > Services > Email > Dispatcher and verify that the Dispatcher process is
running. If the process is in a stopped state, start the process by clicking the Run button. Also ensure that the
start type for the service process is set to automatic.

Browse to Partitions > Partition > Services > Email > Dispatcher and ensure that the start type for the
service instance is set to automatic. Start the Dispatcher instance.

Browse to Shared Resource > Services > Unified CCE > EAMS and verify that the EAMS process is
running. If the process is in a stopped state, start the process by clicking the Run button. Also ensure that the
start type for the service process is set to automatic.

Browse to Partitions > rartition. > Services > Unified CCE > EAMS. Verify that the EAMS instance for
the Agent PG is automatically created. Also ensure that the start type for the instance is set to automatic.
Then start the EAMS instance.

Browse to Shared Resource > Services > Unified CCE > EAAS and verify that the EAAS process is
running. If the process is in a stopped state, start the process by clicking the Run button. Also ensure that the
start type for the service process is set to automatic.

Browse to Partitions > rartition. > Services > Unified CCE > EAAS. Configure the EAAS instance by
providing the MR Connection port number you provided while creating the MR PG (page 60). Also ensure
that the start type for the instance is set to automatic. Start the EAAS instance.

Browse to Shared Resource > Services > Unified CCE > Context Service and verify that the Context
Service process is running. If the process is in a stopped state, start the process by clicking the Run button.
Also ensure that the start type for the service process is set to automatic. If the ECE services server is behind
a firewall and does not have direct access to the internet, the Proxy Server URL should be provided so that
the server can connect to the Cisco Context Service. Format of the URL is:
http://ProxyServerName:Port or https://ProxyServerName:Port

Browse to Partitions > rastition > Services > Unified CCE > Context Service. Ensure that the start type
for the instance is set to automatic. Then start the Context Service instance.

Setting Up Web Links for Chat and Callback

To create a chat and collaboration link on your web site:

4

Open the code view of the host web page and add the edited link code (see page 151) from the entry point
properties at the appropriate point. You may need to ask your web master to perform this task.

ECE is now ready for use. To verify, log in as an agent, supervisor, or administrator and perform basic tasks.
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Configuring Dynamic Messages for Integrated Chats

Dynamic Run Application Script Request (DRASR) allows you to display wait messages with dynamic text
(such as expected wait time) to customers while chat and call requests are being processed by the ECE and
Unified CCE integrated systems. You can use ECC variables and call variables to display the dynamic content.
For details about configuring DRASR, refer the Enterprise Chat and Email Administrator’s Guide to Chat and
Collaboration Resources.

Related Documentation

Refer to the following ECE User’s Guides (for the Unified CCE integration) for more information about
configuring and using ECE.

O]

Enterprise Chat and Email Administrator’s Guide to Administration Console helps administrators set up
and manage business objects.

Enterprise Chat and Email Administrator’s Guide to Chat and Collaboration Resources helps
administrators set up templates and entry points.

Enterprise Chat and Email Administrator’s Guide to Email Resources helps administrators set up
aliases, blocked addresses, delivery exceptions, and blocked file extensions.

Enterprise Chat and Email Administrator’s Guide to Routing and Workflows helps administrators set up
service levels, queues, and workflows.

Enterprise Chat and Email Administrator’s Guide to System Console helps system administrators set up
and manage services, loggers, and system monitors.

Enterprise Chat and Email Administrator’s Guide to Tools Console helps administrators add custom
attributes.

Enterprise Chat and Email Supervisor’s Guide helps supervisors set up and use agent and queue
monitors.

Enterprise Chat and Email Administrator’s Guide to Reports Console helps managers and supervisors
to set up and run reports to analyze various aspects of the system.

Enterprise Chat and Email Agent’s Guide helps agents handle email and chat interactions.
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Installing DFS Management

Perform these tasks on both the servers where you want to store the ECE file share for DFS.

To install DFS by using Server Manager

1. Open Server Manager, click Manage, and then click Add Roles and Features. The Add Roles and Features
Wizard appears.

2. On the Server Selection page, select the server on which you want to install DFS.

3.  On the Server Roles page, in File and Storage Services > File and iSCSI Services, select DFS
Namespaces and DFS Replication. Run through the wizard to complete the installation.

Creating Shared Folders

Perform these tasks on all the servers where you want to store the ECE file share for DFS.

To create a shared folder:
1. Create a folder on the server where you want to store the ECE file share for DFS.
2. Right-click the folder and select Properties. Set the following in the properties window:

a. Go to the Security tab and click the Edit button. Add the Service account and assign the Service
account Modify permissions on the folder. Click Apply.

b. Go to the Sharing tab and click Advanced Sharing and select the Share this folder option in the
Advanced Sharing window. Click the Permissions button and in the Permissions window, assign the
Service account Full Control permission on the folder.

c. From the Sharing tab, copy the Network Path of the shared folder and access it from the second server
to make sure it is accessible. Create a test folder in the shared folder to test the permissions.

Repeat these steps on the other servers.

Creating New Namespace

Perform these tasks on one of the file servers where you want to store the ECE file share for DFS.

To add new namespaces:

1. In the DFS Management window, browse to DFS Management > Namespaces.
2. Right-click Namespaces and select New Namespaces from the context-menu.
3. Inthe New Namespace Wizard, set the following:

a. On the Namespace Server screen, click the Browse button and provide the name of the server where
you created the shared folder. Click Next.
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b. On the Namespace Name and Settings screen, provide a name for the namespace. Click the Edit
Settings button. In the Edit Settings window, select the Administrators have full access; other users
have read-only permissions option. Click Next.

c.  On the Namespace Type screen, select Domain-based namespace. Select the Enable Windows
Server 2008 mode option. Click Next.

d. On the Review Settings and Create Namespace screen, note down the Namespace Name (this is the
UNC path where you access the share). Click Create.

4. Click Close to exit the wizard.

Adding Namespace Server

Perform these tasks on other file servers in the deployment.

To add the namespace server:
1. In the DFS Management window, browse to DFS Management > Namespaces.

2. Right-click the namespace you created on page 156 and select Add Namespace Server from the context-
menu.

3. Inthe Add Namespace Server window, click Browse in the Namespace server field. In the Select Computer
window provide the name of the second server where you created the shared folder. Click the Edit Settings
button. In the Edit Settings window, select the Administrators have full access; other users have read-
only permissions option. Click OK.

4. Select the Namespace Servers tab and check that both servers are listed.
5. Click on the Properties link of the Namespace.
The Properties window opens.

6. In Properties window, go to the Advanced tab.
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7. Select the Enable access based enumeration for this namespace checkbox and click OK.

\\eger.info\Root Properties b4

General Referals Advanced

Mamespace servers poll a domain controller to obtain cument namespace
metadata. You can optimize polling to increase either namespace
consistency or scalability.

How do you want to optimize poling?
(® Optimize for consistency

MNamespace servers poll the primary domain controller (FDC)
emulator each time the namespace changes.

(O Optimize for scalability

Each namespace server polls its closest domain controller at
regular intervals. This is known as namespace scalability mode.

Access-based enumeration hides folders in this namespace that users
do not have pemmission to view.

Enable access-based enumeration for this namespace

Cancel Apply

Enable access based enumeration

Adding Folders and Configuring Replication

For Two Server Installations

Creating Folders on Side B
» Create the following directories on Side B.
e  Drive Name\ECE Files\env
o  Drive Name\ECE Files\eService
o  Drive Name\ECE Files\Uninstaller

o  Drive Name\ECE Files\Utilities

Adding Folders

To add folders and configure replication:
1. In the DFS Management window, browse to DFS Management > Namespaces > DFS created for ECE.

2. In the Actions section, click the New Folder button. Set the following in the New Folder window.
O Provide a name for the folder. For example, ECE.

O In the Folder targets, add the network path of both the shared folders created on the ECE servers.
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3. When prompted to create a Replication group, click No.

4. In the DFS Management window, right-click the Replication folder and from the menu select New
Replication Group.

5.  Run through the New Replication Group Wizard to set up replication.

a.

b.

On the Replication Group Type screen, select Multipurpose Replication Group. Click Next.

On the Name and Domain screen, provide a Name of replication group and specify the Domain.
Click Next.

On the Replication Group member screen, add the servers to be the list. Click Next.
On the Topology selection screen, select Full mesh. Click Next.

On the Replication group Schedule and Bandwidth screen, select the Replicate continuously with
specific Bandwidth option. Click Next.

On the Primary Member screen, select any one server to be the primary server. Click Next.
In the Folders to Replicate screen, add the following folders and click Next.

®  Drive Name\ECE_tHome\env

o  Drive Name\ECE_Home\eService

o  Drive Name\ECE tHome\Uninstaller

o  Drive Name\ECE Home\Utilities

On the Local Path of env on other members screen, click the Edit button and in the Edit window, select
Enabled and provide the Local path for env on side B (page 158). Click OK to close the window. Click
Next.

On the Local Path of eService on other members screen, click the Edit button and in the Edit window,
select Enabled and provide the Local path for eService on side B (page 158). Click OK to close the
window. Click Next.

On the Local Path of Utilities on other members screen, click the Edit button and in the Edit window,
select Enabled and provide the Local path for Utilities on side B. Click OK to close the window. Click
Next.

On the Local Path of Uninstaller on other members screen, click the Edit button and in the Edit
window, select Enabled and provide the Local path for Uninstaller on side B (page 158). Click OK to
close the window. Click Next.

On the Review Settings and Create Replication Group screen, ensure the information provided is corrct
and click Create.

6. Once replication is setup, set the Staging folder quota for the replication. You must set a number based on
the available bandwidth and the size of the files to be replicated. Follow Microsoft documentation for
guidelines for setting the quota numbers.

For Distributed Server Installations

To add folders and configure replication:

1. In the DFS Management window, browse to DFS Management > Namespaces > DFS created for ECE.
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2. In the Actions section, click the New Folder button. Set the following in the New Folder window.

O  Provide a name for the folder. For example, ECE.

O In the Folder targets, add the network path of both the shared folders created on the ECE servers.
3. When prompted to create a Replication group, click Yes.

4. Once replication is setup, set the Staging folder quota for the replication. You must set a number based on
the available bandwidth and the size of the files to be replicated. Follow Microsoft documentation for
guidelines for setting the quota numbers.
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About Always On Availability Group Clustering

@ Important: ECE supports the clustering feature only for installations using the Enterprise Edi-
:% tion of MSSQL.

This chapter talks about an Always On cluster configuration with two nodes. You can add more nodes, if
required. The two deployment models supported are:

1. Reports database and active and master databases are on the same node with a common availability group
for the databases.

2. Reports database is on one node and active and master databases are on a separate node with respective
availability groups for each node.

@ Important: Ensure that all the databases related pre-installation and post-installation tasks
% are performed on all nodes in the cluster.

Pre-Installation Tasks

Installing Failover Clustering Feature

Perform this task on for all nodes of active and reports databases.

To install the failover cluster feature:

1. Open Server Manager, click Manage, and then click Add Roles and Features. The Add Roles and Features
Wizard appears.

2. On the Server Selection page, select the server on which you want to install the Failover Clustering.

3. On the Features page, select Failover Clustering. Run through the wizard to complete the installation.

Creating Prestage Cluster Computer Objects in Active Directory Domain
Services (AD DS)

To create the cluster name object (CNO) automatically, the user who creates the failover cluster must have the
Create Computer objects permission to the organizational unit (OU) or the container where the servers that will
form the cluster reside.

To enable a user or group to create a cluster without having this permission, a user with appropriate permissions
in AD DS (typically a domain administrator) can prestage the CNO in AD DS.

These tasks are done by a network administrator.
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Prestaging the CNO in AD DS

To prestage the CNO in AD DS:

1.

On a computer that has the AD DS Tools installed from the Remote Server Administration Tools, or on a
domain controller, open Active Directory Users and Computers. To do this on a server, open Server
Manager and from the Tools menu, select Active Directory Users and Computers.

In Active Directory Users and Computers, on the View menu, make sure that Advanced Features is
selected.

Create an OU, if it does not exists. For the cluster computer objects, right-click the domain name or an
existing OU, and select New > Organizational Unit. In the Name box, enter the name of the OU, and then
click OK.

In the console tree, right-click the OU where you want to create the CNO, point to New, and then select
Computer.

In the Computer name box, enter the name that will be used for the failover cluster, and then select OK.

As a best practice, right-click the computer account that you just created, click Properties, and then click
the Object tab. On the Object tab, select the Protect object from accidental deletion check box, and then
click OK.

Right-click the computer account that you just created, and then select Disable Account. Select Yes to
confirm, and then select OK. You must disable the account so that during cluster creation, the cluster
creation process can confirm that the account is not currently in use by an existing computer or cluster in the
domain.

Granting User Permissions to Create Cluster

To grant user permissions to create cluster:

1.

In Active Directory Users and Computers, on the View menu, make sure that Advanced Features is
selected.

Locate and then right-click the CNO, and then click Properties.
On the Security tab, click Add.

In the Select Users, Computers, or Groups dialog box, specify the user account or group that you want to
grant permissions to, and then click OK.

Select the user account or group that you just added, and then next to Full control, select the Allow check
box.

Select OK.

Granting the CNO Permissions to the OU

To grant the CNO permissions to the OU:

1.

In Active Directory Users and Computers, on the View menu, make sure that Advanced Features is
selected.
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9.

Right-click the OU where you created the CNO (page 163) and then select Properties.
On the Security tab, select Advanced.

In the Advanced Security Settings dialog box, select Add.

Next to Principal, select Select a principal.

In the Select User, Computer, Service Account, or Groups dialog box, select Object Types, select the
Computers check box, and then select OK.

Under Enter the object names to select, enter the name of the CNO, select Check Names, and then select
OK. In response to the warning message that says that you are about to add a disabled object, select OK.

In the Permission Entry dialog box, make sure that the Type list is set to Allow, and the Applies to list is set
to This object and all descendant objects.

Under Permissions, select the Create Computer objects and Delete Computer Object check boxes.

10. Select OK until you return to the Active Directory Users and Computers snap-in.

Creating Windows Failover Cluster

Perform this task on one active server node and one reports database node.

To install Windows server failover cluster:

1.
2.

Open Server Manager and from the Tools menu, select Failover Cluster Manager.

In the Failover Cluster Manager, right-click Failover Cluster Manager and select Create Cluster from the
menu.

In the Create Cluster Wizard, on the Select Servers screen, enter the Server Name for both active database
servers to be added to the cluster and Click Add.

On the Validation Warning screen, select Yes to validate the cluster nodes. The program will run you through
the validation process.

On the Access Point for Administering the Cluster screen, provide the Cluster Name. This is the name of
the computer object created in the Active Directory. Enter the IP address reserved for the Windows Cluster
Name Object. You will need two IPs for the Cluster if the target servers are at two different subnets. Click
Next.

On the Confirmation screen, uncheck the Add all eligible storage to the cluster option. Click Next.
Click Finish on the Summary screen.

Repeat this task for the reports database node. In Step 3, add the reports database servers.

Configuring Permissions for the File Share Witness Folder

To configure permissions for the file share witness folder:

1.
2.

Create folder on the VM which is used for file share witness (for example, Quorum126)

Give Full control permission to the CNO user on this (for example, collocatedHA which is the CNO in the
organization unit (OU)). Perform the following tasks:
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a. Right click on the folder created in Stepl and select Properties > Security> Edit > Add.

b. Under the Select Users, Computers, Service Accounts or group dialogue box, click the Object
Types button.

c. Search for the CNO user created for the failover cluster (for example, CollocatedHA).
Give Full control permission to the recently created user.

Go to Sharing tab and ensure that the user is added to list with Read/ Write permission.
Click on the Share button for path sharing.

Follow the quorum setting configuration available in “Configure Cluster Quorum Settings” on page 165.

Configure Cluster Quorum Settings

Quorum is a configuration database for the cluster and is stored on a shared location, accessible to all of the
nodes in a cluster.

In case of even number of nodes (but not a multi-site cluster) Node and Disk Majority Quorum configuration
is recommended. If you don't have a shared storage, Node and File Share Majority is recommended. Here it
will be configuring a FileShare Witness quorum.

It is recommended that you configure the quorum size to be 500 MB. This size is the minimum required for an
efficient NTFS partition. Larger sizes are allowable but are not currently needed.

Perform this task on one active server node and one reports database node.

To configure cluster quorum settings:

1.

A

In the Failover Cluster Manager, right-click the cluster you added. From the context-menu, go to More
Actions > Configure Cluster Quorum Settings....

In the Configure Cluster Quorum Wizard, on the Before You Begin screen, click Next.
On the Select Quorum Configuration Option screen, select the Select the quorum witness option.
On the Select Quorum Witness screen, select the Configure a file share witness option.

On the Configure File Share Witness screen, click the Browse button next to the File Share Path field. In
the Browse for Shared Folders window that opens, select the shared folder that you want to use and click
OK. Now Click Next.

It is recommended to have the share folder on a different node than the participating nodes on cluster.

Run through the rest of the wizard to complete the configuration.

Verifying Cluster Settings

1.
2.

Right-click the cluster, and select Validate Cluster.

Review Cluster At this point. The cluster should be fully setup and confirmed to work properly.
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Review the Failover Cluster Manager for any errors. In the Cluster Events node, you can find Windows
Events which are directly related to the cluster. Since the IP address that matches the subnet of the non-
primary server is not accessible until the cluster switches sides, you can ignore the errors related to the dual-
subnet. If you see other errors, investigate and resolve each error.

Enabling Always On Availability Groups Feature on SQL

Perform this task on one active server node and one reports database node.

To enable always-on availability groups feature:

1.
2.
3.

Open the SQL Server Configuration Manager and browse to SQL Server Services.
In the list pane, right-click SQL Server service and select Properties.

In the Properties window, go to the AlwaysOn High Availability tab and select the Enable AlwaysOn
Availability Groups option. You will be prompt to restart the SQL Server service. Click OK.

Perform this task on both servers (primary and secondary).

Change the service account of all SQL server services to the SQL Services Account that you have created
for the ECE application. If you didn’t create a SQL Services Account, use the Service Account created for
the ECE application (page 37).

Restart the SQL Server services.

Configuring SQL Server Always On Availability Groups

Before configuring the SQL Server Always On Availability Groups, perform the following tasks:

»

Adhering to the Microsoft recommendations for SQL Always-On configuration, configure the system in the
Automatic mode.

Verify the stability of the Failover Cluster instance using a Fileshare witness ensuring that it is consistently
online and in a healthy state. This should be supported by a minimum of two upvotes to reinforce robust
high-availability and failover capabilities.

For efficient and automatic synchronization of database replicas within the Always On availability group, set
the Automatic Seeding setting to Yes.

Perform this task on one active server node and one reports database node.

To configure SQL server always on availability group:

1.

First, create a temporary database. This database is required only for creating the availability group. The
database should be in fully recovery model and at least one full backup of the database must be performed.

@ Important: Ensure that a new endpoint is created for the named instance before setting up a
% new availability group.

Go to Management Studio, right click AlwaysOn High Availability and select New Availability Group
Wizard.

In the Specify Availability Group Name screen, provide a name for the group. Click Next.
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In the Select Database screen, select the temporary database created in Step 1. Ensure that th Status is
Meets prerequisites. Click Next.

In the Replica screen, set the following:

O On the Replicas tab, click the Add Replica button to add all the nodes. Select the Synchronous
Commit option for both nodes. For secondary replicas, select the Yes option under the Readable
Secondary column.

O On the Endpoints tab, verify the server names and endpoint URLs.

O On the Backup Preferences tab, select the Any Replica option to allow backup operation at both
primary and secondary servers.

On the Listener tab, provide a fully qualified listener name, which is registered with the DNS, port (default
1433), and select the Static IP option. Click the Add button. In the Add IP Address window, add a static IP
address. Like cluster creation, you need two IPs if the target servers are on two different subnets. Select the
respective subnet from the dropdown and add the respective IP address for that.

On the Summary screen, verify the choices made in the wizard. Click Finish to start the process.
On the Select Initial Data Synchronization page, select the Full option. Click Next.

The Results screen shows if all the tasks are completed successfully. Click Close.

Additional Configuration for Multi-subnet Availability Group

There are two parameters that affect how the AGL is registered with DNS. By modifying these parameters on the
server we can transparently change the experience of the client OS in its name resolution caching.

1.

Open Power Shell as Administrator from the Primary node and import the FailoverCluster module using
the following command:

Import-Module FailoverClusters
To get the Get cluster and the listener name, use the following command:
Get-ClusterResource

Change the value of the RegisterAllProvidersIP and HostRecordTTL parameters for both cluster (for
windows failover) and listener (for SQL Server failover).

Please note that you need to replace <Cluster Naume> with the cluster name and </istener Name> with the

cluster listener name in the script below.

Get-ClusterResource "<cluster Name>" | Set-ClusterParameter RegisterAllProvidersIP
0

Get-ClusterResource "<Cluster Nume>" |Set-ClusterParameter HostRecordTTL 60

Get-ClusterResource "<Llistenmer Nume>" | Set-ClusterParameter
RegisterAllProvidersIP 0

Get-ClusterResource "<Llitemer Nume>" | Set-ClusterParameter HostRecordTTL 601

Restart the Cluster and the listener. Replace <cluster Name> with the cluster name and <Zistener Name> with
the cluster listener name in the script below.

Stop-ClusterResource "<Cluster Naume>"
Start-ClusterResource "<Cluster Nume>"
Stop-ClusterResource "<Listener Name>"
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Start-ClusterResource "<[listener Name>"

Install the Application

» Install the ECE application. See “Installation Process” on page 78.

Post-Installation Tasks

Verifying Recovery Model

Verify that the recover model for ECE databases is set to ful L.

To view or change the recovery model:

1. In the SQL Server Management Studio, browse to the ECE databases.

2. Right-click the database, and from the context menu select Properties.

3. In the Database Properties window, go to the Options section and set the Recovery model to Full.
4

Click OK.

Backing up ECE Databases

» Take a full backup of all ECE databases - Active database, Master database and Reports database. As per
availability group requirements, the database must be backed up once in full recovery mode.

Adding Databases to Availability Group

To add databases to the availability group:
1. Open SQL Server Management Studio and connect with the primary database server or Listener.
Go to AlwaysOn High Availability > Availability Groups > your Availability Group:

Right-click the availability group and from the context menu select Add database.

On the Select Data Synchronization page, select the Join Only option. Click Next.

2

3

4. On the Select Databases page, select the databases from the list of available databases and click Next.

5

6. In the next window click Connect to check the connection with the secondary server then click on Next.
7

You will be notified if the connection is successful.
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Run reports DB utility to configure secondary nodes

Running the Reports Database Utility

This utility needs to be run to complete the reports database configurations on the secondary nodes. Perform this
task on the services server.

@ Note: The Reports Database utility should only be run for fresh installations and major version
¥/ upgrades and not for minor upgrades.

To run the utility:

1.

From the installation package, copy the ReportsDB Utility (SQL Server Always On) folder on the services
server.

Open the reportsdb_utility.properties file in a text editor and set the following properties:

c 0O O O ©0

c 0O O 0O ©0

EGAIN_HOME_DIR: Provide the location of the ECE home directory.
IS_WINDOWS_AUTHENTICATION: Set the value to true.
CREATE_DBLINK_FROM_CONNPOOLMAP: Value is set to true and should not be changed.
REPORTS_DB_SERVER_NAME: Server name of the secondary node for the reports database.
REPORTS_DB_LST_PORT: Provide the port number.

REPORTS_DB_INSTANCE_NAME: Provide the instance name.

REPORTS_DB_NAME: Provide the name of the reports database.

ACT_DB_SERVER_NAME: Server name of the secondary node for the active database.
ACT_DB_LST_PORT: Provide the port number.

ACT_DB_INSTANCE_NAME: Provide the instance name.

ACT_DB_NAME: Provide the name of the active database.

Open the command prompt as an administrator and navigate to the utility folder.

Run the following command:

Mf&éétnyomtém\reportsdb_uti lity.bat createDBObjects

For example, D:\utility\reportsdb_utility.bat createDBObjects

The following log files are created at the same location from where the utility is run:

o

o

reportsdb_validation.log: Check this file to verify that no errors are logged in the file.

eg_log_serv234_ReportsDBUtil.Llog: Check the file to see the status of the utility. You will see
the following message when all the tasks are completed - ReportsDB utility is executed
successfully
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Run the UpdateDBIndexStats Utility

Running the UpdateDBIndexStats Utility

The UpdateDBIndexStats Utility can be used for updating index statistics for ECE active and reports database
specifically after a major upgrade.

To run the utility:
1. On the Services Server, open the input.properties file in a text editor.

2. Provide values for following properties in input.properties file:

o ACTIVE_DATABASE_URL: Specify the JDBC URL for the Active DB. This URL can be obtained
from <ECE File Server Install
Directory>\eServicelinstallation\dataaccess\egpl_ds_connpool_map.xm file.
Perform the following steps:

e Open egpl_ds_connpool_map.xml in a text editor.
e Locate the <connpool> XML node definition having the name as Platform_MSSQL_Pool.

e Locate the child node with the name Url in it. The content of this node is the JDBC URL for Active
DB. (For example: jdbc:sqlserver://<DB server
name>:1433;integratedSecurity=true;databaseName=<Database Name>)

O  ACTIVE_USER: If SQL authentication is used to connect to the Active DB, specify the user name that
is used to connect to the Active DB. If Windows Authentication is used to connect to the Active DB,
then keep this blank.

O ACTIVE_PASS: If SQL authentication is used to connect to the Active DB, specify the password for
the user name mentioned above. If Windows Authentication is used to connect to the Active DB, then
keep this blank.

o REPORTS_DATABASE_URL: Specify the JDBC URL for the Reports DB. This URL can be obtained
from <ECE File Server Install
Directory>\eServicelinstallation\dataaccess\egpl_ds_connpool_map.xmlL.

e Open egpl_ds_connpool_map.xml in a text editor.
e Locate the <connpool> XML node definition having the name as ReportsDB_MSSQL_Pool.

e Locate the child node with the name Url in it. The content of this node is the JDBC URL for the
Active DB. (For example: jdbc:sqlserver://<DB server

name>:1433;integratedSecurity=true;databaseName=<Database Name>)

o REPORTS_USER: If SQL authentication is used to connect to the Reports DB, specify the user name
that is used to connect to the Reports DB. If Windows Authentication is used to connect to the Reports
DB, then keep this field as blank.

O REPORTS_PASS: If SQL authentication is used to connect to the Reports DB, specify the password for
the user name mentioned above. If Windows Authentication is used to connect to the Reports DB, then
keep this field as blank.

3. Save the changes.
4. Open UpdateDBIndexStats.bat in a text editor.

5. Replace <JAVA_HOME> with the JDK home directory. For example, C: \ECE\ jdk.
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6. Save the changes.
7. Run UpdateDBIndexStats.bat file in the command prompt.

8. After running the utility, check UpdateDBIndexStats.log (generated in the same folder) for details
about the last execution of the utility.

Creating Jobs to Take Log backups on All Nodes

Perform this task on all active server nodes and all reports database nodes. Create jobs on all databases to take
backups of logs every 30 minutes. This is required as the database log grows rapidly when the Always On
Availability feature is enabled.

You can use the following script to create jobs for log backups:

» BACKUP LOG [egActiveps]l TO DISK = 'Path\eGActiveDB_LOG_backup.trn' WITH INIT

» BACKUP LOG [egMastesrDB] TO DISK = 'Path\eGMasterDB_LOG_backup.trn' WITH INIT

» BACKUP LOG LeReportsDB] TO DISK = ' Path\eGReportsDB_LOG_backup.trn' WITH INIT
Replace, eGActiveDB, eGMasterDB, and eReportsDB with the database names.

Replace rath with the backup folder path.

m



Appendix C: Convert
Existing Deployment to
HA

» Converting Existing Two Server Installation to HA

» Converting Existing Distributed Server Installation to HA



Converting Existing Two Server Installation to HA

This section helps you convert your existing two server installation into an HA installation. Please ensure that
the SQL is upgraded to the Enterprise version.

Existing installation and VMs:

» VM-A: ECE All-in-One server (file, messaging, application, services and database components are installed
on this server). Please create a new home directory for the installation, for example, ECE_ALL. This will
become the Windows Distributed File System Nodel for file server.

» VM-B: ECE Web server component
Acquire New VMs for Side B (Windows 2019):

» VM-C: For installing the second Messaging, Services, and Application server components, please create a
new home directory, for example, ECE_AMS and another home directory to install the file server, for
example, ECE_FILE. This will become the Windows Distributed File System Node?2 for file server. For
more information on the creation of the ECE_FILE folder and its sub folders for file server replication, see
“Appendix A: Distributed File System Configuration” on page 155.

» VM-D: For second web server component

Data Center 1 Data Center 2
l.....]

Virtual Server with one IP
Load Balancer Load Balancer

DMz DMz

Web Server 1 Web. Server 2

App Server 1 App Server 2

Primary Services

Secondary Services
Server &

Server

Messaging Cluster

Windows Server Failover Clustering (WSFC) Cluster
using AlwaysOn Availability Groups

i NodetsaL : ! NodezsaL i
: Server : : Server

Instance i i Instance

I Windows Distributed File System 1

All'in one box 1 All'in one box 2
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Converting Existing File Server to DFS

Setting up Distributed File System (DFS)

» Install and Enable DFS Namespace and DFS Replication roles and features on VM-A and VM-C. For
details, see “Appendix A: Distributed File System Configuration” on page 155.

Installing Second Messaging, Services, and Application Server Components

» Install the new components on VM-C. While installing:
O  In the Installation Options window, select Messaging Server, Services Server, and Application Server.

O In the File Server Parameters window, provide the new DFS location.

Installing Second Web Server Component

» Install the new component on VM-D. While installing:

O In the Installation Options window, select Web Server.

Converting Databases to SAL Server to Always On Configuration

Perform all the tasks listed in the following table in the order defined.

Task Notes

Perform all the required pre-installation tasks on the new database
servers. “Pre-Installation Tasks” on page 31

“Stopping ECE Application and Disable SQL Jobs.” on page 175

If your existing database uses SQL Authentication, convert SQL
Authentication to Windows Authentication.

“Converting SQL Authentication to Windows Authentication” on page 175

“Installing Failover Clustering Feature” on page 162

“Creating Prestage Cluster Computer Objects in Active Directory Domain
Services (AD DS)” on page 162

“Creating Windows Failover Cluster” on page 164
“Configure Cluster Quorum Settings” on page 165

“Enabling Always On Availability Groups Feature on SQL" on page 166

“Configuring SAL Server Always On Availability Groups” on page 166
> In Step 4, select existing ECE active, master, and reports databases.
» In Step 6, select Join option.

“Verifying Recovery Model” on page 168
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Task Notes

“Backing up and Restoring Databases” on page 176

“Adding Databases to Availability Group” on page 168

“Updating Files and Databases with New Listener Names” on page 176
Ensure that the load balancer URL is being used as the External URL of
Application. For more information, refer to“Mandatory Settings” on
page 108

“Run reports DB utility to configure secondary nodes” on page 169

“Creating Jobs to Take Log backups on All Nodes” on page 171

Sto

1.

“Creating an Encrypted SQL Server Database” on page 98

“Starting the SAL Jobs and ECE Application” on page 177

pping ECE Application and Disable SQL Jobs.

Stop the ECE application. See “Stopping ECE” on page 104.

2. Disable the following jobs on ECE database machines.

o0 EG_OFFERS_SUMMARIZATION_ Active Database. Name
o egicm_data_cleanup_job_Active Database. Name

O egicm_reindex_active_job_Active Database Name

O egicm_reindex_reports_job_Reports_Database. Name

O egut_async_index_create_/Active Database Name

O egut_async_index_create_ Reports_ Database, Name

O populatesmy_Reports_Database_Name

Converting SQL Authentication to Windows Authentication

5\ Important: Windows Authentication is required for setting Always On. You need to perform this
¥ task only if your existing installation does not use Windows Authentication.

To convert SQL authentication to Windows authentication:

1.

2
3.
4

Stop the ECE application.
Follow steps to configure Windows Authentication on MSSQL Server as mentioned in the installation guide.
On the file server, go to the ECE installation folder.

Make the following changes in the file:
ECE_HoME\eServicelinstallation\dataaccess\egpl_ds_connpool_map.xml

a. Locate <conn_pool_list.

b. In all connpool nodes in the list, remove the values of User and Password nodes.
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c. In all connpool nodes in the list, for the Url node, change all references of
integratedSecurity=falseto integratedSecurity=true

For example, change:

<User egid="3026">eGActiveDB</User>

<Password egid="3027">36423441363</Password>

<Url
egid="3028">jdbc:sqlserver://ussuh23:1433;integratedSecurity=false;databaseName
=eGActiveDB</Url>

to
<User egid="3026"></User>
<Password egid="3027"></Password>

<Url
egid="3028">jdbc:sqlserver://ussuh23:1433;integratedSecurity=true;databaseName=
eGActiveDB</Url>

Make the following changes:

a. Browse to £c£_+HoME\eService\lib\deployment.zip
b. Extract \dataaccess\egpl_ds_connpool_map.xml

c. Make the changes listed in Step 4.

d. Add the updated file in deployment.zip.

Backing up and Restoring Databases

To backup and restore databases:

1.
2.
3.

Take Full backups of active, master, and reports database in the primary server location.
Now, move the backup in a temporary location in the new secondary database server.

Take Transaction Log backup of active, master, and reports database in primary server location (same folder
path where full backup was saved).

Restore all three full backups and transaction log backups with NORECOVERY at the secondary database

SErver.

Updating Files and Databases with New Listener Names

Modifying Master Database

Perform this task on the primary node.

To modify the database server name for master database:

4

Run the following query on the ECE master database:
UPDATE [dbol.LEGPL_DSM_HOST]
SET LCHOST_NAME] = ' <Listener Name>'"
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WHERE LCDESCRIPTION] = 'Database Server'

Replace <Listener Name> with the cluster listener name.

Starting the SQL Jobs and ECE Application

1.

Enable the following jobs on ECE database machines.
EG_OFFERS_SUMMARIZATION_ Active Database Name
egicm_data_cleanup_job_Active Database. Name
egicm_reindex_active_job_Active Database Name
egicm_reindex_reports _job_Reportg_ Database,_Name

egut_async_index_create_/Active Database Name

©c 0 0o O O

egut_async_index_create_ Reports_ Database, Name
populatesmy_Reports_Database Name

Start the ECE application. See “Starting ECE” on page 103.

Updating Finesse Files

The Desktop Layout gadget in Finesse points to the ECE web server in the installation. If you are using a load
balancer, after converting the deployment to HA, you must update the layout to point to the load balancer.

To update the Finesse layout settings:

1.
2.

Launch the URL: https:// Finesse Server Namel cfadmin. Login as a finesse administrator.

In the Desktops Layout section, locate the node for ece.xml. In the value, replace the web server name
with the host name of the load balancer used for ECE web servers.

For example, change:

<gadgets>
<gadget>https://ECcEWebServerdomain.coml system/templates/finesse/gadget/agent/ece.xm
L</gadget>

</gadgets>
to
<gadgets>

<gadget>https://ECELoadBalancerdomain.coml system/templates/finesse/gadget/agent/ece
.xml</gadget>

</gadgets>

Save the changes.
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Converting Existing Distributed Server Installation to

HA

This section helps you convert your existing distributed server installation into an HA installation.

Existing installation and VMs:

4

4

>

4

4

4

4

VM-1A: File server

VM-2A: Database server (active and master databases)
VM-3A: Database server (Reports database)

VM-4A: Messaging server

VM-5A: Services Server

VM-6A to VM-10A: Application server

VM-11A to VM-15A: Web Server

Acquire New VMs for Side B:

»

4

4

VM-1B: File server (Windows Distributed File System Node 2)
VM-2B: Database server (active and master databases)
VM-3B: Database server (reports database)

VM-4B: Messaging server

VM-5B: Services server

VM-6B to VM-10B: Application server

VM-11B to VM-15B: Web Server

Converting Existing File Server to DFS

Setting up Distributed File System (DFS)

4

Install and Enable DFS Namespace and DFS Replication roles and features on VM-1A and VM1-B. For
details, see “Appendix A: Distributed File System Configuration” on page 155.

Updating Files to Use DFS

To update files on original ECE server (VM-1A) to use new DFS location:

1.
2.
3.

Browse to £c£_+oME\eService\bin\platform\windows
Open the following files in a text editor: egainstart.bat and egainstop.bat files.

Locate the property env.fs.shared.location in both the files and change the value to point to the new
DEFS location. For example, the property will look like SET
env.fs.shared.location=\\egeng.info\DFS1\ECE\eService
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Converting Databases to SQL Server Always On Configuration

» Perform all the tasks listed in this section: “Converting Databases to SQL Server to Always On
Configuration” on page 174.

Installing Second Messaging Server Component
» Install the new messaging server component on VM-4B. While installing:
O In the Installation Options window, select Messaging Server.

O In the File Server Parameters window, provide the new DFS location.

Installing Second Services Server Component

» Install the new services server component on VM-5B. While installing:
O In the Installation Options window, select Services Server.

O In the File Server Parameters window, provide the new DFS location.

Installing Additional Application Server Components

» Install the new application server component on VM-6B to VM10B. While installing:
O In the Installation Options window, select Application Server.

O In the File Server Parameters window, provide the new DFS location.

Installing Additional Web Server Components
» Install the new web server component on VM-11B to VM-15B. While installing:

O In the Installation Options window, select Web Server.

O In the Application Server Parameters window, provide the Application Server name.
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